How to login as root when root password is not in sudoers in Ubuntu 10.04 on cubox?

Bob Skinner April 10, 2013

Every time I try to update, change the time, apt-get, it asks me for root password, only to find out that root is not in the sudoers file. I password as mine and it says wrong password. So how the heck did I log in with my password in the first place?

  1. Bob Skinner
    June 19, 2013 at 5:04 am

    I gave up with all that. I login as root and stay as root, I did manage to put a user in but some where some thing crashes and I never have foond out what it is that crashes, so staying with root you have to be very carfull but at least it does not crash.............
    Ok Cubox is a plug pc that is made in Israil it has its own version of linux, its a bit like Raspberrypi but alot more complicated..
    Ubuntu is installed manually via pp or by the cubox installer which installes a few differant types of linux headless or ui desktop, it did say there was an android OS but that is not the case.
    The OS is installed either by usb, which really is the web install ie it gets downloaded from solidruns website and installed there and then or as I have said by pp from a main pc.
    It starts as root in other words you are sudo from the start and nothing is entered no password no nothing its in your face root every window you open it warns you NOT TO ANYTHING SILLY.
    Nothing at all is like linux on the does everything for you , ok there is another user already installed called cubox......pass cubox but that is not in the sudoers file so being root login seems to work for me,

  2. Amichai Rotman
    June 18, 2013 at 9:46 pm

    It seems you are confusing between the product name and the user name. When you use the Distribution Installer to install Ubuntu, it starts a standard Ubuntu installation. Near the end it asks you for your name, password and either to encrypt your /home partition. Skip the encryption.

    Now, open a terminal window (CTRL-ALT+T) and enter:


    Just like that, all in one word in small letters.

    That will tell you what's the name of the user you used to login.

    There is no need to mess with the sudoers configuration file and to login or enable the root user!

    All you need to do is add your user (found by the whoami command) to the sudo and adm groups.

    First, lets find out what groups are you a memeber of already:


    where username (without the brackets) is your user name,

    Take a look which groups are on the list. Except your own group, you should see the sudo and adm groups in order to be able to run apt-get commands.

    If these groups are not listed, lets add you to them:

    usermod -a -G sudo, adm

    Run the id command again to make sure it got done.

    If it did, log out and then back in again, or just restart the Cubox.

    Good Luck!

  3. Jeffrey Wilson
    June 6, 2013 at 10:12 am

    Open a terminal and type or paste this command in sudo passwd root .
    You'll be prompted to type in a root pass word afterward logout and log back in as root.
    Or if your prompted for root access that what type in.

  4. Bob Skinner
    April 13, 2013 at 6:07 am

    Lol never thought about that, could be not me having fat fingers but a dislexic programmer lol.
    I shall try that sunday as the mrs has banned me from that pc for a coupke of days lol
    I have tried root but dah ....but not toor
    Have tried root, 'root' ROOT, cubox, CUBOX, cubocs, my password, solidrun, SOLIDRUN,
    Could it have anything to do with the monitor on a differant hz or something, I have tried 2 differant monitors one does flash black at me when the cubox gets very buzy but is stable most of the time., but what would that have to do with a password. That is JUST a thought, I do want to work this out and the web is not giving me the answer.

  5. Bob Skinner
    April 12, 2013 at 6:26 pm

    Arrrrrr now there lies the situation at fault lol cubox is a plug pc in other words its beep beep small like raspPI but in a box already. The distro is on whats called a u- boot installer
    It does all the downloading and install for you, al, you have to do is linux is simple to connect to web simple to find and everyone works together to make the things...........but and thats a big but, for some reson it will not accept the password for root which is ....cubox, so is normal login for the first time , suppose it was made simple for newbies, but this newbie cannot get past the silly su or sudo as the password...........cubox (both normal and root) it does not exist apparently, no one on either the place where I bought it or the the place that built it has been able tocome up with an answer to this very very newbie, its alright saying type this type that but how do you find the file and what do you type.... th tas the question I suppose, I love linux to bits but hey some times its that root password that gets me.

    • dragonmouth
      April 12, 2013 at 9:33 pm

      Have you tried "root" or "toor" as the password?

  6. Bob Skinner
    April 12, 2013 at 12:02 pm

    Nothing worked, I even tried reinstalling and the same came up again with oeut changing any passwords just logging in as cubox with the password as cubox, both root and user are the same login and password on the initial booting. You have to add a user, but cannot even do that as I need the root password, which is cubox, but its not in the sudoers file, if I knew how to put it in I would go ahead and try but again you need a seconroot password to change the file.i have thought about trying to change the file on my main pc but what to change it to I cannot find anywhere on the web.

    • dragonmouth
      April 12, 2013 at 2:30 pm

      How are you installing Ubuntu? Are you doing an Automatic or a Custom install?
      Automatic = installer does everything for you
      Custom = you provide the options

      Did you reformat your hard drive to make sure it is blank, before attempting to install Ubuntu again?

      Where does the user and password of "cubox" come from? That is not a default password for any distro that I know of.

      Are you sure that the user and password you provide during the install is actually "cubox"? Is it possible you included a space somewhere? Or maybe one of the letters is capitalized? Linux is very finicky when it comes to lower & upper case. "CAT" is not the same as "CAt" or "Cat" or "cat".

  7. Bruce Epper
    April 11, 2013 at 3:47 am

    When installing Ubuntu-based systems, the user account created during installation is added to the group sudo and the root account is effectively disabled. Any other users that are added later must be explicitly added to the sudo group if you wish to allow them to execute commands as another user. So, if you are not using this initially created user, you will not have the required privileges to execute commands through sudo.

    As far as the incorrect password message when authenticating a sudo command goes, you should take that at face value. The password simply does not match for the currently logged in user. Perhaps you used the wrong password or in some way fat-fingered it.

  8. dragonmouth
    April 10, 2013 at 12:40 pm

    Check out the following HOWTO about sudoers:

    To check and/or update your sudoers file use the command

    sudo visudo

    • Bob Skinner
      April 10, 2013 at 5:01 pm

      parse error in /etc/sudoers near line 10
      no valid sudoers found, quiting.
      nearly but not quit
      some answer it gave me lol near....whats near its either is or its
      seeing as you cannot go into that file
      thanks for the reply though it was worth a try for me.

  9. Mike
    April 10, 2013 at 10:55 am

    By default "root" doesn't really have a password on Ubuntu. Basically you do everything via sudo and your user password. Same on GUI level.

    Also root doesn't need to be in sudoers as it already has all the privileges necessary. Sudoers contains users which are allowed to perform commands on superuser level via the command "sudo" (superuser do).

    If you do "sudo apt-get updates" your user password should be enough to perform the command.

    • Mike
      April 10, 2013 at 10:59 am

      Sorry, my mistake – root is usually in sudoers as "root ALL=(ALL) ALL".
      Anyway, Ubuntu doesn't allow the root user by default, it's deactivated like the "administrator" user on Win7&8.

      You perform everything via "sudo"

    • Bob Skinner
      April 10, 2013 at 5:06 pm

      I wish sudo would work but NO its either wrong password or I do not have the privalages, depends whether its in the terminal or in changing a UI, Thanks for the answer though,
      I uise the password cubox which is the root and user password and i Have tried my password, its a strange thing this ere cubox OS

    • Bruce Epper
      April 11, 2013 at 3:24 am

      Mike, that's a user specification entry in the file which signifies that the user root can run any command on any computer as any user. The very last part is why root is in the file - so they can run these commands as another user instead of root.

      There should be a similar entry for the group admin (specified as %admin) and the group sudo ($sudo) as well with similar qualifications.

      BTW, the command should not be though of as "superuser do" as many people assume, but "substitute user do" as it enables a user to run commands as though they were another user or a member of a group they do not belong to. And, yes, there are instances when the user root may need to run a command as a user with lesser privileges.

Ads by Google