How do I unbrick my Xolo X9000 Android phone?

Anonymous October 29, 2013

I have bricked my Xolo x900. It’s running an Intel Atom motherboard, and obviously Android.

I went through some pages asking to enter “recovery mode” but after entering into it, the Xolo symbol appears and later a different color screen appears.

What can be done??

  1. Dalsan M
    November 1, 2013 at 6:11 am

    http://www.modaco.com/topic/362277-please-help-xolo-x900-big-trouble/ Try the suggestions here. You will need a micro HDMI to HDMI cable and a tv or monitor with HDMI to see if you can work with it. There are other suggestions to try, as well.

    • Gunjan K
      November 8, 2013 at 10:39 am

      I did what the post says and its working but it restarts automatically after a min or so...

    • Gunjan K
      November 8, 2013 at 5:49 pm

      i did what the post says and the phone has started but there is a problem....its restarting itself in every min or so...what should be done??

    • Dalsan M
      November 8, 2013 at 9:16 pm

      You would need to factory reset the phone, then reinstall the operating system. You need to download and transfer the update.zip file over to your phone from here, and follow the instructions on how to install it.

    • Gunjan K
      November 9, 2013 at 7:26 pm

      no use it say signature failed installation aborted

  2. Dalsan M
    October 30, 2013 at 10:57 pm

    Try installing the ICS update from here: http://www.trickytweaks.com/update-intel-lava-xolo-x900-to-4-0-ics-official-firmware.html. This should allow you to use your device again since the system files became corrupt.

    • Gunjan K
      October 31, 2013 at 8:12 am

      i had rooted the phone and also installed costom rom...i tried to update over air and this thing happened....i cant even enter system recovery mode what shoud i do??

    • Gunjan K
      October 31, 2013 at 8:15 am

      the device is detected by my system and yes the system memory has got currupt...plz suggest something i took it to service centre and they said motherboard has gone....but i know its proper...just need to reinstall original ics files...how do i do that..

Ads by Google