How do I unbrick my phone DIY-style?

Cristián T December 9, 2013

So I think I bricked my Verizon Samsung Galaxy S III (SCH-I535) and I don’t really want to send it to JTAG services since I don’t like relying on customer support for fixing my things. It’s not that I don’t trust them, it’s that I like to learn how to make my own repairs. I’ve never really unbricked an Android phone before so I’m wondering how exactly I’m supposed to do it. Help would be greatly appreciated.

  1. Frank P
    December 10, 2013 at 10:52 am

    you do know that "brick" means it won't charge, won't switch on and its completely unresponsive.

    if you are stuck in bootloops, flash a new rom on to it. otherwise you may be looking at a list of possible fixes. try and be more accurate, other than saying it's bricked.
    goodluck and hope you get it fixed ;)

    • Dalsan M
      December 10, 2013 at 3:13 pm

      // This is the important information needed to understand the OP's situation. Phone does not turn on, no lights of any kind light up when plugged into the charger. We don't know if the red led power light turns on if the charger is plugged into the phone with the battery taken out of the phone.

      If the red led light turns on with the phone plugged in while the battery is taken out, it could mean that the phone is hard bricked or the chip that tells the phone the battery stats is fried. The latter is somewhat common with all versions of Samsung Galaxy 3 phones, and has been mentioned to occur with the Galaxy Note 3 and other Samsung devices.

    • Frank P
      December 11, 2013 at 7:22 am

      Still doesn't say much, did he / she unlock the bootloader, did they flash a new bootloader etc.
      I checked out the omni rom and not much mentioned there either.

      I flashed a Note once and in it they said leave it plugged in for about 20 minutes charging. (just because we can't see anything happening, doesn't mean nothing is happening.) left it plugged and it came up after 30 minutes. maybe the battery pull was to early?

  2. Arun Shekar
    December 10, 2013 at 9:48 am

    I use flashtool for recovering my phone
    It works well on Sony phones...
    I'm not sure about Samsung

  3. SirProudNoob
    December 9, 2013 at 10:08 pm

    You can usually use Odin to flash the phone after putting it into download mode. Instructions for restoring to stock are all over XDA. I've screwed up my SCH-I535 a gazillion times and the only serious damage was to my microsd slot for pulling a card out without disengaging the lock.

  4. Robert Wm Ruedisueli
    December 9, 2013 at 10:07 pm

    Most bricked Samsung phones can be debricked using Heimdal or Odin.

    You can search Google for them, along with the ROM images you need to debrick the phone.

    • Dalsan M
      December 10, 2013 at 3:19 pm

      OP mentions symptoms here: // These symptoms point to either a hard brick or fried chip that tells the phone the stats of the battery (if this chip does not work properly, then the phone does not know if a battery is inserted).

      The method you mention is great for a soft brick, but cannot help in the OP's situation since the phone will not turn on, nor will any lights come in with the charger plugged in.

  5. Kypros V
    December 9, 2013 at 9:16 pm
  6. Hovsep A
    December 9, 2013 at 4:09 pm

    what you did exactly to brick Verizon Samsung Galaxy S III (SCH-I535)?, it is important to find out so that others help you

    • Cristián T
      December 15, 2013 at 10:02 pm

      I don't know specifically what I did to brick my phone, and as I have stated before, all I do know for sure is that my phone stopped working after I tried installing Omega ROM onto it. I kindly appreciate your help.

  7. Harry B
    December 9, 2013 at 12:18 pm

    It's hard to help you without more specific details about how you bricked your phone. I'd recommend you check out XDA, it's a goldmine of information about stuff like this, I'm sure you'll find multiple threads on there about un-bricking phones that will help you.

    The website is:

    • Cristián T
      December 15, 2013 at 10:00 pm

      All I know is that I tried to load Omega ROM onto my phone and it basically stopped working. It wouldn't turn on and no battery icon was shown when plugged in to a wall.

      Also I'd prefer not to use XDA for solutions unless you have a specific thread that I should take a look at that is directly relevant to the problem I am experiencing with my phone, and the solution used to repair it. This is because if I start posting more threads while having to keep an eye on this particular one, things can get very confusing very quickly.

Ads by Google