How do I resolve a Windows 7 network connection shutdown bug?

Anonymous October 10, 2013
Ads by Google

This is the first time after almost a year now since I have had this issue. I never asked for help before because:

  1. I could live with this, but its very annoying.
  2. I have no time to write this long post
  3. I try be as much specific about problem as possible.

Operating System: Windows 7 Home Premium SP1 x64.

Hardware platform: Laptop.

In short: NETWORK CONNECTION LOSES INTERNET AFTER A WHILE (this is 100% Windows, not the modem’s fault).

More details: After turning on the computer, I can use the Internet easily. All works fine, until 3 to 5 hours passes and suddenly I notice that something’s wrong. The Internet is connected, but not functioning as it should be. For example: Facebook – if there is more then one tab open on Facebook, one tab loses connection to chat messages and stays offline, meanwhile the second tab can still perfectly receive messages in Facebook chat from friends.

BUT, if I hit SHIFT+F5 to refresh a page, all I get is just few pictures of Facebook and the remainder of the page won’t load. Chat won’t work anymore. If I hit SHIFT F5 again, it wont load anything at all. It seems like the Internet browser (Firefox in this case) loses some kind of authentication to be able to receive data, slowly. But it doesn’t stop here. This happens to every single app on my PC at that point of time, no matter whether I’m using Chrome or Skype, they all start to lose data little by little.

Things get even more strange: If at that time I’m connected to my Android device in USB debugging mode to my laptop, the developer console “Eclipse” loses connection to my Android device, at same time as the Internet cuts out. However, none of my other USB devices that are connected in standard mode, such as USB flash drive, keyboard, mouse, etc… They still function perfectly.

The problem appeared probably after one hard laptop shutdown, when you hold the power button until it shuts off. Usually this wont effect the PC, but.. sometimes it will, especially if the shutdown occurred while registry code was being written and there was no backup.

At first, days after the Internet connection problem occurred, I tried using System Restore, which didn’t help. Then I kept restarting the PC, which allows the Internet to temporarily work for another 3~5 hours. This got annoying and so I started to look for solutions.

I thought I found a solution but it seems like its just temporary one, which gives just a few more hours of Internet. What I found: I have to go into the services app, and STOP “Internet Connection Sharing ICS” this will make the Internet work again for about 20 minutes, then I can go back to services and start and stop the service, resulting in an extra 1-2 hours of Internet. Also my USB debugging device starts to function to! It’s weird, because all I do is kill the INTERNET sharing service. Unfortunately, after the Internet is gone third time,  nothing helps. If I restart the service, nothing happens. At that point, no page will load and I have to restart my PC.


  • Internet starts to behave oddly after a few hours of use.
  • Internet connection icon in notifications displays a red X, but if you press on it, it shows that it’s connected to the Internet.
  • Network Sharing Center -> Change adapter settings: Shows nothing, as if there’s no network devices installed. This issue occurs regardless of how I’m connected to the Internet, such as 4G, dongle, etc…

Things I tried:

  • Reinstalling network adapter.
  • Repeatedly restarting the network connection sharing service (and many other services).
  • Removing the laptop battery.
  • Running Windows network troubleshooter.

Also noticed this: Processes running the NlaSvc and Netprofm services (using ProcMon) and noticed that both were denied read/write access to subkeys within the HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList hierarchy.

The processes were running as NetworkService and LocalService, respectively, so I tried adding full access for these service accounts to the entire subkey mentioned above. This didn’t help.

Also: Network Location Awareness was set to “automatic startup” (the same setting as default) didn’t help.

Now I am out of options. This is really not an easy case to solve. And please don’t suggest reinstalling Windows — this is not a solution! Because I am a graphics designer, my Windows have lots and lots of custom-made apps. It would take me ages to set everything up as it is now.

  1. Oron J
    October 12, 2013 at 11:42 am

    Leaving aside the Android/eclipse problem for the moment, I think you should start by excluding the possibility that the problem is with the router.
    First of all, reboot your router and see if the problem recurs at the expected time. If it doesn't, problem solved (or at least we have zeroed down on it).
    If the problem still recurs after 3-5 hours, test internet from another computer (connected to the same router, obviously). If that works without fault, then the problem is likely to be in your laptop, but if you still have a problem, then it's either with the router itself, or it's an ISP issue.
    If the problem definitely stems from the laptop, it could be a thermal one (that is, the computer has heated up to the point when a contact on the motherboard has worked loose), or it could be that you have a rogue process on your computer. It's difficult to suggest a straightforeward remedy in this case, as there are so many possibilities, but you could certainly scan for malware with your AV and an antis pyware package (I find Malwarebytes Free excellent as a "second opinion" in such cases.
    Another approach would be to study the logs in Event Viewer and see which processes are active just before the failure, and which processes throw errors. This could give you the answer, or at least a clue, as to where the problem lies.

    As for the Android problem, it could be that Eclipse is affected by the underlying problem, or that it depends on DNS functioning properly etc. Try to resolve the internet access problem first, and if you are successful and Eclypse is still misbehaving, let us know.

    Good luck!

  2. Jan F
    October 11, 2013 at 9:45 am

    Well, the red X on the network connection icon usually means that your system was unable to reach the testing destination from Microsoft (

    This can be the case if your modem/router has lost connection, DNS isn't working properly, a firewall is blocking access or your network interface card lost the network connection (e.g. bad cable, low WiFi signal) respectively a bad driver for the NIC.

    So these are your pointers to start troubleshooting:
    - make sure your modem/router doesn't lose connection
    - make sure your clients have a valid DNS and backup DNS server configured
    - make sure your (clients) firewall isn't acting up, maybe deactivate it for testing
    - last but not least update to the latest driver for the NIC (please use the one provided by the manufacturer, not from Microsoft Update)

    As for your USB + Android issue this is either an unrelated coincidence or both may be caused by a damaged motherboard.

    • Jan F
      October 11, 2013 at 11:22 am

      the fulldestination is
      just in case someone tries to open it and thinks there is something wrong

  3. Hovsep A
    October 11, 2013 at 7:44 am

    perhaps power saving problem? try Power Plan in Power Options to High Performance
    go to bios and make sure that lan power save (if you have this option) is disabled

    if all attempts fail then you need to repair Windows.

    How to uninstall Windows 7 Service Pack 1 (SP1)
    reboot and reinstall SP1

    How to reset Internet Protocol (TCP/IP)

    How To Reinstall Windows 7 Without Changing Your Personal Settings, Installed Programs & Drivers

    How to Repair a Faulty Windows Installation Without Reformatting