How do I install CyanogenMod 10.1 on my Verizon Samsung Galaxy S III?

Chris C August 30, 2013
Ads by Google

How do I install CyanogenMod 10.1 on my Verizon Samsung Galaxy S III SCH-I535 running Android 4.1.2?

I am looking for the best and most comprehensive tutorial on how to do this. I’m not exactly sure what it does but one of the video tutorials I was watching for something else says that I need to have CyanogenMod in order to do it.

Another question. What exactly is Gapps?  I’m not exactly sure what it is and I’d like to know a little more about it and perhaps even consider using it.

Thank you so much for taking the time to answer this question.

  1. Susendeep D
    November 8, 2013 at 6:16 am


    You can resolve your question by clicking on the tick button present on the left side of each comment.Click on the tick button of the comment which you found most useful to solve your query and this would mark this question as resolved.

  2. Dalsan M
    August 30, 2013 at 4:41 pm

    Cyanogen Mod is a modified version of Android ROMs. GApps is the whole suite of Google apps including Google Play Store, Music, Books, Search, Gmail, Maps, etc. If Gapps is not installed then it would not be possible to sign in and use the Play Store and most other Google functions that rely on logging in or other apps that are not a properly matching package. Some custom ROMs already have Gapps included in the installation files, but others may not and should state that you must download and install Gapps.

    Rooting your phone must be performed first, normally by using the Odin method and installing a custom recovery, such as ClockWork Mod Recovery. Once a custom recovery is installed, then you would need to have the version of CyanogenMod ROM you wish to install on your external SD card, making sure the installer is in zip format. You would then go into the custom recovery and make a backup of your device (not truly necessary, but if anything goes wrong, you have something to go back to so you can still use your device). Then perform a factory reset through the custom recovery, wiping the data and Dalvik Cache. After doing this, then you would use the custom recovery to install the custom CyanogenMod ROM using the Install from SD function, then install the Gapps zip the same way, if necessary. Depending on the ROM, you may need to change the kernel and other files. Since you have the Verizon S3, you would have to unlock the bootloader first. For a comprehensive breakdown and steps for installing CyanogenMod on your Verizon S3, go here: [Broken URL Removed]. To get the latest version of Cyanogen Mod for your device, go here: [Broken URL Removed] (get the latest stable version because the other versions may not perform properly). If you run into any issues, search here: [Broken URL Removed], and if you cannot find an answer, ask there as well.

    • Chris C
      August 30, 2013 at 8:26 pm

      I think I'm going to have to re-root my phone since a lot of these things have been leading to an error message that says that system software not authorized by Verizon Wireless has been detected on my phone. I know how to work around it but I don't know how to stop the error from occurring. Where can I find a good tutorial that teaches the user how to un-root and re-root my phone, or just stop that error altogether?

    • Dalsan M
      August 30, 2013 at 10:45 pm

      You have to try to unlock the bootloader again using EZ Boot v1.2. More information with a link to the EZ Boot found here: This is not an uncommon issue, and I don't think you have to go through the extra hassle of unrooting and rerooting your phone. You should be fine after unlocking your bootloader properly.

    • Chris C
      August 31, 2013 at 2:51 am

      Alright, so I looked into the link you sent me and I am stuck at the third step, in which I have to actually run Heimdall, which I am running into problems in doing. Every time I try to run it, with or without administrator permissions, it says that a certain file titled “MSVCR110.dll” is missing from my computer. I read the readme file and it says that the way to fix it is by going to the following link to download the Microsoft Visual C++ 2010 runtimes: I downloaded the file to install the supposed runtimes I required on my computer in order to run Heimdall, and after the installation was complete, I receive the same error message, as if nothing has changed.

    • Dalsan M
      August 31, 2013 at 5:36 am

      Which version of Visual C++2010 Redistributable runtimes did you install, x86 for 32 bit or x64 fir 64 bit? If 64 bit version, then uninstall and use the 32 bit version. Check to see if there are any older versions installed as well since it may (not usually) interfere as well. Uninstall the older versions (2008 and earlier) IF the 32 bit version doesn't work. had these suggestions, but for the S4, but it didn't matter since it had to do with Heimdall. Here is a link for the 32 bit version of the Visual C++ 2010 runtimes:

    • Chris C
      August 31, 2013 at 6:02 am

      I downloaded the x86 version. I think I'm actually supposed to get the x64 but I can't find it. I took the precaution to delete all the other runtimes that had already been installed on my computer. Now that I have the link it might be able to work. Thanks!

    • Chris C
      August 31, 2013 at 6:03 am

      Wait... I think you just sent me the same thing as before.

    • Dalsan M
      August 31, 2013 at 7:56 am

      Sorry, it is the same link as you posted. The 64 bit version will most likely cause the same issue that you are having, with the missing msvcp110.dll missing error. I found that the version you actually need is from here:, which is Visual C++ 2012 update 3. I found this information here. Hopefully this fixes your issue.

    • Chris C
      September 1, 2013 at 3:48 am

      alright cool! thank you so much!

    • Dalsan M
      September 8, 2013 at 7:11 am

      Remember to vote and mark your question as resolved if your question has been resolved. Thanks.

    • Chris C
      September 8, 2013 at 11:19 pm

      How do I do that? Last I saw there was a green button that says “resolved” but I don’t see it anymore.

    • Dalsan M
      September 9, 2013 at 12:02 am

      It may have been removed after the new changes. Sorry about that.

  3. Harikrishnan
    August 30, 2013 at 4:15 pm

    Nothing to say...

  4. Hovsep A
    August 30, 2013 at 9:52 am

    Install CyanogenMod 10.1-M2 Android 4.2.2 on Samsung Galaxy S3 AT&T, T-Mobile, Sprint, Verizon, Cricket, Metro PCS & US Celullar
    [Broken URL Removed]
    perhaps can help

    [Broken URL Removed]

    [GAPPS][4.3][ZIP] Latest Google Apps for Android 4.3

    • Chris C
      August 30, 2013 at 7:17 pm

      It doesn't let me download the first part. It says I have a 404 error.

    • Hovsep A
      August 30, 2013 at 8:44 pm

      perhaps this can guide

      if you have widgets then remove them

    • Chris C
      August 31, 2013 at 2:15 am

      I removed the widgets. When I tried downloading the link it gave me the same 404 error message.

    • Hovsep A
      September 2, 2013 at 6:32 pm
Ads by Google