How can I stream media from my laptop to a Netgear adapter via WiDi?

Scott B September 11, 2013

I cannot stream my laptop media to my TV. I have a Netgear adapter, and a Dell XPS L702x laptop, running Windows 7. My Netgear was working fine until i had to install a new router. I’ve tried everything at Intel,Dell,Microsoft support.

I use intel widi to connect laptop to netgear. When I open Widi it sees the netgear adapter but when I go to connect it does not connect. Its been one week of me trying to fix this problem my last resort is the cord ouch. I need tech help.

  1. Scott B
    September 23, 2013 at 4:08 pm

    My PTV is not supported anymore. The firmware is current. All I know is when I added a new router the PTV does not connect anymore.

  2. Kannon Y
    September 20, 2013 at 10:31 pm

    Have you tried updating your Push2TV's firmware?

    What version of the PTV do you have? There's like PTV2000 and PTV3000 if I remember correctly. And the update instructions aren't the best.

    Another option is to update your WiFi device's drivers. Unfortunately, finding the latest WiFi drivers for your device is a huge hassle, since the laptop manufacturer and the WiFi daughter card are usually entirely different companies. The drivers found at the laptop manufacturer's site aren't always the latest drivers.

    • Scott B
      September 22, 2013 at 9:10 pm

      netgear ntv200s yes I updated firmware. You're right about the drivers I think I have the current driver. when I activate the widi software it does see the netgear 200s but when i press connect it tries to connect but then just stops. I have done all the trouble shooting. This issue started when I replaced my router.

    • Kannon Y
      September 22, 2013 at 10:17 pm

      Are you sure the firmware was successfully updated? One of the bugs in the PTV firmware update process is that they don't tell you the zipped download needs to be unzipped. If you activate the update process, it will appear as if you've updated when in fact it's still on the old firmware.

      And it's the unzipped file that you place in the root directory of the PTV, not the zipped file. This is confusing because they don't specify this in the directions and many firmware update processes have no problem using zipped files.

      If you actually did update the PTV firmware, I would try Googling the name of your WiFi device's manufacturer and the model number. Unfortunately, you may need to remove the rear panel of your laptop to get this information. Let me know if you have any problems getting this info.