How can I see or connect to a particular WiFi network?

P J August 20, 2013
Ads by Google

Here’s the deal: I got myself a new internet connection. My ISP provided me their ‘router’ (can do a lot more than providing internet) and have in the user manual asked me to configure the WiFi settings once I successfully set it up via Ethernet. After configuring the network, I am unable to find the network I set up, although other devices of mine can do so. Also, I can see and connect to other WiFi networks at the same time, so no drivers problem.

What should I do in this case? I have tried searching Google but in vain. Is the router blacklisting sites? In that case, do I need to change my MAC address?

P.S.: Please don’t mention ‘rebooting my router’, as I have done so like a million times!

  1. Susendeep D
    November 10, 2013 at 7:02 am


    If you're bale to connect to WiFi network then kindly choose the most helpful comment by clicking on the tick mark icon of that comment and this would mark your question as resolved.

  2. P J
    August 23, 2013 at 8:28 pm

    Sorry for the late replies. I tried to do whatever I can do and managed to connect like one out of a million times. Pardon me for my exaggeration, but this problem has got my nerve due to this. Please see if that's a bug in Ubuntu (which I don't think) or my router's not working properly (which it does for all other devices).

  3. Bruce Epper
    August 20, 2013 at 11:01 pm

    What is the distance between your router and the affected PC? In many cases, being too close is even worse than being too far apart. Directional antennas in some routers and modems add to the problem. I also know of one router that uses DDNS that wouldn't allow a desktop machine to connect wirelessly because it was already using a wired connection to the router. I'll have to contact that client to get the make/model of his router since I don't have any documentation on it (problem solved over the phone so I never saw the device or connected remotely to it or his system).

    • P J
      August 23, 2013 at 8:25 pm

      Well, I have a laptop and when I try to connect to the router, I don't keep the Ethernet connection on. Also, my laptop came with Ubuntu and all the necessary drivers installed and rest of the networks (wireless) can be seen like always and works well too. While I am in this fiasco, all the other devices seems to work normally without a slighest clue of a problem. What should I do to solve this?

    • Bruce E
      August 23, 2013 at 10:33 pm

      Is your wireless network "hidden?" In other words, is the SSID being broadcast by the router or not. If not, turn on the broadcast and see if it connects reliably. By default, most wireless routers are broadcasting. Some devices have difficulty connecting to any router or WAP that does not broadcast the SSID.

      Have you tried turning off your wireless encryption to see if you can connect reliably without it? This needs to be done on both the router and the computer. (The computer should realize it is not encrypted in Network Manager and turn it off for you. We would want to test this simply to rule out an issue with your encryption settings on either device. (I would suspect this laptop would have the issue, not the router since other devices are working properly.)

      Can you use 'iwconfig' to manually connect to the network? See your man pages for the proper syntax to use. If in doubt, reply back here with your specific version of Ubuntu and I'll check my VMs for the necessary command you need to use. (The explanation of everything may end up being kind of long.)

      Le me know the results of these items and we can proceed from there.

    • P J
      August 24, 2013 at 12:27 pm

      Thanks for the reply Bruce. Well, I had set the network to not broadcast the SSID (after reading an article in MUO :) ), but I reverted the setting later. The reason was that I used 'Connect to Hidden Network' option to connect to my network and it failed. But after setting it to broadcast the SSID and no longer remain hidden, I tried to connect other devices and they connected flawlessly, but my laptop didn't. So I changed the SSID and rebooted the router, and later it worked! But after restarting my laptop the next day, it was not connecting. After restrating the router for multiple times, while keeping the WiFi in my laptop on, it DID connected again.

      I can't figure out how to connect using iwconfig (that's a shame!), but since I am connected right now (thank God for that!), and when I enter 'iwconfig eth1' (my wireless card's 'eth1'), it shows that I am connected and displays the ESSID, MAC address, and other stuff.

      I am running the latest LTS (12.04) version of Ubuntu which is OEM-modified, as it came installed with my laptop with all the drivers and stuff installed.

  4. Oron Joffe
    August 20, 2013 at 4:25 pm

    P J, I'm not entirely sure I understand the situation, so let me put it in my own words, and correct me if I'm wrong! You appear to say that other devices you have can see the WiFi network you created, but not your PC?
    If that's the case, one possibility would be that the router's WiFi is using a standard your PC doesn't support (such as 5GHz which Jan mentions). So first of all, write down the WiFi standards supported by your router and by your PC, and see if everything matches.
    A second possibility (a trivial one, but must be mentioned!) is that for whatever reason, you're out of range! Try to move your PC about and see if it shows up.
    If that's not it either, you could try following the guide on

    • Justin Pot
      August 20, 2013 at 4:56 pm

      Many desktop cards for receiving signal are weak, and many ISP-provided routers are as well. Combined this could be why you're seeing other networks and not your own. How far is your computer from your router?

    • P J
      August 23, 2013 at 8:23 pm

      Well, thanks Oron and Jason for the replies. Oron, For the first part of the answer, as I have mentioned in a reply made earlier than this, both my laptop and the router are less than 2 months old (my router just a couple of weeks old.) and they support the WiFi standards pretty well.

      For the second part, even though I try to connect while keeping my laptop just aside the router, it still DOES NOT work.

      FYI, I may connect to the network like once out of so many times and the next time I reboot, bam! It's gone!

  5. ??????? G
    August 20, 2013 at 11:11 am

    Sorry, please, cancel that. Wrong answer, I didn't read your question carefully enough, I'd have deleted it if I could... I'm sorry:(

    • P J
      August 23, 2013 at 8:19 pm

      Anyways, my reply was wrong too.

  6. ??????? G
    August 20, 2013 at 11:05 am

    It depends on the type of device you are using. As far as laptops are concerned (I'm not using other types of devices), here is how it goes: check if your laptop features a built-in wireless adaptor (all modern laptops do). If you are connecting at a public place, click on the wifi icon in the bottom-right-hand corner of the screen and view the list of available networks. Ask the admistrator for password (some caffees want their clients to order a food or a drink prior to getting passwords), then click on the network name in the list. If you are connecting to your home network, your provider must have given you the password along with the router. Enter the password and set up connection.

    • P J
      August 23, 2013 at 8:18 pm

      Well, my laptop has a wireless adaptor built-in and can connect to any WiFi connections out there. I can also connect to the home network but that happens like one out of a million times.

  7. Jan F
    August 20, 2013 at 10:58 am

    Make sure that the router and the device are supporting the same wireless standard and band. If your router is for example transmitting on the 5GHz band but your device only supports 2.4GHz it will not be able to see and connect to it.

    • P J
      August 23, 2013 at 8:17 pm

      Thanks for the reply. Well, both my router and my laptop supports WiFi 802.11 b/g/n networks as well as both transmitting bandwidth. Also, sometimes I am able to connect, while most of the times I can't.

Ads by Google