How can I resolve Windows 8 compatibility issues on my Dell?

Utkarsh Rao March 11, 2013
Ads by Google

I have a Dell Inspiron 14R running Windows 7 Basic 64-bit and I bought a Windows 8 Pro upgrade disc recently. However, when I attempt to install it (I chose the upgrade option) it shows me some compatibility issues. I resolved 2 out of 3 of these, but the third one is asking me to uninstall Intel PROset Wireless something or other to continue the installation.

However, Dell has made this a system app and doesn’t allow me to uninstall it. I’ve tried several methods, none of which work. Is there a way to get around this problem? I’ve been eagerly waiting for Windows 8 and would like to upgrade as soon as possible.

    March 25, 2013 at 12:23 pm

    Hello, there should be an option to uninstall the software in two places:

    Check under the Dell heading in the programs. All the programs/softwart installed by Dell should show there. Select the one you want to uninstall and there should be an option to do so there.


    You can find the option in the add/remove program. Just find the Dell program/software and uninstall there.

  2. Nevzat Akkaya
    March 11, 2013 at 10:43 am

    If the latest drivers from the Dell's site does not solve the problem, you can use Intel Driver Update Utility here : One way or the other, you should update your network device drivers so that Windows 8 incompatibility is gone.

  3. Alan Wade
    March 11, 2013 at 7:48 am

    Can you list the methods you have tried? I will save us from suggesting them. Have a look at this link, it may help.

  4. Bruce Epper
    March 11, 2013 at 5:37 am

    The Intel PROset Wireless is the driver and control package for the wireless adapter in the system. You should be able to uninstall it just like any other application. The Win8 installer should have the proper driver for this specific set of wireless adapters, so uninstalling it should not have any adverse effects on the upgrade process.

    If Dell is somehow blocking the uninstall, what is the message that you are getting indicating a failure to complete the unistall operation? I have removed this from systems (including Dell) in the past without any problems at all.