How can I remove persistent write protection from a flash drive?

John Jullies Palma February 27, 2013
Ads by Google

Two days ago my flash drive’s files were corrupted so I reformatted it. But then when I copied a file it said the disk is write protected. I removed the drive, re-inserted it, then tried to write the file again, which seemed to work – but then I got the error again and my files showed up as zero kilobytes! I tried reformatting again, but still get the write protection error. I’ve Googled this problem and tried everything to remove the write protection or/and format the drive but nothing seems to work. I did the regedit, the diskpart, and installed a bunch of tools no luck. some of the tools won’t detect the drive. pls help.

  1. Suman Acharya
    April 7, 2013 at 4:06 am

    Hi John!!!
    sorry i am not helping you. I am ALSO HAVING THE SAME PROBLEM and there are thousands, if not millions of user having the same problem BUT NOT A SINGLE PERSON WITH A SOLUTION, i know because i've tried almost all the solution the so-called techs on the web suggests.
    i've tried editing registry, diskpart (Clean, Format, Attributes), FreeDOS, Linux live cd, mUSB fixer, MAC OS, windows xp, vista, 7, 8 and the most easiest answer try the write-protection lock.....
    now i concluded that only 2 or 3 out-of 100 write-protected usb can get its health back (if the user is lucky)....

  2. Etech Etech
    February 28, 2013 at 9:38 pm

    Did you try chkdsk? (You'll need to run it from the command line)

  3. susendeep dutta
    February 28, 2013 at 3:44 pm

    Write protection can be removed by using the tool mentioned here -

  4. ha14
    February 28, 2013 at 12:25 pm

    if you have windows restore point you can revert back to before your USB key problem just to see it is not your operating system causing this problem.

    54 - How to Fix Write-Protected Read-Only Disks
    try RMPrepUSB

  5. Imesh Chandrasiri
    February 27, 2013 at 11:04 am

    Try to conect it to a linux distro machine and check it in that pc. If it gets detected and mounted successfully format or take a look at the file structure. delete any unidentified files ( possible virus ) from the disc.

    if you are using windows use a tool called low level formatter. and format the device. This actually worked on several devices which I had. if this too doesn't work, there might be an error in the device firmware. try contacting the manufacturer.

  6. Rubis Song
    February 27, 2013 at 10:53 am

    Your flash drive might just be damaged. If you try to open it using another OS, such as Linux and still have the same issue, you can consider that the device has completed its life time.

    • John Jullies Palma
      February 27, 2013 at 2:36 pm

      then why can I still see it and open it?

    • Suman Acharya
      April 7, 2013 at 4:20 am

      not only see, we can read it too!!!

  7. Sean Graham
    February 27, 2013 at 10:10 am

    Can you tell us what the brand and model is?

  8. ha14
    February 27, 2013 at 9:39 am

    did you tried on another windows? or MAc or LInux?

    if you have linux boot cd, see if your usb key will be detected.

  9. Tanveer Ahmed
    February 27, 2013 at 5:42 am

    click start click to open on my computer you should see your usb drive E: right click select properties there will be an array of options select the sharing tab option then advanced sharing make sure you have a tick in the share this folder box then click permissions make sure you have all 3 boxes ticked full control changes and read in windows 7

    click start control panel user accounts click on the administrators account if you have made one or you will have to create one in windows XP

    click start right click on my computer select open
    Right click the icon of your Hard Drive (It should be C:/ or something)
    Click Properties in the menu that comes up
    Click the Sharing tab
    Click permissions
    And finally, click Allow next to Full Control.

    • Bruce Epper
      February 27, 2013 at 9:08 am

      "click start control panel user accounts click on the administrators account if you have made one or you will have to create one in windows XP "

      If they aren't already an administrator, they cannot create an account of any type. And there will ALWAYS be at least one administrator account on the system. The default account created during initial installation is an administrator account. Creating an additional administrator account only weakens the security profile of the system in question.

      Also sharing the system drive is always a foolish move and should NEVER be done (instructions starting at "Right click the icon of your Hard Drive..." to the end).

      Your instructions only make the user's machine more vulnerable to attack.

  10. Choon Khai
    February 27, 2013 at 5:09 am

    Some flash drive have a push lock button on its body (just as same as SD card), probably you missed that out. Try checking it out.

    If that don't work, right-click on the drive and go to properties, and then click the "Security" tab. You can click the group "Everyone", lower down you could see the permission with allow or deny option. Usually all option is allowed except "Special Permission", edit accordingly if your options are different.

    • John Jullies Palma
      February 27, 2013 at 2:35 pm

      tried that. tried that.

    • Choon Khai
      February 28, 2013 at 2:51 pm

      I just tried reformatting my flash drive an hour ago, halfway I cancelled it. After that I got the write protection error too. Then, I tried going to safe mode to format it, I was able to format it. Try that and see whether it works or not. Try tick and untick the option "Quick Format" as well.

  11. Bruce Epper
    February 27, 2013 at 3:34 am

    If you are attaching the drive to a hub (especially if it is not a powered hub) or front-panel connector on the computer, try one of the connectors on the back panel and see if the problem persists.

    • John Jullies Palma
      February 27, 2013 at 2:34 pm

      no i'm not attaching the drive from a hub. i actually tried it in 3 different pcs. same problem.

Ads by Google