How can I recover a deleted Raid 1 partition on my 3 TB HDD for free?

Jacob T July 15, 2013
Ads by Google

I was having MB problems so I reset my CMOS. It was really early in the morning and I did it without thinking because I was ticked off. After I booted, I was still able to access my Raid, then it created a memory leak and filled 15.9 GB/16GB of RAM. After I forced a reboot, my Raid was gone!

I know it knew it was there and knew how to access it because I was able to access my files before the memory leak.

I downloaded testdisk and it can find my files on both Raid 1 drives, but I can’t recover the partition. Every time I download software it says it’s free, but it’s not and it’s driving me insane and I’m wasting time I don’t have. Does anyone have any suggestions?

I have all my program licenses and games for my gaming PC on those drives. I don’t care about the games because I can just re-download them. I have been meaning to reformat, so I probably will reformat my SSD soon, but I want to see if I can fix this first.

I have also tried Ubuntu Linux to recover the partitions, but no success. Thanks very much for your help.

  1. Phill D
    July 18, 2013 at 11:23 am

    Try hard disk data recovery software from to recover your lost or formatted or deleted partition of your hard drive.

  2. Kannon Yamada
    July 16, 2013 at 3:26 am

    For me EASEUS is the silver bullet of RAID partition recovery - I didn't know that GPT wasn't supported though.

    Have you tried RecoveryWizard?

    • Jacob T
      July 16, 2013 at 4:57 am

      No not yet, I saw on the download page that there is a 2 GB file recovery limit then I have to pay $70. But I may come back to it as a last resort to recover as much as I can.

  3. Kannon Yamada
    July 15, 2013 at 7:41 pm

    Wow, that's irritating. I'm sorry for your problems.

    When you reset your CMOS battery, it should have set the BIOS back to a non-RAID mode. I think you need to enter into BIOS and set your drives from SATA (AHCI or whatever) back to RAID mode. Hopefully it will then detect your RAID array.

    If not, try reading these threads:

    They clearly identify how this precise issue is fixed. Good luck!

    • Jacob T
      July 15, 2013 at 9:41 pm

      I tried EaseUS Partition Recovery this morning but it says unsupported disk and it doesn't support GPT. Since my HDD is 3TB I set it up to use GPT. Do you know of a version that would support it? I have confidence in this program because it is the only one that sees it in 2794 GB instead of 801 GB. And I tried turning RAID back on in my motherboard but was afraid to open up the settings because I thought it would erase the entire disk. and when I booted it, my files were still there, then it erased it while I was using it. So I am starting to think there would be no harm if I tried to resetup the raid since the partitions are gone. But I have been careful with the drives and made sure I didn't write anything to them.

  4. Susendeep D
    July 15, 2013 at 3:26 pm
  5. Chris M
    July 15, 2013 at 3:16 pm

    You can access the files, and you were going to do a reformat soon anyway, why not jsut copy the files to another drive and then reformat? (Or am I missing something in there?)

    • Jacob T
      July 15, 2013 at 9:12 pm

      I can't see anything on the drive. Windows says the drive space is unallocated and testdisk can find the partition and read the files but when I told it to copy all the files it stopped after a few movies. I tried to tell it to undelete the partition and it said it did but it still isn't recognized by windows. I am trying to find a free program that will either recover my files or undelete the partition. Most of the space is filled with music, movies, and music videos and I don't need to recover those. I just need my basic files like my school work, PDF archives, pictures, etc. all the programs that will do it cost like $80 and its not worth it to me. If I don't find a solution I will probably just give up.

    • Chris M
      July 16, 2013 at 5:05 pm

      What about trying recuva. Piriform is the maker (same company as CCleaner and Defraggler) I'd give that a try. Iffin that doesn't help, then I don't know.

      Good luck, mate.

  6. Hovsep A
    July 15, 2013 at 10:25 am

    partition find and mount?

    • Jacob T
      July 15, 2013 at 9:13 pm

      I tried that this morning but it didn't find any partitions. But thanks very much for the suggestion, I will keep scanning it tonight to try again.

Ads by Google