How can I re-install and boot into Windows 8 after installing Linux Mint?

shaurya gupta March 2, 2013
Ads by Google

I had a dual boot system of Windows 7 and Windows 8. Windows 8 was installed after Windows 7.

I wanted to install Mint and removed Windows 7. However, looking through forums, I came to know that I’d need to move the boot loader from Windows 7 to 8. I tried to do that using EasyBcd, but had no success. So I just installed Mint using a live USB. I installed it on the Windows 7 partition by simply deleting the partition during the Mint installation.

When I deleted the partition and further tried to install, it would give me a message that “dev/sda2 won’t be accessible if mounted, until the PC is restarted”. I pressed next, but the installer froze, although rest of the live Linux Mint was working perfectly. After trying for two or three times, I finally installed it.

And now on restarting the system, I had to accept the fact that I had done it all wrong because my Wndows 8 won’t boot, Mint booted automatically. Grub loader did not appear, too.

Now I tried to use gparted in the Mint operating system. I have not tried using gparted on live media. When I used gparted, it shows just one partition that has no name and is unallocated. This unallocated space was the space – “HDD space – minus – mint partition space”. It was not showing other partition including the Windows 8 partition. However, when I opened file manager, Windows 8 partition as well as other partition did show up and I was able to mount them and use any file. All the important files, I already uploaded them to Skydrive. I tried to install Windows 8 again using a bootable USB, but it said that hard drive was locked.

I don’t need any of the files present on my HDD. So, please MakeUseOf team as well as MakeUseOf readers, help me get out of this problem. Thanks a lot in advance because I know you guys will help me.

  1. Gaurav Joshi
    June 3, 2013 at 3:21 pm

    in linux mint type in terminal
    sudo apt-get install os-prober
    sudo os-prober

    if this doesn't help it may problem because of UEFI systems to solve that do the following
    install grub boot loader and add manual entry for grub type in terminal
    sudo grub-install /dev/sda
    Append to /etc/grub.d/40_custom

    menuentry "Windows 8" {
    set root='(hd0,gpt1)'`
    chainloader /EFI/microsoft/BOOT/bootmgfw.efi

    Warning: gpt1 here is my ESP, yours could be different, like gpt3

    Now apply changes to grub


  2. Chinmay Sarupria
    March 18, 2013 at 1:20 pm

    Restart your computer and before the boot screen appears continue hitting space bar.
    Boot Manager would show up. Select Windows 8 from arrow key and hit Enter.

  3. Donald Schultz
    March 14, 2013 at 4:58 pm

    My expierence with that was to use gparted on a live cd. Doing this you will not be "sitting" on the partition and will be able to do whatever is needed that way. I would try what Sajan Shetty recommended also.

  4. Sajan Shetty
    March 10, 2013 at 7:15 am

    Just boot up with your Windows 8 installation media and Click on Repair your computer ( shown during 1st or 2nd screen of the installation on the bottom) Select Startup repair and see if that works if that doesn't work.If that doesn't work follow the step's again and select command prompt on 'Repair your computer option' there you can try Check Disk command as below:


    Please also run the following command:

    Bcdboot C:windows

    NOTE: Replace C with the drive letter where the system is installed.


  5. Alan Wade
    March 5, 2013 at 1:03 pm

    You dont say if your Windows 8 was an upgrade media or not, so assuming it is,
    Create a new partition or format an exsisting one.
    Re-install Windows 8 to that partition, choose not to activate Windows automatically.
    After the Re-install, check that everything works as it should do.
    Remove the exsisting Windows, the built in Clean-up Tool should help with that.
    Choose the activation applet, and enter your key.

    In the unlikely event that Windows will not accept your key, opt for the phone activation method and try again.

  6. Imesh Chandrasiri
    March 5, 2013 at 11:50 am

    if you don't won't the linux OS anymore, use a bootable windows 8 DVD and repartition the entire system. then install windows 8.

  7. Jim Chambers
    March 3, 2013 at 9:54 pm

    Try doing a quick erase (erases first and last part of HDD) using a live DVD and the re-install Windows 8.

  8. ha14
    March 2, 2013 at 3:32 pm

    are you sure you did not deleted windows 8 also?

    boot repair

    if do not work
    try this
    First boot on your Windows Vista/7/8 installation
    then use again
    boot repair

    • shaurya gupta
      March 2, 2013 at 5:54 pm

      I will try it, but what about the hard disk that is locked?

    • ha14
      March 2, 2013 at 6:44 pm

      check if you have UEFI mode in BIOS, just disable it and try to reinstall Windows. Disable UEFI BIOS and Secure Boot options, and enable legacy BIOS mode. after windows 8 install you can re-enable

Ads by Google