How can I install the Canon printer driver on Windows 7 x64?

William July 4, 2013

I have a Mac Mini with OSX 10.8.4 on one partition and Windows 7 x64 on a second partition. I cannot install Canon MG8100 driver package on Windows.

I get report that the driver is in use and cannot be updated. I have attempted to close it via device manager, task manager and uninstall and nothing works. I get partial install with web utilities but no scanner or printer driver.

Do I need to revert to x32?

  1. Tsf O
    August 28, 2013 at 4:16 pm

    you can go directly here. and it will work decently on both 32,64 bit.

  2. William Dawson
    July 6, 2013 at 10:37 pm

    Already tried all of this. I eventually receive a winnow that say the driver is already in use elsewhere and cannot be deleted. I have uninstalled, deleted files by hand from :C - anything and everything related to Canon, unpaged the all-in-one ……. all to no avail. When installed the solution menu which, on my older PC shows a choice of scanner, printer photo print etc. instead shows only web applications and network.

    If I could make a clean install it would probably be OK but this has so far not been possible. Canon have washed their hands. My new machine is a Mac mini with two partitions with Windows 7 on :c and OSX 10.4.2 on :E (the other partition) and the actual hard drive is SSD not HDD. The HDD is used as a data drive visible from both OSs. All window programs are on :C and all Mac apps are on :E.

    I have also put the Canon MG1800 Driver fro Mac on :E but in theory this should be invisible to :C and now this driver is playing up as well.

    Any idea, very frustrated!


  3. Oron J
    July 5, 2013 at 1:35 pm

    Download the latest driver from the Canon web site.
    Uninstall the old driver (Start=>All Programs=>Canon MG8100=>Uninstall (the items may have slightly different names on your computer).
    Reboot the computer
    Install the new driver

    If this doesn't work, get back to us and no, if you use Win 7 x 64, you shouldn't need to use the x32 drivers.

  4. Hovsep A
    July 4, 2013 at 10:02 pm

    well you have x64 then driver should be x64
    have you tried in safe mode?

    try in clean boot