How can I get my 64GB SanDisk microSDHC working again?

Amar March 26, 2015
Ads by Google

My microSDHC is detected as G: on Windows 7 but won’t read/write or open. How can I get my 64GB SanDisk microSDHC working again?

So far:

  • I have tried using cmd (in administrator) to write: ‘chkdsk G: /f’ or something along the lines of that. This does nothing at all – it just goes to the next line and stops.
  • I have tried using cmd (in administrator) to write “format g:”. This just replies: “Insert new disk for drive G:” and “and press ENTER when ready…” I press enter and it also does nothing at all like the previous command.
  • I also have tried to go to ‘Computer Management’ (Right click on computer -> manage) and right clicking G: but it doesn’t give me the option to format, which is a known solution to something like this.
  • Right clicking the G: from ‘My Computer’ will make the mouse change into the ‘busy’ icon (the blue circle) and will make the green loading line at the top load forever. Clicking on it once and then clicking ‘Properties’ located on the top bar will also do this, and double clicking ‘G:’ will make ‘My Computer’ stop responding.
  • My adapter also shows in ‘Devices and Printers’, but double clicking will make it stop responding. I can, however, get into the properties – but this just shows the G: as a device with 0 bytes on it that ‘is working properly’ (but it’s not). This adapter works with microSD cards of the exact same make too.
  • I have tried other software to format it but it will not open as long as the microSD is plugged in — when it isn’t in, it opens but there is nothing to format.

I am terribly sorry if my question is worded badly. I need a fix that will make my card usable again. I don’t really care about the info on it.

  1. Doc
    April 13, 2015 at 8:11 pm

    Does your card reader support SDXC cards (cards with greater than 32GB of space)? Hardware revisions over the years have created several specs, including SD (up to 4GB), SDHC (some 4GB cards up to 32GB), and SDXC (64GB and up, no upper limit set yet; I've only seen 64GB and 128GB so far). If your card reader hasn't been tested with SDXC (this is the first time trying your card in this reader), it may not be SDXC compatible.

  2. rock
    March 31, 2015 at 11:56 am

    Well if it were seen by say Windows Explorer as a drive or say Computer management as drive. Then it seen by Diskpart as drive for sure.

    Cleaning a disk most often fixes this issue with any drive.
    You can only do this from diskpart in windows 7.
    Its good to know how to use diskpart.

    Run an "admin" CMD prompt.
    at prompt type diskpart
    then List disks.
    view the list of disks. Find you SD cards. disk #
    type select disk "#"
    type list disks
    type list partitions

    Type "list partitions"
    Type "select partition "#"
    Delete partition

    Type "list partitions"
    Type "clean"
    Its now a totally blank and inactive
    You can "Type exit"
    now from "computer management" you make it newly active and format it right up.
    bingo. this will have cleared everything and It should work perfectly.

  3. Kannon Y
    March 26, 2015 at 7:22 pm

    Oron and Jan nailed all the primary rescue solutions for this kind of issue. One of the most powerful recovery tools for SD cards, though, is the low-level format (which in itself is very dangerous):

    You have to scroll down a bit before they talk about it. Here's the download page for the tool:

    Aside from that, I'd like to share my experiences on recovering completely unreadable SD cards: For some reason, the most effective method of getting these properly formatted is usually by using a Linux system to read the drive. PartedMagic is probably the best live disk for this purpose.

    • Ben
      March 29, 2015 at 5:08 pm

      Gparted also works wonders.

  4. Jan F.
    March 26, 2015 at 6:39 pm

    The "hanging" usually indicates that the drive is detected but can't be properly recognized which indicates a technical problem with the controller, either on your PCs side or the SD card.

    So as Oron and ha14 suggested try using respectively formatting the SD card on a different device or computer. If that doesn't work either I'm quite positive the controller in the SD card is damaged.

    Your best bet is is the 5 year warranty on SanDisk cards assuming it's still valid. After that much trouble I wouldn't want to entrust that card with my data.

    • Amar
      March 28, 2015 at 5:59 pm

      Unfortunately I have tried that and that doesn't work either. I just decided to buy a new one instead, so I've kind of given up...

    • Amar
      March 28, 2015 at 6:01 pm

      Thanks everyone anyway!

  5. ha14
    March 26, 2015 at 4:04 pm

    try on another pc, mac, linux.

    before you can try to ninstall USB Drivers on Windows 7
    then after reboot windows will reinstall drivers, check if your sd card will work again?

  6. Oron J
    March 26, 2015 at 12:57 pm

    Sounds like you've tried all the standard solutions, but you could still try to put it into a different type of device (e.g. a camera) and format it there.

Ads by Google