How can I format my Kingstone G3 datatraveler pendrive in Linux or Windows?

vineed g May 27, 2013
Ads by Google

I have this Kingstone G3 datatraveler flash drive. Recently, while making a bootable flash drive for Linux, it went into some kind of problem.

Now when I open it in Windows 7 or Windows XP I can’t format it. For some reason it shows used space 0 bytes and free space 0 bytes in properties. I tried format command in Windows 7, but that was of no use.

When I opened it on Linux (Ubuntu 13.04) the flash drive opens, shows files inside, but when I tried to delete files it shows filesystem read only. I tried chmod command on files, tried deleting it in super user mode, but no use :(

On Linux it shows file system:msdos, while on Windows 7 it shows fat32.

I have tried HP USB disk storage format tool, but that was also useless.

Pleas guys help me with this! :(

  1. Avinash Mali
    May 28, 2013 at 6:43 am

    You can use "gparted" app on Linux, it's really awesome, you can play with partitions as if with a cake !

    • vineed g
      May 28, 2013 at 4:15 pm

      nope it is of no use :(

  2. RH hassan
    May 27, 2013 at 7:53 pm

    you can format your usb using windows xp setup .........

  3. Stephen Hill
    May 27, 2013 at 6:11 pm

    Install gparted as either a program in linux or as the linux distribution itself. Then use it's format controls to format the drive. It's worked for me 100% of the time.

  4. dragonmouth
    May 27, 2013 at 2:12 pm

    Have you tried as superuser:

    chown -R newowner:newgroup files

    • vineed g
      May 28, 2013 at 4:12 pm

      yea i have tried that too

  5. ha14
    May 27, 2013 at 9:13 am

    EaseUS Partition Master Professional Edition
    1) right clickon the USB located in the interface
    2) A new window will open and will ask to give more details (name of flash drive, File system... )
    3) Apply button to apply the changes/operations and to foramt USB key

    How to format USB memory stick in Linux

    • vineed g
      May 28, 2013 at 4:11 pm

      no use the flash drive is not listed even after plugged in :(

    • ha14
      May 28, 2013 at 6:43 pm

      insert your usb key to windows
      Start > Run then typ: cmd right click on choose run as administrator
      2) on the black screen type: diskpart and hit enter
      3) then type: list volume and hit enter
      do you see your usb key?

    • vineed g
      May 29, 2013 at 2:30 pm

      i have used diskpart,,,its shows the disk ....i have even tried to run attributes disk clear readonly command after select the disk

    • ha14
      May 29, 2013 at 3:47 pm

      if it shows the disk then try this
      Type in the following:
      1. diskpart
      2. list disk
      3. select disk
      (enter the number that corresponds to your USB drive)
      4. clean
      5. create partition primary
      6. select partition 1
      7. active
      8. format fs=fat32 quick
      9. exit

  6. Rajaa Chowdhury
    May 27, 2013 at 9:07 am

    1. Right-click on My Computer and choose Manage
    2. Click on Disk Management
    3. Right-click on your USB drive and select "Change drive letter and paths"
    4. Reinsert the USB flash disk to the computer, and see if it works?

    • Rajaa Chowdhury
      May 27, 2013 at 9:09 am

      If it doesn't work, then try this :

      Uninstall Hidden Device Drivers:
      Click Start -> click All Programs -> click Accessories -> right-click Command Prompt, select Run as administrator. If you are prompted for an administrator password or confirmation, type your password or click Continue.
      At the command prompt, type the following commands (press ENTER after each):
      When in Device Manager, click View then Show hidden devices
      Expand the category containing your device, and then double-click the name of your device.
      Click the Driver tab, and then click Uninstall.
      If there is a Delete the driver software for this device box, check it (make sure you have internet connectivity so that you may reacquire these drivers). Read and Confirm Notification, click OK.
      Exit Device Manager, and restart your computer.
      You will be prompted with Found New Hardware. Select Locate and install driver software. Confirm permissions. Windows will now search for your hardware driver and reinstall it.
      Test the device again

    • Rajaa Chowdhury
      May 27, 2013 at 9:10 am

      Even if that does not work, then try this:

      In the Properties window of the device the Capacity of the USB drive is 0 bytes (0 bytes Used space, 0 bytes Free space)” , it seems that the USB device is a RAW volume. So I suggest you checking whether the USB device is a RAW volume first, you can take the following steps.

      1. Insert the USB device to a USB port.
      2. Click the “ Start ”.
      3. Right click the “ cmd”, and choose “Run as administrator ”.
      4. If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
      5. Type chkdsk f: ( I suppose the USB device letter is f )

      Note: The USB device is a RAW volume, when using Chkdsk it says ” type of File System is raw “. Chkdsk is not available for raw drives.

      If the USB device is really a RAW volume, please follow the steps below.

      1. Right click the USB device.
      2. Click “ format ”.
      3. If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
      4. Click “ Restore device defaults ”, then click “ Ok “.
      5. See if it works.

      If neither of the above works, I suggest you follow the following link for the methods on how to fix the USB problem.

Ads by Google