How can I format a write protected USB thumb drive without switch in Windows Vista?

Brandon Ragoo February 11, 2013
Ads by Google

Whenever insert my thumb drive into my USB hub and try to format it, I get an error message stating that it is write protected.

Today was the first day I ever encountered this error using a thumb drive and I tried Google the issue, but was unsuccessful in finding any appropriate solution as it didn’t have any websites providing any article on troubleshooting this problem. All it had was forums with other people who encountered this problem and the response seemed to be no benefit to me or the person who asked the question.

Several people said there may be a switch on the USB thumb drive, but my thumb drive doesn’t have any switch. Please reply and give me a solution to my problem asap. Oh and I’m running Windows Vista Home Premium 64bit Service Pack 2 the flash drive is an 8GB NextGear.

  1. Brandon Ragoo
    May 30, 2013 at 5:33 am

    Guys sorry for the late response I kept forgetting to reply to this as I have been busy and lost all hope with the flash drive, I'm thinking its a hardware issue. I even tried all the instructions in this article // but all failed.

  2. Addy Emmanuel
    April 26, 2013 at 11:43 am

    how do format my write protected pen drive?

    • Doc
      May 22, 2013 at 12:21 pm

      Try using a Partition Magic live CD / DVD. Linux always works when others fail for me at least. Use it to reformat the partition to most any file system you want. Good luck!!

  3. Venn
    March 23, 2013 at 7:13 pm

    If ur pd couldn't format by all the ways u did...then u shud connect ur pd at the time when you install new windows in ur pc. it will give u option that "which drive u wanna install windows at that time u must select ur pd also...gud luck.

  4. Nevzat Akkaya
    February 15, 2013 at 1:23 pm

    Unfortunately many of the questioners does not provide feedback so we wonder what happened, did any solution worked on him, if it's solved, which one solved?

  5. Noha Philipz
    February 13, 2013 at 2:51 pm

    Open the Windows Registry editor with the shortcut Windows-r, enter regedit into the form

    Navigate to the following Registry key:


    Double-click the new entry afterwards and change the value from 0 to 1. A value of 1 disables writing to all connected USB devices. If you want to enable writing again you need to change the value of the key to 0.

  6. Nevzat Akkaya
    February 13, 2013 at 10:04 am

    This MakeUseOf answers provides so many useful results even I didn't know many of the alternatives before. Long live MUO and all the tech supporters.

    • David Wellins
      May 28, 2013 at 6:43 am

      I have tried pretty much all the answers i have found on the internet to format a write-protected pd, and nothing has helped yet.
      still working on it. (my pd is a micro sandisk cruzer.)
      any specific advice hat works would be awesome.

  7. Gaurav Joshi
    February 13, 2013 at 3:29 am

    you can use killdisk

  8. Paul Pruitt
    February 12, 2013 at 6:03 pm

    1. Right clicking on the drive.
    2. Choose Properties.
    3. Choose the Security Tab.
    4. Look and see if there are only Read rights on the drive. If there are, go into the Advanced Tab and fool around with the parameters until you can take ownership of the drive and change the permissions.

    Maybe another responder can share exactly how to take ownership.

  9. Justin Pot
    February 12, 2013 at 5:24 pm

    This has happened to me a couple of times, and formatting the drive usually solve the problem. If nothing else here works give that a shot.

  10. Bruce Epper
    February 12, 2013 at 4:12 pm

    Instead of plugging it into a USB hub or a front-panel USB port, use one of the ports on the back of the machine.

  11. Nevzat Akkaya
    February 12, 2013 at 11:40 am

    It's useful if you have an advanced disk/partition manager like Paragon's. They always have free editions ( besides giveaways (// You can manage (re-partition/erase/format) your disks and flash drives easier with it.

  12. Jan Fritsch
    February 11, 2013 at 11:09 pm

    You can find a multitude of possible solutions in our previous question:

    Why is my flash drive write-protected and how can I format it?

    How to remove write protection from a Toshiba USB drive?

    Is it possible to format a write protected flash drive?

  13. Alan Wade
    February 11, 2013 at 6:29 pm

    Try this:
    It may help and is very detailed to help you.

  14. ha14
    February 11, 2013 at 5:01 pm

    try this mUSBfixer to format USB key (this delete all files on USB key)

    perhaps like this
    Start > Run "cmd" with administrative rights
    type--> diskpart
    type--> list volume
    type--> select volume #
    type--> attributes disk clear readonly
    type--> x:\>attrib -r /s /d (X= hard drive, usb key)

Ads by Google