How can I fix my modem after a firmware upgrade with a fatal error?

Kaashif Haja November 10, 2012

Few months back, I was using D Link DSL 2640U modem. I had some problems with it. When I upgraded my modem, I downloaded different version number unknowingly and upgraded it. I got fatal error and now I am unable to use the modem. Can’t either connect to internet or log in to modem’s IP address. I tired resetting the modem, too. But it’s of no use. Is there a solution for my problem?

  1. Aniket Singh
    November 11, 2012 at 2:22 pm

    buy another modem...aur replace it

  2. ha14
    November 11, 2012 at 9:36 am

    if there is return policy then use it

    » how to upgrade firmware dlink dsl 302g

  3. Drew Butler
    November 11, 2012 at 4:12 am

    this isn't the same model but seems like the same problem.
    "Hi Rarst, I bought DSL-2540U today morning for one of my customers. I strongly need NAT support on it but when I try to update the firmware, it gives this error: “Fatal error during image uploading.”
    why is this happening? what should I do?

    reply quote #
    @Saman Atabaki

    Check that you are using firmware for correct hardware revision. See this (in russian, but images are self-explanatory)

    Had you tried advice from post? Rename firmware file to short name, place in root of disk C and use Internet Explorer to update."

    The credit for this goes to Rarst and the link to the forum I found this on is

    Never had anything similar happen to me nor can I say this will work for you but seems like a good place to start. Hope this helps

    • Kaashif Haja
      November 13, 2012 at 12:50 am

      I don't find any images in the first link you provided!

      • Drew Butler
        November 13, 2012 at 6:21 am

        My guess is because of a region lock. Those files were from a Russian website. Try doing a google search for D Link DSL 2640U modem Original Firmware images. I don't know what will show up in your country or I would provide another link.. Should be easy enough to find a "stock firmware image" and try the technique listed in the comment above.

  4. Erlis D.
    November 11, 2012 at 2:30 am

    Probably it needs flashing! The best option is to take it to the ISP (if they gave it to you), and ask them to fix or replace it! You can either take it to a computer repair shop! But I doubt that anyone will try to repair it! So, the best option is to buy a new one! But first try the other options...
    To tell you the truth. it never happen this problem to me! And I've never heard about this problem before! So, I will assume that one of the suggestion I gave to you will help!

    • Kaashif Haja
      November 13, 2012 at 12:49 am

      I tried to repair. But, couldn't do it.
      Most probably, i should throw it away!
      Anyway, Thanks for your reply!

      • Erlis D.
        November 13, 2012 at 3:11 pm

        Don't forget to go to a repair shop too! Probably they might fix it!

        • Kaashif Haja
          November 14, 2012 at 2:04 am

          Will give it a try! :)

  5. Jim Chambers
    November 11, 2012 at 2:13 am

    Buy a new one as your old one is toast.

Ads by Google