How can I connect a CyberPower computer to the Internet after factory reset?

Cristián T October 16, 2013

My friend’s computer is a CyberPower computer, not sure what model. I just factory reset it, and when Windows was reinstalled, the computer couldn’t connect to the Internet. The Ethernet drivers are unable to be found on the computer. I need to get the computer able to connect to the Internet and I don’t know how to do it. Also the computer is really low-res and expanded and I can’t figure out how to disable that. Please help.

  1. Problem Solver
    October 18, 2013 at 1:29 pm

    Tell your friend to go find the driver disc that came with the computer. Problem solved.

    • Cristián T
      October 20, 2013 at 2:01 am

      I did exactly that and he can't find it.

  2. Oron J
    October 17, 2013 at 2:59 pm

    Cristián, reading through the comments again, I think I understand what the confusion stems from. Although CyberPower builds PCs, this is essentially an assembly job. ALL the internal components (motherboard, processor, graphics, network interface hard discs etc) are made by other companies, and most requires its specific driver (disc drives and most keyboards & mice use the built-in drivers). Because CyberPower build PCs to order, there's not even a standard "model" which will consist of a fixed set of parts. You need to find out what the constituent parts of the computer are and get the necessary drivers for them.

    If CyberPower are highly organised, they may have the list of components on you PC which they will be able to trace through their invoices and can send to you.

    If not, you can open up the computer and note down the make & model of the components. The most important component is the motherboard, followed by the expansion cards (cards which are plugged into the motherboard). Note down the make & model of each board and then go on the hunt through CyberPower's support page and download the necessary drivers. If you prefer, you can search for the drivers on google. For example, if your motherboard is made by ASUS and the model is F2A85-M PRO you would simply google "ASUS F2A85-M PRO drivers", which will take you to ASUS's support page, where you may or may not need to select the motherboard model again and the version of Windows. Once you have done that, you will get a long list of drivers available for that motherboard. The most important components for you are: chipset, ethernet, wifi (possibly called "wireless") and graphics (possibly called "video").

    Once you install them and restart the PC, you should be able to connect to the internet. However, there may be other drivers you need, so open up the device manager (in Windows Vista or 7 you can simply search for it. In other versions of Windows, you'll find it in the Control Panel under "system". Once it opens, you'll see a list of device types. Any devices that are recognised but not working properly will be listed in the correct branch and have either an exclamation mark or an X over their icon and you should update the drivers for them (there's an option in the device's properties to do that, or you could search for a driver and install it yourself).

    If any devices are not recognised at all, they'll be listed under "other devices". The solution is the same, but you'll need to identify them yourself by doing further detective work...

    Best of luck!

    • Cristián T
      October 17, 2013 at 11:29 pm

      I just installed the Ethernet drivers, and I still can't connect to the Internet through Ethernet. I don't know what's going on.

    • Oron J
      October 18, 2013 at 10:12 am

      OK, a few questions:
      1. What version of Windows are you using (XP, Vista, 7 or 8)?
      2. Are you using a wired connection or WiFi?
      3. Did you check the Device Manager to see if the driver is working properly? What is it reporting?

    • Cristián T
      October 22, 2013 at 12:21 am

      I'm using Windows 7 Ultimate 64-bit.
      I'm using a wired connection. The computer in question usually doesn't connect to WiFi because it's a desktop.

    • Oron J
      October 24, 2013 at 8:38 am

      Hi Cristián, the next step is to oopen the Network and Sharing Center and run the "Troubleshoot problems" wizard. If you are lucky, it will sort out the problem. If not, note down the error message and post it here.

    • Cristián T
      October 26, 2013 at 7:34 pm

      I tried that, and it said that it couldn't identify the problem

    • Oron J
      October 27, 2013 at 2:12 pm

      Alright. Let's try it like this. Go into the device manager and check the status of the Ethernet driver. It should be in the "Network adapters" branch, and will probably not say "ethernet" as part of its name, but will have something to differentiate it from WiFi adapters. Quite often, ethernet adapters have "10/100" or "GBE" in their name (to indicate their speed). Is it shown as working?
      If not, what is the problem? Is it disabled, faulty, driver stopped? Or perhaps there's no ethernet driver shown, in which case look at the "unknown devices" branch and make a list of all the devices listed there. Report your findings here and we'll continue from there.

      If the device IS shown as working, open the Network and Sharing Center and click on "Change adapter settings" on the left. Double click on the "local area connection icon" and study the information there. First of all, does it show something in the "speed" category (e.g. 100.0 Mbps)? If not, you have a communication problem between the card and the router. This may be resolvable, so report it to us. If the speed's there, whaty about the packets sent & received? If it 's a large number, it means that the computer is "talking" to the internet (or at any rate, to other computer), but if it's a small number (<1000), this is indicative of something else (e.g. TCP/IP configuration problem or firewall issues) and we can try to help you there.
      Looking forward to hearing from you!

  3. Oron J
    October 17, 2013 at 10:12 am

    There's a list of hardware companies at the bottom of the page. You're supposed to look for the driver for each component under the appropriate manufacturer. Since you don't know what model the computer is (and by extension, what make & model each component is), I suggest you contact the CyberPower suppoort people using the contact info on that page, and ask them to help. They should be able to help you identify the hardware and tell you which drivers to download.

  4. Oron J
    October 16, 2013 at 10:19 am

    Sounds like you're missing the specific drivers for your PC are missing (at least the Ethernet/WiFi and graphics). You could try DriverPack, as Hovsep suggests, or you could look for a drivers disc among the discs that came with the PC, if any, and install them. If you don't have a drivers disc, you could download drivers from You'll need to know the model name at a minimum, but if you have trouble figuring this out, there are contact details on that page so you can phone or email them and I'm sure they'll be able to advise you properly.

    • Cristián T
      October 16, 2013 at 8:53 pm

      I don't understand what I'm supposed to do on that page. It doesn't clearly explain what name corresponds with which driver.

  5. Hovsep A
    October 16, 2013 at 10:07 am

    maybe the windows iso dvd you have used is not a good one.

    DriverPack Solution

    • Cristián T
      October 16, 2013 at 8:48 pm

      I loaded DriverPack Solution on the CyberPower computer. When the program loads up it states that I need to search for the drivers on the web, five drivers require installation but weren't found in driverpacks, and that I should try adding other driverpacks or download from the links provided by the program.

    • Hovsep A
      October 16, 2013 at 9:07 pm

      well you can download on another pc, transfer to usb key then plug the usb key to your pc, copy paste to desktop then load the driverpack and see if this will help to advance.

    • Cristián T
      October 16, 2013 at 11:58 pm

      That's what I did.

    • Hovsep A
      October 17, 2013 at 11:54 am

      so you solved your problem?

    • Cristián T
      October 17, 2013 at 8:49 pm

      Unfortunately I did not. I tried that and it didn't work.

    • Hovsep A
      October 18, 2013 at 8:52 am

      use your windows cd to repair windows and try again, sometime missing system file can cause this problems.

    • Cristián T
      October 19, 2013 at 4:27 pm

      Well the thing is that the computer was connected to the Internet before I used to the Windows CD. After I used the Windows CD, it lost its ability to connect to the Internet. Downloading the drivers from my laptop to an external hard drive that I have, and then transferring them to my PC and installing them there fixed the display, but did not provide the computer access to the Internet.

    • Cristián T
      October 20, 2013 at 1:56 am

      Correction: I do not have my Windows CD, and thus I did not use it. Instead, what I used was a DVD with the necessary ISO files burnt onto it. After I used this DVD to factory reset the CyberPower PC, it was unable to connect to the Internet through Ethernet, and had a low-resolution display. I fixed the display and set it to normal, but the computer is still not able to connect to the Internet.

    • Hovsep A
      October 20, 2013 at 2:09 pm

      perhaps to check here for the drivers
      i had similar problems with my windows 8 internet browsers could not display web pages so i had to use my backup to restore windows, have you tried wifi connection to see if his can help internet access?

      Windows 7: Ethernet controller driver on my Windows 7 Cyber Power pc not found.

    • Cristián T
      October 22, 2013 at 12:20 am

      Yeah. I read that and unfortunately didn't find any solutions.

    • Hovsep A
      October 22, 2013 at 6:17 pm

      is it possible that the motherboard has a problem, perhaps to make dual boot with another windows or linux version and see if connection will be established

Ads by Google