How can I handle a USB flash drive that shows ‘your drive needs to be formatted’ witout formatting it?

Ras Magombe Steven August 11, 2012
Whatsapp Pinterest

I have a USB flash that when you try to open says ‘your drive is not formatted’ and cannot proceed beyond that. How can I solve this without formatting because I have some information that I need from it.

  1. Usman Mubashir
    August 22, 2012 at 7:26 pm

    When I encountered this problem, I quick formatted the drive and recovered everything using easus data recovery tool

  2. jones198315
    August 22, 2012 at 1:57 am

    When I faced the similar situation, I just formatted the USB drive to use it further and used USB data recovery tool to perform Mac photo recovery from formatted USB drive. This tool worked with good results. I hope this will help you. You can also download demo tool [Broken Link Removed] and test the data recovery process.

    August 20, 2012 at 10:01 pm

    Hello, does it give you the option of answering no to the formatting? If it does, answer no and it will open the contents. Was the flashdrive disconnected without using the safely remove option? That is mostly the main reason for corrupted drives.

  4. Kaashif Haja
    August 20, 2012 at 1:23 am

    I see that your have some files which you don't want to get deleted
    Try to backup your files in Linux, then you format it!
    Your problem is solved.

  5. Bert Jerred
    August 18, 2012 at 12:16 pm

    Sometimes, a USB flash drive is formatted with a filesystem that the operating system (e.g., Windows 7) just doesn't know how to read; if you have access to a computer running something like Ubuntu, I would try plugging it in there - and if you aren't immediately able to find your data, use the "Disk Utility" to find out a) if the USB device has a problem, or b) if it's a filesystem issue.

    For example, Windows likes the NTFS and FAT formats. When I used a 4GB USB flash drive to run a version of the Chromium OS, Windows could only see a portion of those 4 gigs. Plugging the same drive into an Ubuntu machine allowed me to see the whole deal, which included some weird partitions.

    If you're feeling particularly daring, you can use a program called, "Testdisk," to recover deleted files! Fun!

  6. ras magombe steven
    August 14, 2012 at 6:06 am

    i have tried most of these options but non seem to be working, luckily the user had the data backed up else where, so i just formatted it and its now working.

    thanks alot.

  7. Mihovil Pletikos
    August 13, 2012 at 6:36 pm

    most probably you'll have to format it.... but try to use check if it works on other computer or/and check for errors on it

  8. Erlis D.
    August 12, 2012 at 9:45 pm

    One reason might be the one Pankaj said (see above comment)..
    But if not, the better way I know is, moving all your files on you hard disk, than format your USB, and move your files back to your USB...

  9. GrrGrrr
    August 12, 2012 at 8:23 pm

    i guess u r using usb on Windows-7

    try checking in some other OS/PC.

  10. echantrea
    August 12, 2012 at 10:26 am

    Try to change port if it fails. format and recovery.

  11. Lambvolution
    August 11, 2012 at 9:04 pm

    try to use different machine with different OS

  12. Pankaj Lakhani
    August 11, 2012 at 10:17 am

    You can solve it by properly attaching your USB onto your PC or laptop. It might not be properly detached, try this if it works. If not then try to repair it with right clicking on drive, then properites, click on repair. If this also not solves it, USB might have hardware problems that requires a servicing which might help recover your content inside it.

  13. Ole Funch
    August 11, 2012 at 9:04 am

    When tis happens to me, I usely have a menu saying "Repair", and this normaly works.
    Another tip is, try using it on another PC, and try to see if the same thing happens, if not, then you can copy the files you don't want to loose!

  14. ha14
    August 11, 2012 at 8:21 am

    Click Start and then Run. Type cmd and then click OK. Type the following:
    chkdsk [USB drive letter] /r
    this will Scan for and attempt Recovery of bad sectorsor
    chkdsk [USB drive letter] /f
    this will Automatically Fix file system errors on the disk

    to recover files before format try recuva, Pandora Recovery

    • Ole Funch
      August 11, 2012 at 9:06 am

      or try a mini recovery tool: pdr6free (.exe), you can search for it.

Ads by Google