How do I get the rated data transfer speeds on a dual-band router?

Federico October 28, 2014
Ads by Google

Hi everyone!

I tried to boost my WiFi transfer speed from PC/smartphones to my NAS (Network Attached Storage). Wired transfer speeds were decent, but not what I wanted.

Granted that all the tests I’ve done were made less than a meter away from the router, channels are not saturated and there are no walls near it.

My problem is this:

I have a Western Digital NAS.

As far as I know is a 10/100/1000Mbps device.

My router also had the Gigabit Ethernet port (10/100/1000Mbps) and file transfer cable was pretty ok (about 35MB/s). I could not say the same for the transfer via wifi as it was fixed at 10MB/s regardless of whether the PC which was transferring the files would use a wireless-N (300Mbps) or something else.

I thought the bottleneck was then the router, so I bought a dual band D-Link router.

My idea was: 1000Mbps NAS connected to the 1200Mbps router with a PC that has a 802.11ac network adapter (866Mbps – 1200Mbps). I did a test disconnecting everything else from the PC and the NAS, but the transfer speed from PC to NAS was the same: 35MB/s with the PC wired, 10MB/s via WiFi.

I checked the Windows network sharing center, AC adapter network properties, and it shows for the first 2-3 seconds: 866.5Mbps (the max it can goes i think), after that it drops to 300… 458… 125… the the transfer rate moves about randomly.

I tried to configure the router to have two different networks, one 802.11n only 2.4GHZ and 5GHz 802.11ac only, with two diffrent SSID. Then I tried to use the same SSID 866 + 300 as described on the product but nothing seems to go faster..

Any tips?

Sorry about my English; it’s not perfect >_<

Have a nice day and thank you!

  1. Bruce E
    November 6, 2014 at 9:24 pm

    Can you run a speed test with your PC wired to the router as well? I just want to know if it is worth the effort to run several scenarios on my own network in looking for a solution. Also, how large are the test files you are using and are you doing both read and write testing to the NAS?

    • Federico
      November 8, 2014 at 10:48 am

      Granted that all the tests I’ve done were made less than a meter away from the router, channels are not saturated, there are no walls near it and there were no other devices connected via wifi or cable.

      I'm using the same solid mkv file (7.7GB) to test r/w speed on the NAS (MyBook Live 2TB).
      Router is TP-LINK Archer D7 (AC1750)

      PC via WIFI write speed = 15-16MB/s
      PC via WIFI write speed (using FTP) = 20-21MB/s
      PC via WIFI read speed = 15-16MB/s
      PC via WIFI read speed (using FTP) = 25-26MB/s

      PC via CABLE write speed = 30-33MB/s
      PC via CABLE write speed (using FTP) = 44-46MB/s
      PC via CABLE read speed = 58-59MB/s
      PC via CABLE read speed (using FTP) = 77-78MB/s

      Here is all the data. I hope these will help us to solve this weird situation.
      Have a nice day!

  2. Federico
    November 2, 2014 at 2:42 pm

    I've already done all that you suggested to me before. The devices are connected to the 5GHz network and there is no other form of life within 500m around my house that has a 5GHZ connection. The drivers are the latest and the network is set to AC only.

    I brought the router back, that was probably bad and I've got another TP-LINK AC 1750 router. This is working well and in fact my phone 1×1 has a link speed of 433Mbps and my pc has 867Mbps. The NAS is connected to the router via gigabit and the PC is connected to the router via wifi. Everything else was disconnected for testing. The transfer rate is now 15MB/s from PC to NAS via wifi.

    Please stop talking about channels, walls or anything like that >_<. You now should have all the information about the connection, the NAS is always the same. I still don't know how to solve this problem è.è

  3. Kannon Y
    October 30, 2014 at 6:29 pm

    Hello Federico,

    I can only see a handful of potential bottlenecks. First, the router has a USB 2.0 port, which means your theoretical transfer speeds over external storage (if you are using USB to connect) would be capped to a theoretical maximum of 60MB/s, although the real-world performance would be lower. Probably much lower.

    If you are connected wirelessly, the theoretical maximum transfer rate would be the wireless-N component in the NAS, which operates on the 2.4GHz and I believe offers a maximum transfer rate of in somewhere around 1-2 MB/s or 8-16mbps. It can go all the way up to 600mbps, in theory.

    The factor that I think is causing your transfer issues is more than likely related to multiple issues. It could have to do with broadcast channels. It could also have to do with the wireless device on your PC.

    You may have a 2x2 or 1x1 MIMO (two or a single internal antenna) on your PC, rather than 3x3 or 4x4, which allows (I think) the simultaneous transmission of three spacial streams.

    I think that when you upgraded the router to AC (which WOULD increase your speeds) you did not upgrade the wireless AC device on your PC (which I assume is a laptop or a USB device). Unfortunately, laptop and USB device wireless-AC units are bottlenecked by the number of antennas employed. So a two-antenna unit should only get about 2/3rds the theoretical speed of the advertised wireless-AC, which is about 867mbps. A 1x1 device will only get a maximum transfer rate of 433mbps.

    If possible, try the following:

    1. Enter into the router's settings and disable all wireless connection standards, except for wireless AC (so disable G and N).

    2. Play with the channels available within the router's settings. Broadcast channels can greatly effect your overall throughput and therefore might be the limiting factor.

    3. Upgrade your PC's drivers for the wireless AC network adapter to the latest one.

    I hope that helps! Me me know if anything worked.