Why can I not format my USB flash drive?

Erlis D. September 19, 2011

Some days before my USB was ok, but now doesn’t work anymore. At my computer it doesn’t have its name anymore, but reads ‘removable disk’. When I click ‘properties’ it show 0 byte of memory. When I right-click ‘format’ the format window appears and I click ‘format’ and a new window appears reading ‘unable to format drive’ or sometimes ‘the device is write-protected’, but it doesn’t have any lock or unlock key.

The USB is a 8GB Kingston. Please, can anyone help me?

  1. erin
    June 4, 2012 at 9:01 am

    i found that i could not use my usb after turning it into a bootable drive and it wouldnt format back to the original 4gb size even with formatting it from my computer/usb. i found this worked for me. and made my usb from 6.5 mb to full 4gb capacity again. yey i thought it was gona have to go in the bin. hope u have luck with this.
    usb formatting tool from cnet. cnet is a great site. ive been using there site for years and always been wat i need.
    u install the software onto usb. follow installation instructions. when installed open the software from ur desktop then it will ask to format ur usb drive. format it to fat32. thats what i did and it gave me back full capacity. goodluck :). oh sorry mike just saw u did this one. THANKS MIKE. LEGEND

  2. Iqbal
    March 5, 2012 at 9:21 am

    Hi i have a 8 Gb Ur Kingston pen drive which is showing 0 bytes and can not be formatted any solution

    • Erlis D.
      March 9, 2012 at 5:25 pm

      Hi. Unfortunately nothing worked for me. I don't know if anyone has any solution.. But for me none worked. Maybe the chips are dead, and the USB won't work anymore. This is all I can say you...

  3. Erlis D.
    September 21, 2011 at 3:39 pm

    I tried all the possible ways, except the linux way. And none of them worked. I think that maybe my USB chips are dead. I'll get a live linux cd and about 1 week I'll try it. If this way don't work too then I'll surrender.

    • Tina
      September 22, 2011 at 5:23 pm


      thanks for your feedback. Please do let us know whether Linux works for you.

  4. Sonny Bass
    September 20, 2011 at 11:13 am

    Bootice is a good tool for formatting portable drives.It also is portable. download here  http://www.softpedia.com/get/System/Boot-Manager-Disk/Bootice.shtml

  5. Mike
    September 20, 2011 at 3:36 am

    First you should rule out a faulty USB port on your computer - try another one, if possible try the USB drive on another computer too. If that doesn't help and with your drive showing 0 byte I can only think of it being encrypted and maybe you removed the necessary driver or software or you unplugged your drive premature and it is now corrupted. 

    In either case I would try the HP USB Format Utility

  6. Jeffery Fabish
    September 19, 2011 at 10:12 pm

    Yeah, the same thing happened to my 8GB Kingston, only this was after it went through the washer. Make sure it is properly connected into the computer. My drive will light up when it's properly inserted. After checking to see if my drive was write protected (which it wasn't) I assumed it was just a false positive error message, as Windows doesn't know which error would be best suited for this case. Does the USB work on any other computers? 

    Mine will still do this on occasion when I take the USB out and try to put it back in. I have to insert it back into the port in very meticulously in order to get it to be recognized.

    The device is write protected [Solution]

  7. Anonymous
    September 19, 2011 at 8:28 pm

    I've got the same problem, but with a USB hard drive. Just happened last week and I've tried almost everything. (I have a list somewhere with a thing or two I haven't tried.)

Ads by Google