Why can’t I format this LG USB flash drive?

Fems Pogi September 27, 2012

A friend of mine asked me to format his 120 GB LG flash disk (that’s what Windows Disk Management told me) as he cannot do it with his laptop. I tried and found out that I cannot do it either. exFat is the “original” file system, I tried to format with FAT, FAT32, and NTFS – to no avail.

It looks like the volume is “mounted”. What could have been the problem?

  1. brian ubaldo
    September 29, 2012 at 9:50 pm

    Start-Run-Type CMD hit enter
    type this format E: /FS:FAT32
    [E] depends on your harddrive just check in my computer which drive is your flashdisk that you need to format.

    if you want to format FAT32 system to NTFS use the opensource tool [SwissKnife]
    just google it and it take 1 minute only to download.

  2. Dimal Chandrasiri
    September 28, 2012 at 5:39 pm

    try going in cmd mode, or get a low level format utility. and if it asks to unmount the disk in CMD mode, just say yea. or else it'll skip the formatting.

    low level format is good too. if above fails, try a low level format. for sure, it'll make it done. :)

    • Fems Pogi
      September 29, 2012 at 9:11 pm

      Dimal Chandrasiri.....i have also done command line interface formatting on the Windows Dos prompt with all the applicable slash (/) commands....didn't work - so far...but thanks anyway....

  3. Ahmed Khalil
    September 28, 2012 at 10:49 am

    i think their is problem with this flash, is what windows say true, i mean is it really 120GB. if so this mean it is SSD and i think it came wit special software utility kit

    • Fems Pogi
      September 29, 2012 at 9:04 pm

      Ahmed Khalil....probably not a solid state drive because it was bought about two years ago.....yes i believe that there was some utility software kit to MOUNT this volume....only that the present user does not know much about software....he just give it to me to try my luck on it...

  4. Deekshith Allamaneni
    September 28, 2012 at 8:50 am

    Use any Linux system to format. If you dont have Linux available, you can download Ubuntu (www.ubuntu.com) and use it in Live CD mode to get your task done.

    • Fems Pogi
      September 29, 2012 at 9:01 pm

      Deekshith Allamaneni...unfortunately, i am on the ship now...downloads are blocked..but thanks anyway....

  5. HLJonnalagadda
    September 27, 2012 at 12:00 pm

    A 120 GB flash drive? Wow..

    • Fems Pogi
      September 29, 2012 at 9:09 pm

      HLJonnalagadda.....yes it is a 120 Gb flash drive although i suspect that it is only 32 Gb but that a software mounted it as 120 Gb....

  6. Loreson San Juan
    September 27, 2012 at 11:40 am

    It may be busted.

    • Fems Pogi
      September 29, 2012 at 9:00 pm

      Loreson San Juan...it could be but Windows Manager detected it...only that it was formatted as exFat....however, when opened using Windows Explorer "it says that the drive is not formatted....when formatted - windows advised that formatting failed...

  7. ha14
    September 27, 2012 at 7:34 am

    1. Right-click on computer and select “Manage”
    2. Select “Disk Management”
    3. Right-click on your USB drive and select “Delete Volume”
    4. Wait for volume to delete, then right-click on USB and select “New Simple Volume”
    5. Follow the prompts and it will reformat the USB to your 120GB default.

    or at command prompt under administrative rights
    list disk
    Select disk number (your usb key)
    detail disk
    Select disk number (your usb key)
    create partition primary
    select partition number (your usb key)
    format fs=fat32 (or you can choose fs=NTFS)

    • Fems Pogi
      September 29, 2012 at 8:57 pm

      ha14....i have also done as you described EXCEPT delete volume BECAUSE this is not accessible - being in GRAY.....but i will try this DISKPART on the command prompt...i will update this as soon as i can...thanks...

  8. Rody
    September 27, 2012 at 7:17 am

    You should be try with Linux for formatting your USB Drive or you can find a USB Formatter on the online just search on Google.

    • Fems Pogi
      September 29, 2012 at 9:07 pm

      thanks Rody....i will also try this....

  9. bonioloff
    September 27, 2012 at 3:26 am

    Try to do formating in Linux, And wow, yo have 120GB Flash Disk?

    • Fems Pogi
      September 29, 2012 at 8:53 pm

      bonioloff.....thanks for the advice but i have no access to Linux for the time being...and yes the capacity of the flash disk is 120 Gb, as reported on Windows Disk Manager...

Ads by Google