Why can I not format and use my flash drive?

Dan July 25, 2010
Ads by Google

Question on formatting a flash drive: I have this 4 GB Kingston flash drive. I have used for some time. I recently backed it up and installed a Linux distro on it, after formatting it. Later I formatted it again (both times using Gparted), and now it can’t be used.

Using it on Windows says that it needs to be formatted. When clicked Format, it carries on the process and finally says Windows could not complete the format. I have tried it over and over, and I have tried formatting it with Gpated and Disk Utility in Linux. Nothing seems to work.

Disk Utility says says Error creating file system. Gparted keeps volleying me back and forth between having to create a partition first and something else. I am really frustrated now. I wasted several hours hunting for solutions on the web. I know some of us out there has a solutions. Please help! Thanks in advance.

  1. Ericpeacock79
    August 3, 2010 at 5:44 am

    if the HP USB Disk Storage Format Tool doesn't work, then your flash drive is gone bad.
    probably time to replace it.

  2. Jack Cola
    July 27, 2010 at 3:59 am

    In My Computer, when you right click on the drive and select format, it doesn't work? Have you tried a quick format and long format, different file system and allocated unit size?

    Try it on a different computer as something may be running that isn't letting you format it.

  3. Dan
    July 26, 2010 at 6:47 pm

    Thanks for the reply Abhigyan!
    I ran the commands. But when I issue he command "list disk" the system is not able to detect the flash drive in question, even though it has been connected to the computer and the icon of USB appears in the task bar on the bottom-right.
    It just lists the 300 GB hard drive that is in my computer, as Disk 0.
    Hope you have more tips.

  4. shawnlanglois
    July 26, 2010 at 2:16 am

    There is a windows application that I use for this very purpose, when I am doing a little distro hopping.

    HP USB Disk Storage Format Tool

    It is easily found via Google search, or if you search for it over at softpedia.com

    It will allow you to format your USB key back to it's original size.

  5. Aaron B.
    July 25, 2010 at 8:43 pm

    im not sure why linux is giving you so much trouble. i had the same problem and i used the disk utility in ubuntu to delete all the partitions and then used the same utilty to create a fat32 partition and format it. unfortunately everything i had on the flash drive was gone but if you didnt back up all your data before trying to boot linux from it then you deserve the lose.

  6. Anonymous
    July 25, 2010 at 3:01 pm

    Since you have already tried the GParted and Linux ways, there is no harm in giving this Windows method a try. In Windows, Go to the command prompt (Go to Start > Run > cmd.exe). Once at the prompt, perform the following commands:

    1. diskpart
    2. list disks (this lists the disks connected to the system)
    3. select disk # (where # is the disk number corresponding to your disk)
    4. clean
    5. create partition primary
    6. active
    7. format fs=fat32
    8. exit

    Many a times, this method has worked surprisingly well for me. So give it a shot and let us know.

    • Dan
      July 26, 2010 at 5:59 am

      Thanks for the reply, Abhigyan! I tried it but after I execute "list disk" the flash drive in question, connected to the computer and appearing in the "My Computer" explorer window, is not listed (with a # number) as you told, in the result. Only the internal hard drive of the computer is listed as Disk 0.
      I hope this too sparks your thinking further and hope you can give some more tip or a way around with this.

      Thanks once again!

Ads by Google