Why can I not format my flash drive?

Amogh.M.S May 6, 2011
Pinterest Stumbleupon Whatsapp
Ads by Google

I am using a 4 GB Strontium pen drive.

Once at a time I tried to use it like a bootable flash drive, but it was error. Then I tried to format it in Ubuntu. It said that cannot mount. Then I tried to format it from disk utility, it was also failure.

Then I just plugged the device to Windows 7. At first Windows shows format complete, but when I just copy a file and re-plugged device it shows it must be formatted. I tried to format into fat, fat32, exfat etc. and also tried cmd, hp tools, gnome format. Again and again it was failure. Ubuntu is saying that cannot create fat filesystem.

What will I do? I know you will help me. Please!

  1. Sonny Bass
    May 6, 2011 at 7:07 pm

    You could try Parted Magic

    Download the ISO file, burn to a CD, then boot from the live CD. In my opinion this is the best partition tool available.

  2. Anonymous
    May 6, 2011 at 5:29 pm

    Have you used in on another computer?

    try to format with this tool

    Also HP format tool