Why can’t I flash my Xperia Mini Pro?

Dimal Chandrasiri September 13, 2012
Ads by Google

I have a Xperia Mini Pro and recently I flashed the device in order to install the new ICS. ( before it was introduced to my mobile due to Sony batching process ). It was fine and after flashing I repaired the mobile using Sony Update Service. the mobile works fine but now I want to gain root privileges. I used a guide for this, and in the flashing software, I cannot connect my device in the flash mode to detect it by the software. I cannot even repair the mobile since, it wont get detected by the Sony Update Service. Although the mobile is detected by the pc suite as an external storage device, or as the mobile. what can I do to this. since I’m over my warranty period I cannot go to a service center. It’s very frustrating.

  1. Dimal Chandrasiri
    September 20, 2012 at 2:58 pm

    @Kannon Y : I went through that and I did all of them correct before when I tried. I have an idea on how to connect it. :) the problem is that even I press volume down key and connect the device it won't go to the flash mode! It boots up into charge mode. the battery icon appears and the device is in charge mode. when I connect it in the proper way, the device should boot up and it should go on to the flash mode and windows should install the flash drivers according to the device. and in my case it doesn't happen... :( I suppose I have a usb brick.. :( can you tell me or guide me to fix this!

    • Kannon Y
      September 23, 2012 at 6:25 pm

      As with any other kind of trouble-shooting methodology, we need to one-by-one, eliminate every potential problem before concluding that we have a temporary or permanent brick (USB brick). With this method, there are a few other questions that might be useful asking:

      Have you tried a different computer? Sometimes individual computers might develop problems: a cable might begin to go bad, a USB port might not be supplying the right voltage, a driver might be bad or missing or a connection might be loose. Trying a different computer would help narrow the range of potential problems down.

      Something else: I saw this this forum post on how to get your phone to recognize flash mode. It doesn't exactly sound like a reputable response, but you never know.

      Also, have you tried asking the posters on Androidforums.com about your particular issue? Someone there might be more able to solve the problem. However, it doesn't appear to be a particular active forum. :-(

      • Dimal Chandrasiri
        September 23, 2012 at 6:55 pm

        first of all, m very thankful for you to take time on my question.

        for your question, I did try those things. :(

        I tried it with different desktop PCs, different USB ports in the same PC, and even changed the data cable. bt no use. I read the xda forum link your posted here, bt he says that, his device gets detected by windows as a semc device, bt not mine. even windows doesn't recognize it as a semc device. :( I'll try asking there too.

        • Kannon Y
          September 24, 2012 at 7:11 pm

          Then I believe this to be related to some problem within FlashTool. There are some other possibilities, but it seems that you are technically experienced and good with following directions, so it's my assumption that the likely problem is FlashTool.

          My other thought on this could be that you have the wrong firmware on the phone. Do you know if you have the SK17i or the SK17a? They are similar device and flashing the wrong ROM could cause problems.... But I don't think that's a possibility in FlashTool.

          This is the primary thread we should be following and asking questions in:


          They discuss all the major issues. If you have any problems, they are very active about solving them. Just make sure to read the documentation first, before asking any questions.

          I skimmed it over and don't see anything directly addressing your problem.

          This is the thread that deals with FlashTool for the Xperia Mini Pro, and related devices. Try asking your question here, first, before checking in the main thread (first link above).

  2. Rakesh Mishra
    September 14, 2012 at 7:44 am

    heyy dimal first you try to remove your google account from your device and then try to flash it .

  3. Kannon Y
    September 13, 2012 at 3:42 am

    Hello Dimal, I'm really sorry your device is misbehaving.

    This is actually the most common problem that people who correctly rooted/flashed their device experience. The reason is that Sony officially does not support users having root privileges on their own devices and whenever Sony pushes a firmware update out (or a security patch, which is specifically designed to remove your root privileges), it is a fresh kernel, which replaces the old, rooted kernel. Unfortunately, the mod community for the MiNi has not yet rooted the ICS kernel DIRECTLY. On the up side, they have managed to fix your particular issue and have a complete and well written tutorial on how to gain root on ICS:


    The basic idea of this root process is that your downgrade to 2.3 first. From there it's a relatively simple process to reacquire flash and root ICS. Good luck!

    • Dimal Chandrasiri
      September 13, 2012 at 2:06 pm

      I din't root my device bt I flashed it with the global firmware from the link below. It was the tutorial I used to update to ICS. the thing is, I wanted ICS before Sony released it so went on with the below tutorial to get it!


      I went with the steps and installed ICS perfectly. no flaws what so ever. not even a single random restart. bt the thing is I dint try to connect the device in flash mode after that. ( by pressing Volume down + connecting the cable ) Then I wanted to root it after few weeks and then I tried with flash tool. It dint recognize my device even with the right key combination. Then I tried to connect it to the SEUS bt it dint work there either. that's the place where I got to know that there is a problem with my device.

      The thing is when I try to repair with the pc companion, the same problem occurs and, a special thing happens. even the repair service doesn't detect the device, the pc companion detects the device as a normal mobile with no memory card inserted.

      is there any chance of being a USB brick.? what Can I do with this. I hope you are clear with what I said!

      • Kannon Y
        September 14, 2012 at 5:37 am

        Dimal, you were very clear in describing the situation.

        There is always the possibility of bricking the device after rooting/flashing a custom recovery.

        It seems that the primary issue is that your computer isn't properly detecting the Xperia. Have you tried reinstalling the device drivers for Windows 7?

        Just go to device manager and remove the drivers and Sony's software. Restart and reinstall them before plugging the Xperia back in (or follow whatever special instructions come with the software).


        It should reinstall the required drivers. Hopefully this is the issue! If it isn't, I would guess that the problem is with Flashtool or perhaps the wrong ROM. Do you know if your phone is the SK17i or the SK17a?

        • Dimal Chandrasiri
          September 15, 2012 at 7:01 pm

          thank you! :)

          Yeah I tried re-installing the device drivers at one point! but didn't work out as I planned! now I'm stuck at the point with no option to go. I searched the internet about similar problem but none existed.! :(

        • Kannon Y
          September 17, 2012 at 7:18 pm

          I've been thinking quite a bit about a possible solution to your problem. Google isn't telling me much and everything I know about the Android operating system tells me we may have a semi-major issue.

          If FlashTool doesn't work at all AND you do not have ClockWorkMod (CWM) installed, then it's possible we have a semi-brick or bricked device. But that's a worst case scenario. There's still a few things we can do.

          Before assuming a brick, I would first double and triple check your procedure for running FlashMode. Are you sure that you are using the correct key presses? For example, your device must be turned off when connecting. You sound like you know what you're doing, though, but every little thing helps. :-)

          Linked below are great instructions for entering FlashMode. They discuss issues, such as making sure you have the latest version of FlashTool:


          Anyway, that said, it's almost always possible to recover a device through ADB, although the method may not have been developed yet. In the event we cannot find an answer, one may eventually be developed.

          In the future, please consider installing a custom recovery. Once you successfully get one onto your device, it's almost impossible to brick it (unless you gain root and mess with your system directory/factory reset incorrectly/etc). Good luck!

        • Kannon Y
          September 17, 2012 at 7:19 pm

          This is a great recovery for the Xperia series:


Ads by Google