Why is my flash drive write-protected and how can I format it?

Anonymous February 8, 2012
Whatsapp Pinterest
Ads by Google

I have a 8GB Gernade Flash Drive that “became write-protected” as I was in the middle of transferring data. I have tried many solutions, but I have no idea what is wrong and it seems like this is happening to a lot of people.

Things I have already tried:
I opened Computer Management and double clicked Disk Management. I right clicked the drive and selected “Format…” Hit OK, and OK again when it warned me that formatting will erase all data on this volume. But I got the Error “the operation did not complete because the media is write-protected” I tried selecting the drive and right clicking on the partition, but “delete Partition” was not selectable and “Format…” gave me the same error.

I ran the command prompt, typed “chkdsk I: /f” but it says, “the type of the file system is FAT32. Windows cannot run disk checking on this volume because it is write protected.”

I also ran the command prompt and typed, “diskpart”. In the DISKPART> prompt I typed, “list volume.” selected the volume (in my case volume 2) and typed “attributes volume clear read only” It just gives me a list of the possible commands for diskpart and prompts me again with DISKPART>
(I have tried running diskpart on a windows 7 computer and I was able to type, “attributes volume” and get a list of the attributes. Readonly along with all the other options available said value :NO. When I typed “attributes volume clear readonly” it game me an error saying the operation is not supported on removable media.)

I have run regedit and created key “StorageDevicePolicies” and DWORD “WriteProtect” and set the value at 0 (it did not exsist originally)

I have tried downloading Neo9, but when I run the application it says, “USB Flash Disk not found!”
(I also tried running Neo9 on a windows 7 computer and it gave me the same error

I downloaded the HDD low level format tool. When I ran the program and selected my disk there was a message where the details should be, “Details are unavailable for this device” I run, “FORMAT THIS DEVICE” and hit okay when it warns me that all my data will be lost. While it is running it gives me hundreds of messages, “2/7/2012 3:59:28 PM Format Error Occurred at offset 37158912 19 – The media is wrte protected” Obviously the date and offset changed as it continued. The how to site with this program said it may take a few tries so I tried 5 times on a windows 7 computer and once on a Windows XP. The same result occured with both.
and odly enough the serial number listed in the low level format tool program was 000000 although I don’t know if this is relevant.

Some more information that probably isn’t relevant:
I bought a 8GB Gernade Flash Drive from Thinkgeek.com and began putting music files on it. Specifically MP3’s. I got 3.6GB of music on it when it stopped, mid tranferring data, and gave me the error, “Cannot copy data: this disk is write-protected. Remove the write-protection or use another disk.” As soon as I got that error I could no longer add, or remove any files.
There is no button or switch on the flash drive.
I have tried plugging it into Windows XP, Windows 7, and even Windows Vista, but all said it was write protected.
I was using Windows XP when it suddenly became write-protected, and attempted most of my solutions on the same Windows XP computer. I tried every solution listed above on the XP and tried most of them on Windows 7 as well.
In “My Computer” the drive used to be found under “Devices with removable storage” but now it is located in “Network Drives” However, when I plug it into Windows 7 it still is located under, “Devices with Removable Storage”
I have scanned the drive and found no viruses. I know the files I put on there had no viruses. I did not download anything or even access the internet while my drive was plugged in, before it became write protected, so I do not think it is any kind of virus.
The Manufacturer gave me this website //www.makeuseof.com/answers/format-write-protected-flash-disk/ to attempt to solve the problem, which is where I began searching for solutions. None on that page helped me, nor did the links provided in the comments have any working solutions.

If anyone has any suggestions please, PLEASE, let me know! Any way to re-format it, or just completely wipe it clean and re-install the drives, or if you just have a suggestion that wasn’t listed above. Thanks for your help!

  1. cybuzz
    September 30, 2012 at 2:48 am

    Had a similar problem with a portable WD-250.
    (My guess is after failing to eject the media.)

    Solution that worked for me (Win 7 64bit).

    1. Used the Diskpart cmd tool, after following detailed instructions as found here:

    2. (extra/optional) - Used "Check Partition" option from EaseUS Partition Master (home edition / free)

    • Marconne
      October 7, 2012 at 3:12 pm

      Hi, I have the same problem and tried all options from above. nothing helped!

  2. john
    August 10, 2012 at 2:29 pm

    whenever i connect a device to my computer... whenever i try to format it.... it shows that the disk is write protected... what should i do now? coz each device i connect to my computer shows it is write protected....i tried all the ways shown to remove write protection.... what should i do now?

    • mckeinley
      August 24, 2012 at 7:43 pm

      here's the link. .i've tried it on my 2gig write protected flashdrive and it worked. .though i encountered a problem, after the format, the memory became 114mb instead of 2gb. .it was like the files are still there, they're just hidden. .but at least i can open the flash drive. .tomorrow i'll try to find solutions into restoring the original memory of my flash drive.

      [Broken Link Removed]

      .by the way, it's a Filipino website and requires registration. .

  3. Unnikrishnan P R
    August 7, 2012 at 6:42 pm

    Did you try to format with Xbox ?

  4. Dude
    August 4, 2012 at 4:39 pm

    After experiencing this problem I quickly fixed it within a short time. I pulled the drive in and out of the USB port rapidly so as to corrupt the data. It did so so bad that it was ale to disengage write protect. I the reformatted the drive and enabled ready boost I only did this beacause nothing as on my drive and I planned to use it for ready boost. But had the write protect error.

    If you don't care about info on the drive it's worth a shot. If you do try backing up the information and then do it.

  5. Darkwarrior86
    June 29, 2012 at 7:45 am

    all above methods are useless i tried every thing but only this method worked without any error

  6. amr
    June 25, 2012 at 8:47 am

    i have the same problem but i can not solved

  7. JanDerek
    June 21, 2012 at 8:23 am

    Here are some instruction :

    -Run Registry Editor (regedit).
    -Navigate to the following registry key: -HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
    -Create a New Key named as StorageDevicePolicies.
    -Highlight StorageDevicePolicies, and then create a New DWORD (32-bit) Value named as WriteProtect.
    -Double click on WriteProtect, and set its value data to 1.

    To read more about this try looking here : http://www.techyv.com/questions/write-protect-error-my-flash-drive

  8. Ashish Pundir
    June 5, 2012 at 8:08 am

    My pen drive is not formatting.

  9. Sorin
    May 27, 2012 at 8:38 pm

    I've tried also on Linux with gpart, but is of no use. I noticed that when I use diskpart on XP it doesn't list any details on the volume (in my case volume no 4, letter f). Diskpart couldn't identify any disk on this volume. I think is the reason that all the softwares indicated here fail to work. It must be a method to identify a disk on the pendrive.

  10. f a R h a n
    May 16, 2012 at 4:34 am

    Drive should have a physical button. when it turn on it become write protected. I also have the same problem with SD card. and i tried to format this CARD but when i tried to do it it give the error the drive is write protected. then i check the SD card carefully there is small button on the SD card which moves forward or backward. at backward it is write protected. I move this button to forward point then insert the card,. and here i go it format the CARD without any error . . . . :-) . . ..

  11. Abdullah Al-Najjar
    May 14, 2012 at 7:09 am

    a also have the same problem
    i tried to do all solutions
    - from dos diskpart
    -from registry
    - by programs

    Is there any one can give us a Strong Solution >>>
    i don't think so...

    • ha14
      May 14, 2012 at 8:40 am

      how about to try on mac or linux

      • Clay
        May 16, 2012 at 1:44 am

        I have the same issue, tried it on a Mac and it wouldn't even read it.

  12. Jia
    May 9, 2012 at 12:21 pm

    i also have same problem. Anyone can teach me how to solve it?

  13. hasan
    May 2, 2012 at 3:50 am

    It's simple: download this [Broken Link Removed] [...] .9.1.1.zip run it and it will format your USB even if it is write protected. Good luck!!

  14. Ratikant
    April 24, 2012 at 3:24 am

    my flash drive is write protected and i am not able to format it ...
    i tried many time to format but it occur an error of write protected ....
    so sir can you please help me out of this........

    • Susendeep Dutta
      May 14, 2012 at 9:00 am

      Have you tried some of the solutions performed by the person who asked the question like using neo 9 tool -

      [Broken Link Removed]

      and Changing Storage device policy?

  15. Enterflex
    April 9, 2012 at 11:51 am

    How was it resolved?  I have this problem too - came right out of nowhere.

  16. Canary7
    March 26, 2012 at 5:13 pm

    you tried what I have tried nothing works yet but i will keep trying if it works i will post.

  17. John
    March 13, 2012 at 3:12 pm

    Some of these work some don't, some flash drives just have to be thrown out when this happens

  18. Meseret
    March 10, 2012 at 7:08 pm

    hello,the solution is use Linux operating system  to format.

  19. Bob
    March 6, 2012 at 4:39 am

    Had the exact same problem with a new sandisk ultra 16gb this week... pretty much followed the same entire path Corey traveled.  The bummer is that Corey's final breakthrough doesn't work for me...my sandisk ultra isn't listed at the RU forum and my vid (0781) and pid (556C) didn't bring up anything anywhere.  I think this flash drive is just screwed and sandisk is sending another.  What a lot of work to track this type of thing down!

  20. Babiryeimmy
    February 28, 2012 at 5:03 pm

    if the flash disk has a virus that is difficult to delete

  21. Tina
    February 22, 2012 at 1:12 pm

    Thank you for the thorough update, it's much appreciated!

  22. all is lost
    February 21, 2012 at 3:06 am

    This actually worked for me! Thank you man you made my day. I'll share how I did it in reply to my own separate comment.

  23. all is lost
    February 20, 2012 at 12:46 pm

    I have the same problems man. I tried most of the processes that you did too. I even downloaded a dozen random formatting tools just to see if it'll work. But, to no avail. Anyhow. If you're using Windows XP, hit F2 I believe to get to some sort of window where you can change a few options before booting up windows (forgot what it was called). Once you get there just keep hitting the right arrow key till you get to to the window where you'll see "exit and save changes" and exit and discard changes" or something like that. Choose exit and discard changes and you should be able to choose how windows will boot. An option for choosing safe mode with command prompt should be there.

    PS: This didn't work me. 

  24. Corey Haertel
    February 16, 2012 at 2:25 pm

    Hey guys, the latest mystery; I got a replacement and went straight to copying music files, just like the first, but it was transferring very slow. Slower then normal. a few hours into transferring it froze and gave me the same error as I got the first time. I removed the drive and re put it back in and run a scan and automatic fix on my computer. It scanned completely and said it fixed the errors. I checked to see if it was still write protected and I was able to copy a picture to the disk. BUT nothing else would copy. After that picture it told me everything else was write protected. Now it is locked like the first one. I can't remove add or anything. After I removed the drive and put it back in a second time it never said the picture was actually put on. Also I was transferring files from a DIFFERET COMPUTER. The first one was windows XP, this one was Windows Vista. I only got 1.86 GB of data before it write protected itself too! =[ I have tried to run all the command prompt solutions and tried to fix this through my Reg Editor. I have downloaded a few of the re-flashing tools, but none have worked. I have yet to try Linux on either of these, but it seems like they are completely corrupt and nothing else will work. I will let you all know today once I get to borrow a Linux machine.

  25. Corey Haertel
    February 10, 2012 at 1:13 am

    This question was never resolved, I don't know why it says it has been. Is there a way to change it to unresolved?

    • Anonymous
      February 10, 2012 at 10:09 am

      if you have windows cd, first insert usb key and then boot on windows cd, then act like you will install windows but on usb key and choose format usb key.

    • Kmark332
      February 10, 2012 at 10:59 am

      I would really like to know how this gets fixed.  I had the same thing happen to me yesterday.  I plugged in a 4gb robust on a vista system at school and it said it was write protected.  I went home and tried it on my win7 and it doesn't even recognize that it's there. I don't even get an icon to remove it. I still get a series of lights on the flash drive itself when I plug it in.   I used it as a backup for my laptop and for word docs, there was still over 1gb left (I am not sure exactly because I cannot retrieve any info...according to laptop it doesn't exist)  I am going to get a new one today and start over on what I have to but I would like to have a way to get the original data back.

    • Ed
      February 11, 2012 at 11:43 am

      It is possible that one of the flash chips broke down (usually there are two) since formatting and repartitioning didn't work. It is also possible that you got one of those fake usb flash drives. These are flash drives marked and being sold as 8gb but in fact only 512mb/1gb/2gb or in your case 4Gb. 
      Since thinkgeek is a reputable website, I think it is the former. The only way to fix your drive is to reflash its firmware. You need two programs: 

      1. Chipgenius: http://www.4shared.com/file/224703245/544bd14b/ChipGenius.html

      You need that to identify the VID and PID number of your drive. Insert your flash drive, run the program and take note of the value of these two.

      2. FC Mptool: http://www.4shared.com/file/224707449/d6127685/FC_MpTool_FC8308_FC8406_v20200.html

      This is the reflashing tool. Run the program and follow the screen. If it ask for username and password, you can leave it blank. You will need the two numbers here (VID & PID). If this version of MpTool didn't work, just search 4shared for other versions. There are several available. 

      Chances are you will just recover 4Gb of your drive (if one chip is bad), but at least it will be usable. But if you're lucky you will get the 8Gb back.

        February 15, 2012 at 9:58 pm

        I attempted to run the 'Chip Genius' program, but unfortunately I get an error, "Run-time error '53' File not found" when I select ok, it closes the program. It gives me this same exact error when I run the program with no usb devices plugged in. If i can not get the VID and PID then there is not much hope for reflashing the device is there? Also, would the VID and PID be the same on another of the exact same USB? I have a replacement since I got this for christmas, so I'll have a second very soon, but I don't know if the VID or PID changes at all. Sorry everyone that I can't be more adament about trying all these selections, I have been very busy with work and school, but I'm trying all these solutions as fast as I can. Thank you all for your patience.

        • Ed
          February 16, 2012 at 10:33 am

          I forgot to say, I use this program in my Windows XP box. I remember having problems with it in Windows 7.

        • Corey Haertel
          February 16, 2012 at 2:10 pm

          Chip genius worked on vista, FC Mptool did not however. It tells me, "NO LOADER IMAGE FILE!" Also, the latest mystery; I got a replacement and went straight to copying music files, just like the first, and it was transferring very slow. Slower then normal. a few hours into transferring it froze and gave me the same error as I got the first time. I removed the drive and re put it back in and run a scan and automatic fix on my computer. It scanned completely and said it fixed the errors. I checked to see if it was still write protected and I was able to copy a picture to the disk. BUT nothing else would copy. After that picture it told me everything else was write protected. Now it is locked like the first one. I can't remove add or anything. After I removed the drive and put it back in a second time it never said the picture was actually put on. I tried these programs on them, but the FC Mptool did not launch successfully. Also I was transferring files from a DIFFERET COMPUTER. The first one was windows XP, this one was Windows Vista. I only got 1.86 GB of data before it froze too! =[

        • Ed
          February 16, 2012 at 11:36 pm

          Looks like it's a bad batch of drives. Might be lemons.

        February 15, 2012 at 10:19 pm

        Also I attempted to run FC_MP Tool, but it did not even recognize there was a disk drive to select. All the buttons and fields were greyed out and the only thing I could do was close the program.

    • Tina
      February 11, 2012 at 7:35 pm


      the question has been marked as unresolved. Please update it or let us know once it was resolved. Thank you!

    • dcm
      February 11, 2012 at 8:17 pm


      ive been having the same problem exactly as what youve described in the first post for 2 months. i did everything what you did with no success.

      i usually listen to mp3 files from 8gb kingmax (super stick mini) with no prob until one day i got write protected error from winamp. and the problem went on that i could only read the usb drive but nothing else (no delete no format etc)

      i could imagine how frustating it was for you because i also carry around my daily work files in that usb drive.

      i just solved my problem and really happy :-) to share it with you and others. i hope it will work the same as it did with my usb drive.

      [Broken Link Removed]

      "It's in Korean or Chinese - forgive and apologies on my lack of knowledge in language matters ;-( 
      I downloaded UFix Rar? using the Green download image on the page and after extracting it had
      an english How To pdf attached."

      the original post is here

      good luck

        February 15, 2012 at 10:16 pm

        I just tried this program. I was very excited because last time my device broke (Dingoo a320) I got a foreign program I couldn't understand, and that was the one to finally fix my program. Alas, this was not the case this time. =[ When I run the program it has no options under "control disk" and the only buttons are recover and exit. When I press recover, even though there is no disk selected, the program freezes and I have to open task manager to end the process, just to get it to close.

    • David Holliday
      February 18, 2012 at 10:07 am

      I am experiencing the same problem with a 2GB flash drive and have tried all the things mentioned above. Does anyone have any other ideas, there must be a solution out there. I know it is simple enough to throw it away and get another flash drive but surely there is a challenge here for someone to resolve. Suggestions still welcome even though it suggests that the issue is resolved.

  26. HLJonnalagadda
    February 9, 2012 at 3:24 am

    If that does not work, connect the USB stick and then boot into Safe Mode with Command Prompt
    Booting into safe mode can be done by hitting F8 during normal boot.

    After booting into safe mode, start the console, enter C:windowssystem32>G: , where G is the drive letter for the USB.

    Then enter G:>format G: and hit enter.

    Hit Y after the disk format message.

    That's it.

    • Corey Haertel
      February 10, 2012 at 1:19 am

      I could not figure out how to boot into safe mode with command prompt. If I boot my computer in safe mode there does not appear to be anywhere I can enter C:windowssystem32>I tried to boot the USB from the original safemode boot screen and it gave me the message, "Selected boot device not available."
      I am not familiar with safemode, so perhaps I am doing something wrong.

      • Anonymous
        February 10, 2012 at 4:51 am

        Try hitting F8 or F10 continuously during the boot initialization.

      • Anonymous
        February 10, 2012 at 4:51 am

        Try hitting F8 or F10 continuously during the boot initialization.

    • Corey Haertel
      February 10, 2012 at 1:21 am

      Also, if I simply enter C:windowssystem32>b: into the command prompt, (b: is the drives letter) it gives me the message, "access is denied."

  27. HLJonnalagadda
    February 9, 2012 at 3:14 am

    Maybe the write protection of USB devices has been changed in the registry.
    Try undoing that.
    Hit regedit into the run command,Windows+r, to go to the registry editor.

    Navigate to:


    If this key does not exist, create one called StorageDevicePolicies. Select the key afterwards and right-click into
    the right window. Select New > Dword (32-bit) Value from the context
    menu and name the entry WriteProtect.
    the new entry afterwards and change the value from 0 to 1. A value of 1
    disables writing to all connected USB devices. If you want to enable
    writing again you need to change the value of the key to 0.

    • Corey
      February 9, 2012 at 10:43 pm

      I tried this, on 2 seperate computers. (one was Windows 7 and one was Windows XP) However, nothing appeared to change.

      I have yet to try any of the other suggestions you all left me. Thank you all for taking time to help me find alterantive ways to fix my flash drive.

    • dhor_ph
      May 23, 2012 at 6:03 am

      i tried this on my windows xp computer and it works great, thanks and God bless!

    • Eva
      June 20, 2012 at 9:53 am

      Thank you! I tried this on my PC running XP and it worked :)

    • Joe
      June 30, 2012 at 8:57 pm

      Worked like a charm for me! Thank you!!!

    • Aqqin
      August 24, 2012 at 1:54 pm

      It worked! You're the best, niqqa.

    • ranceli
      September 19, 2012 at 12:17 pm

      thanks bro. this procedure helps me in my problem.. try this one. it really worked perfectly.. just key in the value of 0 then remove your device. now insert it again then try formatting it. thats it!

    • cchalkdust
      September 30, 2012 at 12:30 pm

      Thank you for the advice! +1 for you.

    February 9, 2012 at 1:31 am

    Hello, visit next link and download the apacer formatting utility.  There are other things you could try in the article but from what you say, you already try: 


    You could also try the following low level formatting tool:


    Also HP USB Storage format tool:


    • Corey Haertel
      February 10, 2012 at 1:52 am

      I tried all three methods listed in the first link you provided. I attempted to use Apacer Formatting Utility, but I get the message,“Device Not Found/nPress any key to continue. . .”It exsist the command prompt as soon as I press any key. I tried several times and the same thing happend.

      When I downloaded the HP USB Storage Format Tool, it gives me the error, "Device media is write-protected" I tried all options available, but all gave me the same error message.

      However, Thank you for taking the time to find all these links and formatting tools for me!

      • FIDELIS
        February 10, 2012 at 7:51 am

        Hello, you could also try the tool shown in the link below.  It is for extreme cases.  If this does not work, I would say the only thing you would have left to do would be to use a linux live CD or gparted itself:


          February 15, 2012 at 10:34 pm

          I tried this and after I ok it to execute and erase the partition it gives me the error, "WRITE ERROR (MBR WRITE PROTECTED?)!" then it gives me a second error, "Error 7 Write error returned by RMPARTUSB." right after the first error. I think it is time to start borrowing Linux to end this game.

        • FIDELIS
          February 15, 2012 at 10:55 pm

          Yes, after everything you have tried, I would say that is one of the few options left. 

          This is a shot in the dark, but you never know if it will work or not. Have you heard of DBAN (Darik's Boot and Nuke)? It is a zero level tool for harddrives. You would have to download and burn a CD/DVD or a USB flashdrive and run it from there. Connect your USB drive and see if this tool can clean your portable:


        • Vulcanit3
          May 16, 2012 at 5:33 pm

          Nope, i have a similar situation and I also thought that linux would fix it (Sandisk Cruzer Blade 16GB) unfortuantly linux was not able to format it either. Just the plain error of "Unable to format. Disk is write-protected"
          Im thinking that these were a fail batch of drives

  29. Anonymous
    February 8, 2012 at 8:18 pm

    1. Start > search bar -> CMD and press enter
    2. type< diskpart
    3. type< list disk
    4. type< select disk # (# is the number of the USB key)
    5. type< attributes disk clear readonly

    Fix USB Flash Drive Detection Problems With EaseUs Partition Master

    if you suspect that hidden virus is there
    1. Go to control Panel, Folder Options -- select VIEW--- select Show hidden files and folders and uncheck Hide protected operating system files
    (recommended)  click APPLY
    2. go to your USB  delete virus and all the shortcut folders that have
    no data in them. create new folders (give the same name as your normal non infected hidden folders) and copy the data from YOUR hidden folders
    into them. once that is done delete the old hidden folders.
    3. enter task manager--- find the virus program that is still running which will have the same name as the one you just deleted off the usb key
    4. go back to control panel, Folder options select view- select DO
    NOT show hidden files and folders and recheck Hide protected operating system files (recommended).

    autorun eater

    • chaertel
      February 10, 2012 at 12:57 am

      Only one disk shows up in DISKPART> and that is Disk 0 which is online and has 74 GB so it is definately not that one. I HIGHLY doubt it is a virus, I have had these files for a long time and never had a problem transferring them between flash drives.

      • Anonymous
        February 10, 2012 at 10:04 am

        Have you tried diskpart on windows 7 and xp?
        DiskPart - Removing ReadOnly Flag from Volumehttp://blog.patricknielsen.net/2010/02/diskpart-removing-readonly-flag-from.html

        have you tried  EaseUs Partition Master? to see if it detects usb key

      • jey
        August 3, 2012 at 12:28 pm

        wat it means usb is unreadable?

    • Damian
      June 22, 2012 at 10:04 pm

      i did the command prompt and it said it did it sucessfully, but the flash drive is still write protected.. is there a step i missed? if it helps any i am using a 8GB EMTEC on Windows 7 home premium computer.
      please help me.

    • dj
      October 15, 2012 at 7:16 am

      it didnt work for me ;(

  30. Anonymous
    February 8, 2012 at 6:50 pm

    First, What is on the drive? Did you try to image it or anything like that?

    Have you tried it in another computer?

    If you have a linux machine, I would recommend gParted to try to format the drive.

    • Corey Haertel
      February 10, 2012 at 1:25 am

      I have put MP3 files on it, but there were a few album cover pictures that made it on as well.
      I have tried it on 4 computers now. Windows XP, (2 different)Windows 7, and Windows Vista. I have not tried it on Linux, but if none of the other solutions work, I will attempt to borrow my brothers computer and format with a linux machine.

      • Anonymous
        February 10, 2012 at 1:45 am

        Hmm. Ok, Keep us posted, Also when you do try the format follow the article I linked to. 

        • chaertel
          February 16, 2012 at 5:37 pm

          Tried on Linux. It just says write protected and will not let me do anything. I tried gparted and everything. Thank you, but I'm starting to think it is corrupt for good and I just have a flash drive of music I can't change.

        • dee
          August 8, 2012 at 7:26 am

          i've tried linux, assuming linux won't read the protection used in windows. IT'S USELESS....

Ads by Google