How can I fix wireless connectivity problems in Windows 7 64-bit?

Rishav May 16, 2011

I am using 64-bit Windows 7 on a Dell Studio15. Wireless connections keep losing base after every 5 minutes. I have to disconnect and reconnect each time for it to work for a few more minutes. Wired connections have no problem whatsoever.

Also, I have Ubuntu on Windows, where both connections remain stable.
Is there a solution to this?

  1. Rishav
    May 23, 2011 at 9:29 pm

     It's really working great!! 

  2. Rishav
    May 23, 2011 at 9:28 pm

    I just updated the BIOS. Net seems to work fine now! 
    I'll update you guys if something creeps up.

    Thanks a lot FIDELIS!

    • Tina
      May 23, 2011 at 10:22 pm

      Thanks a lot for the update, Rishav!

      May 26, 2011 at 5:04 am

      Hello, glad it worked out for you.

  3. Rishav
    May 23, 2011 at 9:07 pm

    Sorry for the delay. Had my exams going on.

    First of all, thanks a lot for your inputs. I just updated my driver, does not help. 
    Have checked with all my other friends, they have the same settings. 

    The links provided to the BIOS knowhow do not work, although I have downloaded it. Is it necessary, at all, to back up the BIOS

  4. Tina
    May 22, 2011 at 4:54 pm


    were you able to solve your issues with your Windows 7 wireless connection? Please do let us know what did the trick or whether you need more help. Thank you!

    May 17, 2011 at 10:57 pm

    Hello, this is the link for Dell driver downloads for you laptop Dell Studio 15.  Double check it is the right model and download  the open box that says BIOS.  Check the BIOS number you have installed and if it is the same as the most recent one do not bother downloading it.  This is the link:

    When updating your BIOS, your laptop has to be connected to an outlet....not on batteries.  Manufacturers usually provide an utility to flash the BIOS.  It is the safest way to do it because it usually creates a backup of the BIOS version installed in case you have to restore it.  As a warning, if something goes wrong when updating BIOS, it can make your computer unbootable. 

    The following link explains how to install BIOS.  It is the link provided by DELL so you should be safe by following the instructions posted there.

    Is it possible for you to find out if the network you are using is configured as a N network or configured as a mixed one?  If it is an N network means that all the devices connecting to it have to be N compatible.  If it is a mixed network, devices with b/g/n can connect to it. 

    You could also try disabling IPv6 on your laptop.  The only downside of this would be that you would not be able to share files and printers on your network.  Now that I think about it, you are saying that other people with same model connect to the network without a problem.  Have you tried comparing your laptop's settings with theirs?  See if you can get somebody's laptop similar to yours and check their settings with yours.  If there is a difference in settings change your settings so that they are same as theirs...after all their settings are known to work.

  6. Rishav
    May 17, 2011 at 1:28 pm


    The security is compatible, it's wpa2 (AES-encrypted)on both my system and the router. I am using my college wi-fi so I do not know the kind of router they are using.Many of friends are using the same model without any hitches. I even got my network card replaced(twice) but that did not solve the problem. Clearly, it is an OS issue, because the net works perfectly with ubuntu.The power settings are max performance and the driver is Intel Wifi Link 5100 AGN- (release date jan 2010). It appears to be the latest driver.I've not mingled with my BIOS before, so i feel a bit skeptical on this part. I googled it, but there is not enough material on how to handle it. Can you please help me out here.Thank you for your time.

      May 17, 2011 at 11:12 pm

       Hello, can you check the setting on your wireless card to see if they match the following settings?

      -- Open Network and sharing -- select change adapter settings-- right click on your wireless card and select properties-- select configure-- select advance tab-- select IBSS mode and verify that it is set to 802.11a/b/g/n Auto-- click OK

      • Rishav
        May 23, 2011 at 8:58 pm

         The settings are exactly as above mentioned. no problem there

    May 17, 2011 at 12:23 pm

    Hello, as you may know, windows 7 comes with two TCP/IP protocols working by default(IPv4 and IPv6).  Go into your TCP/IP settings and make sure that both protocols have dynamic addresses on them and not static addresses.   Also make sure that all your drivers are up to date. 

    What kind of a router do you have?  What kind of encryption do you have enabled?  Is there another computer on your network that does not loose wireless connection?  Also make sure that your router has the latest firmware installed.  If your router does not have the latest firmware, it might not be compatible with the encryption you are using.  For example you might be using wpa2 and your laptop and because your router does not have the latest firmware, it is not able to use wpa2, only wpa or wep.  If you have wpa encryption, make sure you use the wpa with AES and not wpa TKIP.  Try to use wp2-AES.

    Are you connecting to a hidden network?  If you are, set the router to broadcast your network and connect to it.  Make sure to set the encryption and save it.  Once you are connected, you can hide the network again if you like.

    Also you could try updating the BIOS on your laptop.  Go to the computer's manufacturer  site and download the most recent BIOS file they have.  Make sure that it is the right BIOS for your computer and then install it. 

    Try changing the encryption you are using from wpa2 to wpa and then check if it still looses your connection.  If it still looses access try changing it to wep and try again.  This is just a trial, if you can help it stick to using wpa or wp2.

    Also you might want to check your power settings.  There might be settings enabled that are causing your wireless to go to sleep.  Go into your power settings for your wireless and if available set it to maximum performance.  Also make sure that the option allow the computer to turn off device to save power is unchecked on the device manager.  Hope it helps,


Ads by Google