How can I fix a Windows 7 update error 80072EE2?

Vijaynand Mishra September 17, 2012

I want to resolve the issue of error in Window Update error 80072EE2. I tried every possible way, but could not resolve it. Please suggest! This is for Window 7 Professional .

  1. Andreas
    November 15, 2012 at 8:32 am

    On my (company) machine there was a proxy set for the system (not in IE):
    "netsh winhttp show proxy" showed it. Had to "netsh winhttp reset proxy" to take it out.
    After that Windows Update worked again.

  2. Igor Rizvi?
    October 3, 2012 at 11:12 pm
  3. Alexandros Dakos
    October 1, 2012 at 6:27 pm

    this is probably temporary i have encountered it too. Just wait and it will in most cases be fixed on it's own.

  4. Jarvis Dettmering
    September 25, 2012 at 4:00 pm

    Do you might have a spam problem on this internet site; I also am a blogger, and I used to be questioning your circumstance; we've designed some good techniques and were looking to exchange possibilities with other men and women, be positive to blast me an e-mail if significant.

  5. Dimal Chandrasiri
    September 20, 2012 at 5:43 pm

    If you receive Windows Update error 80072ee2 while checking for updates, the Windows Update servers might be experiencing an unusually high number of requests for updates. Close Windows Update, wait 10 to 15 minutes, and then run Windows Update again. You can also wait for Windows Update to run at its next scheduled time.

    trying to save your time reading the windows forum! :)

  6. Dave Rimmer
    September 19, 2012 at 4:18 pm

    Have you solved this problem yet looks like you have had lots of help if not here is another link for you -

  7. susendeep dutta
    September 18, 2012 at 11:23 am
  8. ha14
    September 18, 2012 at 8:41 am

    Windows Update error 80072ee2

    Windows Update Microsoft Solution


    on cmd type
    regsvr32 jscript.dll and hit enter
    regsvr32 oleaut32.dll and hit enter
    repeat with the rest msxml.dll, bscript.dll, softpub.dll,wintrust.dll, initpki.dll, cryptdlg.dll.

  9. ahmed Fouad khalil
    September 18, 2012 at 4:31 am

    their is aproblem in the site, i make the post one time but after refreshing the page i found a repeated post many times also my name and acount data is avaliable as will as my point but the site still insest to ask me to log

    • Tina
      September 29, 2012 at 3:07 am

      Your duplicates have been removed. Sorry for the delay!

  10. Ravi Meena
    September 18, 2012 at 4:16 am

    you need to delete temprory update files

    1) Open Computer by clicking the Start button , and then clicking Computer.

    2) Double-click the local hard disk where Windows is installed, typically drive C.

    3) Double-click the Windows folder, and then double-click the SoftwareDistribution folder.

    4) Double-click the DataStore folder to open it, and then delete all files and folders in the folder. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    5) Click the Back button. In the SoftwareDistribution folder, double-click the Download folder to open it, and then delete all files in the folder. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    • ahmed Fouad khalil
      September 18, 2012 at 4:26 am

      Just go back to last check point of windows before update and try again with the windows update

  11. Bruce Epper
    September 18, 2012 at 3:05 am

    Have you tried the possible solutions presented here? It appears that it is timing out when attempting to contace the update servers. Is your firewall getting in the way? Antivirus/antimalware software? Instant messaging? Download or internet accelerators? Proxy server?

  12. Mike
    September 18, 2012 at 12:43 am

    According to Microsoft it's a problem with contacting the update servers.

    Try to visit to see if you can get there in general.

    Other then that I recommend the following tool. If there is a problem with Windows Update itself this should fix it.

Ads by Google