How can I fix my iPhone 4 stuck in DFU mode?

Anthony S October 14, 2011
Ads by Google

I currently have an iPhone 4 Verizon that I believe is on 4.2.9 or 4.2.10. It shows with Tiny Umbrella iPhone4CDMA 4.2.10 (8E600)-3879313118606 and iPhone4CDMA 4.2.9 (8E501)-3879313118606. Unsure which, since I can’t load the phone.

I used the, I went to Restore phone to remove the JailBreak. Kept receiving errors, unable to connect to device when the Apple sign came up during restore and iPhone was being prepared with the little loading bar that wasn’t filling up. Eventually I tried Tiny Umbrella and it got Stuck in DFU.

Now I am unable to Exit Recovery/DFU mode with or without Tiny Umbrella. While using Umbrella’s Fix Recovery option, it loads a black screen with a lot of coding and just stays there or goes to a white screen and stays there.

Any detailed steps would be very much appreciated.

  1. sheraz
    May 12, 2012 at 4:54 am

    yesterday i tried to upgrade my iphone 3gs 8gb from 4.1 to 5.0.1 with preserved baseband (06.15.00) using redsnow. everything was fine till i click cydia in my phone which tried to download packages. i left my mobile in that and when came back to see, the phone screen was black. then i know that my phone is in dfu mode. i tried in redsnow to boot it but white screen nothing ahead. while itunes keeps on different errors every time i try to restore from custom ipsw. the good thing is itunes recognize that my phone is in dfu mode. so now i cant boot my phone in normal mode and cant restore it from itunes. i tried differnt softs to exit recovery mode but no luck. i am in win7, itunes 10.6 (latest from apple website). plz help

    • Susendeep DUtta
      May 12, 2012 at 2:41 pm

      Connect your iPhone to PC,hold down power and home button together for 15 seconds and then hold only home button for 10 seconds.iTunes will detect your phone and will start the recovery process.

  2. Kamalpreet
    March 26, 2012 at 10:47 am

    Aight so what happened to me was i tried to downgrade to ios 5.0.1 but my iphone 4s was stuck in dfu mode, what i did was plug it in and let it connect to itunes and i clicked restore. Now while its preparing to restore hold the power and home buttons down and it should work :).

    • TimTomTam
      April 19, 2012 at 11:32 pm

      THANK YOU!!!

    • sam
      May 9, 2012 at 11:07 am

      Thanks so much, my phone just booted.

    • Disy
      May 11, 2012 at 6:26 pm

      I just wanted to say thank you so so so so much!!! I had this same problem and was able to boot my phone back up using this trick. THANK YOU!!!!!

    • Tommy
      May 19, 2012 at 10:20 am

      Thanks a billion!!!!

    • Prettiestinpink
      May 24, 2012 at 10:46 pm


    • hello
      July 14, 2012 at 1:40 pm

      thanks a trillion buddy!!!!!!

  3. Jay
    October 15, 2011 at 6:28 am

    Did you try restarting the phone and holding the power button for some time?
    If Itunes can detect your phone, then you can restore it.

    Download a firmware from the link below and restore.

    video guide :

  4. Mike
    October 14, 2011 at 7:22 pm

    You can try to enter the normal DFU mode right after using the "Fix Recovery" option

    1. open iTunes
    2. use the "Fix Recovery" option in Tiny Umbrella
    3. immediately press and hold Sleep/Power and Home button for 10 seconds
    4. release the Sleep/Power button but keep Home pressed

    If it worked the iPhones screen should be black and iTunes should tell you that it has detected an iPhone in recovery mode.

    At this point it us up to you what you want to do. 

    My personal suggestion is to go back to vanilla iOS by removing the Tiny Umbrella or any other Jailbreak hosts file entries and do a regular restore via iTunes.

    If you attempt another jailbreak I suggest to carefully read about supported devices and firmwares because JailbreakMe only supports iPhone 4 CDMA 4.2.6-4.2.8 ~ none of which you listed for your iPhone.

Ads by Google