Where can I find Linux mint drivers for my Dell Inspiron network card?

andy September 25, 2010

I have installed Mint 9 on my Dell Inspiron n3010 and it does seem to recognize neither my network nor my wireless card. As such, I have no access to internet unless I boot Windows.

Any idea how to handle this?


  1. Fucxk
    October 8, 2011 at 11:55 pm

    holy fuck back to windows

  2. Yash
    February 18, 2011 at 11:02 am

    No, that didn't work me.
    When I rebooted, my wired internet was still not working...
    What have I done wrong ?

  3. Andy
    February 17, 2011 at 7:16 pm

    Yash, frankly I no longer remember all the details but try the advice from http://ubuntuforums.org/showthread.php?p=9449490 and let me know how it goes. Then,if you have a functional network card download the wifi driver and run it (see below)

    Faiz,I am away from my laptop but if you go to the Dell website and provide them with your service number the site will provide you a list of compatible Windows drivers. Just try everything with wifi in it.

  4. Yash
    February 16, 2011 at 6:42 pm

    Hey, I'm having the same problem on my Dell laptop.
    Could you please explain how you manged to resolve your problem ?
    Thanks in advance...

  5. andy
    October 11, 2010 at 5:34 pm

    I got it. I used this solution (http://linuxwireless.org/download/compat-wireless-2.6) for nerwork while for wifi I manually found the inf file after unpacking the windows driver on the dell site and double-clicked it to run in terminal.

    • Faiz
      October 12, 2010 at 2:07 am

      Andy I'm glad to hear that you found a way to use your wireless as well as your network. I have the exact same dell n3010 and have been facing the same problem as yours. Could you tell which driver on dell site did you download?

  6. andy
    September 27, 2010 at 9:51 pm

    OK, so i tried something similar to this:
    "It will say searching for hardware drivers. Then when it comes up click on your wireless driver which I am assuming it is the Broadcom STA wireless driver."
    Only that, since I cannot connect to anything via cable I made a print-screen of the error message and downloaded the drivers manually from ubuntu.com from a different system.
    now the driver manager says:
    "These package contains Broadcom 802.11 Linux STA wireless driverfor use with Broadcom's BCM4311-, BCM4312-, BCM4321-, andBCM4322-based hardware.
    and then below
    "drivers activated but not in use" (see http://imgur.com/EhEkR.png).

    I would guess the reason I am not able to use my wireless driver is because i have no network capabilities in the first place (the other half of my problem)

  7. Anonymous
    September 27, 2010 at 8:22 am

    did you tried http://sourceforge.net/projects/ndiswrapper/

    can you try this method

    read https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

    All you need to is find the Windows wireless driver .inf file somewhere on your hard disk. And that's it. The long manual configurations are no longer needed. That's it.

    or open a terminal: Some reported that making audio louder has fixed wifi
    sudo apt-get install linux-backports-modules-alsa-lucid-generic
    sudo kate /etc/modprobe.d/alsa-base.conf
    options snd-hda-intel model=basic

    possible this, It should work regardless of the distribution.
    follow the instruction in the txt file

    Try this open up a terminal and type

    sudo apt-get update

    Then let that run then when connected with an ethernet cable to your router go to

    system>administration>hardware drivers

    It will say searching for hardware drivers. Then when it comes up click on your wireless driver which I am assuming it is the Broadcom STA wireless driver.

    Click on it and on the bottom right of the box there will be a button that says activate. It is very important that you are connected to your router with an ethernet cable so that you can download the driver and it will activate it once it is downloaded and you will be able to use your wireless.

    go into Synaptic Package Manager and search for "broadcom". After reinstalling those drivers, reboot, and the system will find the wireless drivers with no problem.


    The Dellâ„¢ 2.4/5 GHz WiFi Link 5100 Wireless-N Half-Height Mini-Card is an ideal solution for your wireless networking requirements. It supports 802.11a/b/g modes as well as 802.11 draft n networks

    KNetworkManager :http://kde-apps.org/content/show.php/KNetworkManager?content=46395

  8. andy
    September 26, 2010 at 7:48 pm

    Thanks ha14. I do not have a dial-up connection to the Internet. I have a cable connection to which I normally connect via wireless (if needed i can plug in a cable however).

  9. Anonymous
    September 26, 2010 at 9:50 am

    start a terminal session, then type: iwconfig or ifconfig you might see something like: eth0 (this is your ethernet port) lo (this is your local loopback) and possibly wlan0 (this will be your wireless card).

    Identify the modem with the ScanModem tool or wvdialconf.
    Download, configure and install driver. If needed, it's often more economical to buy an easy one.
    Configure the dial-up connection to your provide

    or Ndiswrapper

  10. Andy
    September 26, 2010 at 7:54 am

    I guess this makes sense...

    I found:
    Atheros AR8152 PCI-E Fast Ethernet controller
    DW 1501 Wireless-N WLAN Half-Mini Card

    And also:
    Microsoft Virtual Wi-fi miniport adapter
    Broadcom Virtual Wireless adapter

    Hope I am giving the right knfo

  11. Tina
    September 26, 2010 at 6:10 am


    for users of your Dell Inspiron model this might be obviousl, but for everyone else, could you please specify the network card in your computer? Thank you.

Ads by Google