Why is the file system on my USB pen drive not recognized?

Bakhtier April 9, 2011

I have USB pen drive Silicon power 4 GB. Recently, I had a problem with it. When I plug it in, it showed that software is installing. On my computer it displayed as removable drive, but by double clicking I get a message insert a drive and properties showed that it is unrecognized file system and with 0 bytes data. How can I restore my pen drive?

  1. Bharathi
    March 24, 2012 at 8:38 am

    When i insert my pen drive in a system  after i open its formatting how to solve this..

  2. Tina
    April 16, 2011 at 4:23 pm

    Thanks a lot for your response and sharing the file! Unfortunately, it can only be downloaded by RapidShare Pro members.

  3. Bakhtier
    April 11, 2011 at 7:57 pm

    I have tried in another PC, and in Mac as well. No result. I couldn't wait till everyone writes me a solution. I went to IT guy, and he restored my USB drive. Now it works. I lost all the data. I don't know what he did. But as soon as I will get the info. I will let know everyone.

    • Tina
      April 11, 2011 at 8:07 pm

      Thank you for the feedback, Bakhtier! Looking forward to hearing what the IT wiz did with your flash drive to fix it. :)

  4. Anonymous
    April 11, 2011 at 1:52 pm

    Hope that your usb key is not broken one.

    Have you tried your usb key in another pc, if there works then just format it and ty it again on your pc.

    USB port may stop working after you remove or insert a USB device

    you should try shutting down the computer and literally disconnecting the powercord from the powersupply then reconnect after a few minutes and start up the computer again!

    JetFlash OnlinE Recovery from Transcend

    Neo 9 tool

  5. Peepen_skaunt
    April 10, 2011 at 1:20 am

    you can try CHECK FLASH. you can find more information and the DL link here: http://mikelab.kiev.ua/index_en.php?page=PROGRAMS/chkflsh_en - hope it helps.

  6. Anonymous
    April 9, 2011 at 7:52 pm

    Make sure that the lock/unlock switch (if present) is set to the unlock position

    The best will be to format it again, choose FAT32 system file.
    HP USB Disk Storage Format Tool

    • Greenway256
      April 10, 2011 at 12:18 am

      Once/before it's formatted, you can try some data recovery tools to try and recover any data you had on it.


    • Bakhtier
      April 10, 2011 at 6:17 am

      One more point, I can't format it! It just says please insert drive.

    • Bakhtier
      April 10, 2011 at 9:10 am

      Here is the detailed explanation of my error without a solution. Who can give me the exact step by step solution?

Ads by Google