Why can I not extract zip file contents to C:\Program Files in Windows 7?

Rob April 30, 2011
Ads by Google

I’m trying to embed subtitles into an avi file using VirtualDub.

I have to create a folder called ‘virtualdub’ in ‘C\program file’ and then unzip the contents of the ‘virtualdub’ zip. I get “ACCESS DENIED” when I try. I can create the folder there, and extract the contents anywhere else on my hard drive, just not to C\program file\virtualdub.

I’m using Windows 7 64 bit. I’ve tried putting the zip file inside C\program file\virtualdub and extracting there. Can’t do that either.

If I right click on the zip file and select the security tab, I have ticks for all options except for ‘special permission’ for ‘system’, Rob(Rob-PC\Rob) and Administrators(Rob-PC\Rob).

I have tried yelling “You work for me!” at the computer, but it hasn’t made any difference. Does anyone have any ideas?

    May 1, 2011 at 7:54 am

    Hello, I use virtualdub and virtualdubmod a lot. I have it running on windows 7 32 and 64 bits computers and also on vista and xp pro. You are trying to do your installation wrong. You do not have to create a folder for virtual dub on the Program Files folder. The main reason for this is that virtualdub does not need to be installed because it is a portable application....it needs to be executed/run. Everytime you need to use virtualdub, just double click on the executable file and virtualdub will open. These are the steps for using virtualdub

    -- download zip file
    -- unzip file to C: drive (or any drive/folder you want)
    -- when file is unzipped, it creates a folder named Virtualdub-1.8.1. The numbers refer to the the version of virtualdub you downloaded
    -- navigate to the place where you extracted the folder
    -- open the folder
    -- double click on the VirtualDub.exe file
    -- virtualdub opens and you are on your way.
    -- if you have extra filters, you unzip the file and copy/paste the .vdf file to the plugins folder located inside the VirtualDub-1.8.1 folder.
    -- to make it easier to access the program itself, pin it to the taskbar and you are set.

    With regards to creating folders on the Program Files folder, only programs installed on your computer will create folders there by default. Also, you do not need to be playing with permissions with regards to virtualdub, once you click on the executable you are on your way...unless you want to block other people from using it. Hope it helps,

    • Send_more_spam
      May 2, 2011 at 12:14 am

      Thanks for your help. So, ok i don't need to install it in a folder in program files. I was only following instructions from a tutorial which rather annoyingly, showed what he was doing as he did it and his 'extracted bits' clearly went into the folder he had created.
      After trying to extract to my created folder in prog.files, and failing, i created a folder called virtualdub in C drive but outside of prog.files. I then created two folders inside that one. I called one virtualdub, and put the zip called 'virtualdub-1.9.11zip' file inside and extracted the parts in the folder. In the other folder, which i called 'plugins', i put the zip file called 'subtitler-2-4zip' inside and extracted it's bits.
      I opened the video file and subtitles but could only get as far as the last stage. The stage where you can preview the final stage, but when i clicked on 'something' i'd get the message like 'can't find ''something'.exe in folder'. So i gave up, asked this question and uninstalled it all.
      I've just reinstalled it with the subtitler folder inside the folder with the extracted virtualdub files.
      Now, i click on File...open video file...(click on the avi file) and then ...open,
      i get this message from virtualdub:

      "Couldn't locate decompressor format 'XVID' (unknown)
      VirtualDub requires a Video for Windows (VFW) compatble codec to
      decompress video DirectShow codecs, such as those used by Windows
      Media Player, are not suitable."
      I'm sure i have only uninstalled the virtualdub and subtitler programs yesterday.

      It looks like somebody just extended the tunnel, of which i could see the light at the end of, by another mile or so...

      The video file is an avi which is set to play using vlc player as default, lke it was yesterday.
      I really hate computers. They make me feel dumb and my head hurt!

      • FIDELIS
        May 2, 2011 at 9:03 am

        Hello, if that is the error you are getting what you have to do is download the xvid codec and also it would be good to get the k-lite codec pack. The k-lite codec pack comes with all the codecs you need for VFW. Go to the following link and you can get the xvid and also k-lite codec pack

        Another thing, you do not need to create the folders. Once you extract virtualdub it will create the folders for you. Just remember where you extracted the folder and navigate there. Open the extracted folder and you will find a plugins folder already there. Extract the subtitler-2-4zip folder and then open it. Copy the file with the extension .vdi to the plugins folder and that is it. Good luck

        • Send_more_spam
          May 3, 2011 at 11:21 pm

          I've just realised that i haven't mentioned that i am using DivXLand Subtitler 2.0.7
          Have you been assuming i have or are you now shouting explitives at the monitor? The last stage where it all goes tits up is when i try to embed the subtitles and i'm then asked where the virtualdub.exe is. I asked one of the I.T. guys at work today about how to extract to the program file. I'd been checking the security tab on the zip files, he suggested checking it out on the folder i've created in the program file on my C drive. So i can now extract to my program file on my C drive. But it still doesn't create the plugins folder by itself. I have to do that. It doesn't matter where i create a folder and extract to, or let the zip file extract to it's own folder. Still no plugins folder inside. Divxland can't find the virtualdub.exe file no matter where i put it!
          In your last attempt at curing me of stupidity, you say to 'Copy the file with the extension .vdi to the plugins folder'. Did you mean the 'Subtitler.vdf' file? I don't have a .vdi file in the subtitler-2-4zip folder, but i do in the virtualdub folder. Anyway, i've put a copy into both folders and it still doesn't work.
          Are you using JUST virtualdub to add subtitles?
          Can it be used to embed subtitles onto vodeo by itself?
          When i've started it i can see how you import the video clip but i can't see how to import a subtitle file.
          I thought this was going to SOOOOOOOOOOOOOOOOOOOOOOOOooooooo easy as well :)

        • FIDELIS
          May 3, 2011 at 11:40 pm

          Hello, yes I meant to say the .vdf file...I am sorry about that. No, virtualdub does not add the subtitles by itself. You have to get the filters for it. If a remember correctly, there are a few choices for subtitles. Are you looking to add hardcoded subs on an .avi file to convert to dvd? or you just want to convert the .avi file to dvd with soft subtitles? If you just want to convert the .avi file to dvd with soft subtitles, there are easy ways to do it. The following is a link on how to add subtitles using virtualdub. This is the way that i have used in the past:


        • Send_more_spam
          May 4, 2011 at 10:46 am

          Yes i have an avi video i want to embed some subtitles onto. You don't see anything unless the person isn't speaking english. After resisting the temptation to go and get a hammer and trash the computer, i have deleted everything and using your link downloaded everything it says to. Including the latest version of virtualdub, the experimental version.
          Guess what? When i extracted it it ...wait for it....created it's own plugins folder!!!!!!
          I got goose bumps!
          So i went through the old procedure using divxland as i hadn't deleted that and i think it's working. Virtualdub is 32% of the way of doing something anyway :)
          More shortly...

        • FIDELIS
          May 4, 2011 at 8:27 pm

          Hello, it is good to hear, it is working now. Let me know if there is any other issues, maybe I can help.

        • Send_more_spam
          May 4, 2011 at 11:36 pm

          Hey, thanks so much for your help! I couldn't reply until now because i had to go into work earlier than planned, but yes, i have finally applied subtitles to a video!
          THANK YOU!!
          I was telling a colleague at work that i had finally done it. He really upset me by telling me that ConvertXtoDVD can do it. That's a program i've been using to convert all sorts to put onto a dvd to play in dvd players...I'll be checking that out next.
          If he is right, i shall be VERY annoyed :)

        • FIDELIS
          May 5, 2011 at 1:58 am

          Hello, your colleague is right.....that is way in one of the comments I was asking you if you wanted to put hardcoded subs or softcoded subs on dvd. With convertxtodvd you can do that easily as long as the subtitles and the video file have the same name and are located on same folder. It works pretty well and as long as the subtitle track is on sync there should not be any problems as long as the program can read the subtitle extension. The difference between using virtualdub and convertx is that, with virtualdub you insert hardcoded subs and convertx you insert softcoded subs. Do not be annoyed, just remember that you learned to do something new....

        • Tina
          May 8, 2011 at 6:20 pm

          Hey, thanks for your feedback and glad it worked out for you after all. :)

  2. namespace
    May 1, 2011 at 1:22 am

    Program Files directory is a protected sensitive directory. This is a security feature of Windows 7 to prevent unauthorized tampering of files.

    Instead, extract the files to your desktop and copy them to the directory you want them to be in.

    • Send_more_spam
      May 1, 2011 at 11:38 pm

      Thanks for your help. But i tried that, and when i tried to use virtualdub, it couldn't find a file which, was plainly in the folder :(

Ads by Google