Why has my external hard drive suddenly become write protected?

Anonymous August 3, 2014
Ads by Google

I have an Iomega 1TB portable external harddrive. I’ve been using it on my windows laptop for the last year or so basically for storing photos. I hadn’t used it in 2 months or so, and just went to move some more photos onto it, and the following message comes up:

The disk is write protected. Remove the write protection or use another disk” – Try Again or Cancel.

I don’t understand. Nothing’s changed. I can still access all the photos on the hard drive, so I don’t think it’s corrupted. It’s just that I can’t copy any more new photos onto it. I’ve only used about 150GB so still heaps of room.

I’ve searched forums, and tried the command diskpart process for both the volume and the disk, and that doesnt appear to have worked, even after rebooting. I would appreciate some thoughts from some experts (my IT knowledge is not very strong!!)!

Thanks in anticipation.

  1. Jan F
    August 4, 2014 at 1:27 pm

    It may be a permission issue.

    Right-click and select properties on the external drive within the explorer.
    click on the Security tab
    click edit and make sure to set Everyone to have all permissions (full control/access) and inherit those permissions to all sub-levels


  2. Hovsep A
    August 3, 2014 at 9:07 pm

    1) go to device manager
    2) locate the Iomega 1TB portable external hard drive
    3) right click on it and choose uninstall (do not delete the driver)
    4) reboot, windows will detect the Iomega 1TB portable external hard drive and install the driver
    see if this will help