Why can I not download the Windows Vista Service Pack 1?

Domma Martin May 20, 2011

I have Windows Vista and every time I try to download the Windows Vista Service Pack 1, it stops and gives me this on a black screen –
0xc01a001d ” 37213/90418(\Registry\Machine\COMPONENTS\DerivedData…)

My computer is not running right because I need to download this.

Thank you for your help.

  1. Tina
    June 21, 2011 at 12:37 am


    your question has become a little confusing. Thus I recommend you start fresh and ask a new question. It sounds like you are now trying to repair Windows Vista and do not want to lose your user data. That is a different question anyways.

  2. domma
    June 16, 2011 at 7:50 pm

    OK, I am sorry for all the confusion! I do appreciate all the comments.
    I found my disc but it is:
    Toshiba Recovery and Applications/Drivers
    Windows Vista Home Premium 32-bit

    If I put this disc in will it tell me what to do? I do not want to recover and lose everything I have on my computer.

    Thanks again for any and all help

    May 24, 2011 at 7:10 am

    Hello, information seems to be a little bit confusing...at least for me.  If you are running Vista, the only way you will be able to fix your problem would be to reinstall Vista using the custom install option.   By using the custom install, you will be able to keep all your files and data on a folder of your main drive.  The name of this file is usually Windows.old.

     If you want to install vista with a custom install to fix your problem, follow the steps on the following link:

  4. Tina
    May 22, 2011 at 5:35 pm


    did you manage to download the Service Pack following the advice above? Please let us know how it worked and in case you need additional help. Thank you!

    • Domma
      May 22, 2011 at 11:23 pm

      I'm sorry, I have windows XP I have that disc.
      Thanks Tina

      • Tina
        May 22, 2011 at 11:28 pm


        does that mean your question is solved? Did you try to download the wrong Service Pack? 

        For Windows XP you should have Service Pack 3 installed.

        • Domma
          May 22, 2011 at 11:32 pm

           My updater says I have one important update available and it is the  Windows Vista Service Pack1?? I have had this notice for a while and have tried to install it several times and the same thing happens.

        • Domma
          May 23, 2011 at 12:12 am

           No it is not resolved. Do you know why it would say I have one important update available and it is the  Windows Vista Service Pack1?

  5. Anonymous
    May 21, 2011 at 10:37 am

    If you have the windows vista cd, boot from it and choose repair function.

    Description of the System Update Readiness Tool for Windows Vista, for Windows Server 2008 ...

    Use a linux boot cd
    browse to the WINDOWS folder.
    Right click and rename the SoftwareDistribution folder (or alternatively copy it somewhere and delete it)
    Browse to the system32 folder
    Right click and rename catroot2 to catroot2.old (C:WINDOWSsystem32CatRoot2edb.log C:WINDOWSsystem32CatRoot2tmp.edb)
    Click the start gear and click logoff, shutdown
    Pull the linux cd-rom from the drive.
    Boot from the hard disk and select startup repair.

    Go to run and type cmd
    •Then type below command in MS-DOS:
    •Del c:WindowsSystem32CatRoot2edb.log.
    • relaunch windows update

    • Domma
      May 22, 2011 at 11:26 pm

       I'm sorry. I have windows XP, I have that disc.
      Thanks for your help,

      • Anonymous
        May 23, 2011 at 10:07 am

         Download microsoft fixit for windwos and see if any available for micosoft update so that to fix your windows update.

Ads by Google