Why can I not download PDF guides from MakeUseOf?

pravin November 6, 2010

On download page for the manuals, when I click for downloading the manual for Linux or any other title nothing happens. In short, I am not able to open or download any manual.

  1. Tina
    November 6, 2010 at 4:06 pm


    I just tried to download a PDF guide from our downloads page and it works well.

    This is how it works: On top of the page there is a list of guides. When you click a link in the list, your browser should jump down to the screenshot for that guide. When you click the screenshot, the guide should open or start downloading the PDF.

    What browser are you using? What happens when you try to open the download link in a new tab or window?

    • pravin
      November 9, 2010 at 3:09 pm

      thanks, for the reply, i was using chrome and was getting nowhere
      but after i saw this reply, tried I.E.(using version 8) and got the job done,
      but just curious, what should be done to use the chrome?

      • Tina
        November 11, 2010 at 5:41 pm


        I could actually reproduce your problem in Chrome and doing some more research, it seems to be a common one.

        I could fix it by enabling the Chrome PDF Viewer plugin. In Chrome, open this site: chrome://plugins/ Then scroll down until you see the Chrome PDF Viewer plugin. It was the second to last in my list and it was disabled. Enable it and try to open a PDF file from our Downloads page. For me it worked instantly, without restarting the browser. The Adobe Reader 9 plugin is also enabled by the way.

        If this doesn't do the trick for you, there is another workaround. While you may not be able to view PDF files in Chrome, you can still download them. Right-click the download link and select "Save link as...".