Why can’t I connect to my Tight VNC server even I am on the same network?

Mel February 3, 2010
Ads by Google

I have a laptop running Win XP home with a pretty current SP and its display bit the dust. I wanted to set up VNC to use it for mundane purposes like being an IP phone server (as in MagicJack) and maybe a music server in the near future. I set up everything using an external display.

Set up to run tight vnc as a system service. Reboot several times due to windows updates and what-not. When I boot it up, I can see the VNC icon in the tray stating it is a service and displaying the static IP address information of this machine.

From another machine, again in the same home network of mine, I am trying to connect to this machine by specifying its IP address. I am using the VNC viever downloaded from the tightvnc download page. After 10-15 seconds, I am getting the dreaded failed to connect message.

I went beyond the call of duty for this and edited windows firewall settings and allowed ports 5800 and 5900 to be allowed and in the VNC server settings, I un-clicked the auto port setting and set it to port and values being VNC to 5800 and http to 5900 as the default values suggested.

Still no dice. Anyone has any idea what I might be doing wrong ? I did a quick google search and found few articles referring to this being a client issue but having downloaded the server and the client from the same source and same web page, it sounds quite oxymoron to me.

Any help is appreciated.

  1. pceasies
    July 23, 2010 at 5:04 pm

    Sometimes antivirus firewalls will block ports. Make sure you check anything else installed.

  2. Varun Kashyap
    March 20, 2010 at 6:46 pm

    I would second teamviewer if that suits your needs. As for your issue.. can you ping the other machine? It may sound dumb but I have had similar issues, tried lots of things only to discover later that the wires were not plugged in right!

  3. ├Žnon1mus
    February 4, 2010 at 9:39 am

    How is your network set up? You might want to check to see if the settings are correct. Alternatively, you could use a different VNC application.


    Have you tried using Teamviewer? It's much easier to set up.

  4. The Cov
    February 4, 2010 at 12:01 am

    Are you using the following