How can I connect to the internet via Windows 7 on my HP mini?

SweetP August 24, 2010
Whatsapp Pinterest

I am not able to connect to the internet through Windows on my HP Mini.
I can enable Quick Web and access the web. Any suggestions? I get an error that says ‘Windows is unable to connect’.

  1. gghy
    September 29, 2011 at 11:46 pm

    Whats the HP website ?

  2. Tina
    August 24, 2010 at 3:55 pm

    I assume that you are using Windows 7.

    Just to make this clear to everyone else, Quick Web is a kind of cloud operating system from HP that launches independent of Windows. It comes with software dedicated to accessing the internet and using online services, including chat, eMail, and a browser. Quick Web supports WiFi, LAN, and DSL settings. The user can also access their media data on the hard drive.

    If the internet can be accessed using Quick Web, the hardware must be working. Hence, the observed problem must be with Windows and my guess is that it is a driver problem or conflict of some sort.

    Can you not connect to the internet at all or is just the WiFi affected?

    Did you download and install the latest network drivers from the HP website?

    If you have not changed your operating system (installed another one) and if updating your drivers did not fix the issue, I strongly recommend that you use your warranty and make HP solve the problem for you! Your internet issues are not caused by the hardware, rather there appears to be a general problem of Windows 7 and WiFi or maybe in your case with network adapters in general.

    I have a HP mini running Windows 7 and have been having issues with the WiFi. LAN connection works fine. I had removed Windows 7 Starter and installed Windows 7 Professional. I tried every way I could think of to fix it, including re-installing different versions of the operating system (but not Starter) numerous times and even exchanging the hard drive. Accessing the internet via Quick Web always worked. However, once I was within Windows 7, the WiFi was erratic and generally ended up not working. Some 'fixes' would seem like they worked, but I was not able to solve these issues long term. It was very frustrating. Finally I gave up and now I'm using a WiFi USB adapter, which works flawlessly. I assume that reinstalling the default operating system would fix my issue because everything worked perfectly fine before I removed it.