Why won’t my computer open my Kingston 8GB USB flash drive?

PriNce YaSh April 9, 2012

When I connect my USB and click on my “removable disk” it prompts me to insert a disk into the drive. Why doesn’t my computer automatically open the USB? I have 8GB of movies on it I’d like to retrieve!

  1. Nikhil Chandak
    November 9, 2012 at 3:26 pm

    ask the Kingston company
    or its corrupted ..?
    or it maybe hving some virus or virus type files
    or try ur pd in some other computers of different operating systems ..

  2. Indronil Mondal
    April 13, 2012 at 6:46 am

    Kingston...was that branded ?? or is that one of those Chinese electronics that never works.. I had one 32 gb that always copied data but never i got those data back..
    just check it in another computer if it works or not if it dont works then no hope..
    but be sure to check manufacture site for details 

    • Indronil Mondal
      April 13, 2012 at 6:50 am

       maybe it is corrupted

    • PriNce YaSh
      April 13, 2012 at 7:08 am

      its branded........m usng this pd frm past 3 years.....wrkd f9

      • KKK
        September 17, 2012 at 3:39 am

        ill just bought usb kingston brand when i plug in it.. the dialog box said that " please insert disk into drive E:" ill do usb tricks.. and some one tell me use usb show then YAHOO.. and recently ill find out that my usb is fake, well its from china, maybe my usb i bought did not under go quality standard.. ill get a new one.

  3. Susendeep Dutta
    April 13, 2012 at 5:44 am

    @facebook-100001071477952:disqus  : I searched for recovery software for a variety of drives but I found that older drives have drives for Windows 98 SE and have PDF guides for security version USB drives.

    You can now only solve the problem by referring to FAQ if the method mentioned by me previously didn't helped you out.

    FAQ -


    • PriNce YaSh
      April 13, 2012 at 6:30 am

      tnx fr d reply.......but i hv checked faq also.but nothng wrkd.!...i it mns my pendrive is nw jst a plastic....TNx agn

    April 10, 2012 at 11:34 pm

    Hello, are you sure your are clicking the right one?  I have an 8GB flasdrive that when connected, it shows two different drives.  When you click on one, it tells you to insert a disk...but if you click in the other, it shows your storage and what you have in it.  Try connecting your drive and go to computer/my computer and see if two separate drives show.  

  5. ha14
    April 10, 2012 at 6:29 am

    perhaps also autoplay problems
     Microsoft AutoPlay Repair Wizard http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=2648

    • PriNce YaSh
      April 12, 2012 at 6:33 am

      both not wrkng.......bt tnx fr d reply!

  6. Susendeep Dutta
    April 10, 2012 at 4:12 am

    For simpler method,visit your pendrive's manufacturer site and download recovery software if available.Install it and and your pendrive will start to function properly.

    If the above method doesn't works then -

    How To Fix "Please Insert a Disk into Drive" Error In Windows -


    • PriNce YaSh
      April 11, 2012 at 6:02 am

      plz provide the link of dt recovery software if u can.......tnx fr d reply!

      • Susendeep Dutta
        April 11, 2012 at 2:51 pm

        If you provide your pendrive manufacturer name then I can provide you exact link.

        Have you tried Transcend's online recovery software as mentioned by @ha14:disqus ?

        • PriNce YaSh
          April 12, 2012 at 6:33 am

          ya i hv tried d transcend software but when i open it .IT shws dat ""CANT FIND ANY DEVICE''...........n my pendrive manufacturer is kingston data traveller 2.0 

        • Susendeep Dutta
          April 12, 2012 at 7:10 am

           I'm having a bit difficulty finding the correct model .

          I found the product similar to what you have mentioned here in the
          comment and in the question.Is it the correct device you are referring
          to in the link below -


          Could you please mention your drive's information i.e. full name you have problem with by visiting the link below -


        • PriNce YaSh
          April 13, 2012 at 5:17 am

          sry but dis iz nt my product........chek out dis image.....it is my pendrive

        • ha14
          April 12, 2012 at 5:33 pm

          do you have the same problem with other usb keys?

          you can Easeus partition master home edition to format the usb key (this will erase all data)

        • PriNce YaSh
          April 13, 2012 at 6:36 am

          no other usb r wrkng fine.........n i thnk easeus will nt detect the pendrive........i hv already tried with easeus daa recovery software.......

        • ha14
          April 13, 2012 at 9:30 am

          maybe other OS like MAC or Linux can detect it so then you can format there and reformat on Windows?

Ads by Google