Why does my computer lose its internet connection after some time?

John February 1, 2011

Recently, my computer started losing its internet connection whenever the duration is over an hour. I have tried resetting the winsock and attempt to assign IP address manually, but after restart the problem still persists. It says the default gateway is not available.

The modem is fine and my network adapter is working properly, while the cable is working with no problems.

Could someone assist on this issue?


  1. Madan
    April 27, 2012 at 9:21 am

    I have just buy Hp pro book 4431s model laptop with 64 bit , win 7 free OS and i have huewai c5005 model CDMA mobile modem PC suit ,when i connect device its not saw device , i have try to connect through the device manager there is also problems in interface device how can i connect my device and run internet smoothly ?

  2. Anthony stamps
    April 13, 2012 at 4:36 pm

    this problem could be solved bye at&t they could help i search this question online this could be fixed by bye uninstallying hardware or software off the comeputer or motuem router or talk to your internet provider comcast at&t are the internet providers you should use and you shuld get netgear or a cisco moutem or router
    or try unpluging the device and  pluging back in if it still conntinues if your wirless you need to use wired connection an get at&t or there might be something unpluged hope you get it fixed ty for your time

  3. Keith
    February 4, 2012 at 9:58 am

    I had this problem for a year and I tried everything and I do mean everything.
    My Networking card was a Nvidia.
    In final desparation I bought a Realtek Gigabit LAN Card from Ebay for a fiver and my problem is now sorted.
    I now have an Internet speed of 14Mb increased from around 3Mb.

    • Tina
      February 4, 2012 at 6:10 pm

      Thanks for the input, Keith!

  4. cevin
    January 26, 2012 at 1:08 pm

    My computer is what makes my internet go down. my mom can netflix all day on the play station and it will never mess up. Only when i turn my computer on it goes down. My modem says its still connected to the dns Server but the internet light goes off

  5. Tjkitl
    January 24, 2012 at 7:05 am

    Hi.. am faced the same issue  but nw solved . pl. try this.

    The reset command is available in the IP context of the NetShell utility. Follow these steps to use the reset command to reset TCP/IP manually:To open a command prompt, click Start and then click Run. Copy and paste (or type) the following command in the Open box and then press ENTER:cmdAt the command prompt, copy and paste (or type) the following command and then press ENTER:netsh int ip reset resetlog.txtReboot the computer.

    then assign a new IP for NIC. 


  6. Rfiddler
    December 22, 2011 at 12:24 am

    thanks for the info mate .I had the same problem and worked great thanks a heap mate

  7. Lunchbox096
    November 16, 2011 at 7:45 pm

    Same Issue but i rebooted my laptop. When it finished it restarted and i signed in and i had no internet connection (wired).

    • Lunchbox096
      November 16, 2011 at 7:48 pm

      Anyway it said "No Deafult Gateway Was found) I connect the wire to my xbox 360 and it works fine...no issue

  8. Riswan
    November 12, 2011 at 5:42 pm

    hello my friend's, i m using the lenova G550 Laptop, if i m open my pc the total network pc is totally slow, i m check the router but not fault in router,if shutdown my pc its ok wht problem plz help me my friends,give me a solution

  9. Abdul Rahman
    October 21, 2011 at 1:31 am

    i know the answer for the connection is connect but seem like no connectivity.
    first go to the control panel and open windows firewall and go to the tab advance.
    and Tick Wireless Network Connection in case it is untick and click setting and go to tabnICMP and Tick everything. then click ok. and
    Tada... it work now... and can surf internet again..

    • karen
      April 3, 2012 at 7:56 am

      do you mean advance settings? coz i had been looking for the ADVANCE TAB to no avail

    • asif
      May 7, 2012 at 4:50 am

      dear sir mujhe mere system mein 60 mints off hona cahiye automiticly on off hona cahiye please help me thanks

  10. Elgato47
    October 6, 2011 at 4:20 am

    go to device manager, click on properties of your adapter and uncheck the box that allows Windows to disable the adapter to save power

  11. Abdallahseif
    October 5, 2011 at 11:16 am

    I have a Lenovo Pc, windows server 2003 , and I lose the internet connection after connect the network?
    please help me !!!

    • asif
      May 7, 2012 at 5:50 am

      please reply my ans sir

  12. Aibek
    February 13, 2011 at 8:11 pm

    Hey John,

    Were you able to figure it out? Let us know


    • John
      February 14, 2011 at 1:12 am

      Thanks, I have stored many information about the issue, unfortunately the problems still persists but rarely. I have found all the help I need.

      • Kim Akimoto
        May 12, 2011 at 11:31 am

        it always need repair, sometimes it's really annoying to repair........

  13. Anonymous
    February 6, 2011 at 6:33 pm

    your download is corrupted?

    In these cases you have to click Add Plug-ins, followed by Plug-in Gallery and search for the particular App you want.

    You can either type it into the search box sitting right in front of you (after clicking), or you can browse through Yahoo's Apps by category on the right hand side of the page.

    Once you find the one you like, click "Try it now" and follow the prompts.

    This error can occur in Yahoo Messenger and perhaps earlier versions. This error happens because, after a clean install of YM and on first connection, it attempts to download, install, and execute various scripts that work with YM plugins and various things. If these scripts are somehow prevented by the user from being downloaded, this error message will appear every time YM is connected

    The solution to this problem is:

    1) Stop preventing these scripts from being downloaded when YM connects (at least once), which will allow them to be downloaded and installed properly within YM. If you have a firewall such as ZoneAlarm, it may alert you that YM is trying to act as a server. Allow this connection.

    2) With YM still open and connected, open the Plug-Ins Manager by clicking the "Add Plug-ins" button. Scroll down the entire list of plug-ins. There will be at least two plug-ins enabled by defailt. I think they are Yahoo Weather and perhaps Yahoo News. Disable all running plug-ins by clicking the red "stop" button beside them. Then close the Plug-ins Manager and close YM.

    From now on, the SocialView error message should no longer display when connecting YM no matter what you do.

  14. Iqgringo
    February 5, 2011 at 5:19 pm

    Check your cables(coax) / connections to modem. Connections can degrade over time.

  15. jason
    February 4, 2011 at 10:29 pm

    i have an windows XP, and i am trying to download yahoo messenger, but when i try to open it, it pops up and then just quickly pops off, it says that their is an error with social view plugins. jaso

    February 2, 2011 at 9:44 pm

    Is it possible for you to post the following information?

    - Operating System
    - 32 or 64 bits
    - Computer manufacturer
    - Motherboard manufacturer
    - If you have router: brand name of router
    - Firmware for router

    • Johnjiang2011
      February 3, 2011 at 4:03 am

      I'm using Windows 7 64bit, HP Pavilion dv6 and I couldn't see the router since I'm only connected through the modem. I'm using my school's modem, so I can't access the physical device itself.

      • FIDELIS
        February 3, 2011 at 7:44 am

        Not having access to the router makes things more difficult to troubleshoot from that end. Have asked anybody else connecting the same way you if they have similar issues? Have you asked somebody to let you use their laptops for a couple of hours just to check if the same thing happens?

        I read somewhere before that issues similar to yours were fixed by installing the vista 64 drivers. Give it a shot.

      • GB
        February 4, 2011 at 1:40 pm

        Since you are using the school's modem, I'd check with them. They probably have a timeout set at an hour. This is a normal action by schools when they get complaints from users that they can't always get on.

    February 2, 2011 at 8:46 pm

    Does it matter what adapter it is being used when you loose internet connection? Are you using wireless or wired?

    • John
      February 3, 2011 at 4:03 am


  18. Anonymous
    February 2, 2011 at 8:22 pm

    Go into Atheros NIC adapter properties
    1)Open Device Manager
    2)Locate the Network Adapter
    3)Right click, Properties
    4)Go to Advanced tab
    5) Locate the Task Offload (aka TCP offload) property on the list and set it to Disabled

    After setting this property and applying the changes, the Internet connection should remaine stable and no longer dropped out when transferring large amounts of data.

    try this driver
    L1WinSetup_v2.4.7.29_WHQL.rar http://partner.atheros.com/Drivers.aspx
    Flow Control ON
    Task Offload OFF

    Go to Control panel ... then administrative options.
    Then "services".
    Scroll down and find a service named "Bonjour service". double click on this service, then disable it. Now choose "automatic (delated start)".
    Click OK then close everything and reboot, when you do, your network and internet connection should be fine.
    Takes a lot to explain the problem but it is a service created by Apple that is commonly used in several applications to get your network card to configure itself
    automatically to work with certain services. It does not play well with windows services as a rule, and delaying the auto start gives the windows services time to start prior to its activation at reboot.

    Next go to local Area connections
    Select Properties
    In Network Tab - Uncheck Internet Protocol Version 6(TCP/lPv6)
    Highlight Internet Protocol Version4(TCP/lPv4) Click Properties
    Go to General Tab
    Select Use following DNS Server
    Perferred DNS Server Address
    Alternate DNS Server Address
    Click "OK"

  19. Danny Reyes
    February 2, 2011 at 4:37 pm

    Reset you modem or Router! :) good luck

  20. Mike
    February 2, 2011 at 12:05 pm

    If you are running Windows Vista and your computer is in sleep mode before the problem occurs please install the latest service packs and updates.

    If you are using AVG Anti Virus please deinstall it and see if the issue is still present.

    Besides of nVidia nForce the ASUS Onboard Controller are also known for having this issue.
    Try updating the driver from either of their Support sites.
    Try updating the driver as FIDELIS described (via Microsoft Update).

    February 2, 2011 at 6:46 am

    Hello, this a possible fix for you:

    -- Start
    -- Right click Computer >> select Manage
    -- Double click Device Manager
    -- Expand Network Adapters
    -- Highlight the network card causing trouble
    -- Right click >> click uninstall
    -- Restart your computer

    When if finishes starting up, windows 7 should be able to offer you a driver for your card. Run your computer with that driver. If that does not work for you, check with your motherboard or network card manufacturer to check if there is any updates for your network card.

    It does not sound as if you have a router, but if you do check what the lease time is. It could be that lease is set for an hour and that is causing your problem. Change the lease time to a higher number or even a few days.

    Do you have any apple software installed like Itunes or quicktime? Sometimes the Bonjour service has to be disabled with a delayed time to start so that it does not interfere with other services.

    What brand of network card do you have? When windows 7 just came out there were a few issues with Nvidia cards. Check which one you have.

    Check this link if you have an atheros card:

    • Johnjiang2011
      February 2, 2011 at 2:07 pm

      I'm using Realtek PCi Family Controller for my LAN network adapter, and Atheros for the wireless connectivity.

      Thanks for the tip

      • Elgato47
        October 6, 2011 at 4:25 am

        Go to control panel, System and Security, click on System, the Device Manager on the left. Click on network adapters, and then left click on your PCI controller, then click properties, power management, and uncheck the box that allows Windows to disable the adapter to save power.

        • Elgato47
          October 6, 2011 at 4:27 am

          right click on the PCI adapter, sorry...

        • Lores1810
          March 22, 2012 at 5:30 pm

           Thank you! I'm not sure if my problem will be solved once I have never noticed if it just happened when I was only with batteries...I think that happens always but I'll try what you just said! :)

        • Carson
          October 15, 2011 at 6:48 pm

          wow sweet thanks

        • Jorunnso
          February 3, 2012 at 1:59 pm

          Extremely helpful, thanks a bunch....

        • Josh Jthompson
          February 20, 2012 at 6:03 pm

          This helped a lot, my computer has been like this for over a year, cheers.

        • aj
          February 21, 2012 at 8:50 pm

          Thanks man! easy fix

        • Sir C
          March 25, 2012 at 12:53 am

          Thank You Saint Elgato!  That's been driving me nuts for the past year.

Ads by Google