Why has my Compaq Presario CQ61 stop working?

Shegzy4 P September 12, 2013
Ads by Google

I will be glad if I can get help here.  My Compaq Presarion CQ61 stopped working and the last thing i did was just to restart it when all the videos I have been watching on YouTube were kinda skipping.  So I decided to restart thinking maybe that can help.  After restarting, the laptop stopped loading and showed a blank screen with light brown color.  I waited for several minutes but still can’t bypass that place so i decided to remove the charger and battery cell for a permanent shutdown.  I put in the battery cell and the charger back but no charger light is showing and the laptop just stopped working.  I pressed the switch on button but the laptop doesn’t work and the charger light stopped showing and I tried other chargers but still the same; not working.  Thanks and hope to hear from you soon.

  1. Shegzy4 P
    September 14, 2013 at 8:17 am

    i have tried it 3 times but still not working

    • Hovsep A
      September 15, 2013 at 7:46 pm

      If something wrong with the BIOS then can explain this behaviour in this case you need BIOS Injection, the manufacturer can do this. If it is hardware problem like dead motherboard...then you need to buy a new laptop.

  2. Shegzy4 P
    September 14, 2013 at 4:09 am

    no power light or any light, no sound, just like a dead laptop, i plugged in the charger, there was also no charger light

    • Hovsep A
      September 14, 2013 at 7:04 am

      well it happened to me with my motherboard after i shutdown my pc, never again powered on so i had to replace it.

      1) unplug your charger and take out the battery
      2) Hold power button for 60 sec.
      3) Put battery back and Plug in charger
      4) Turn it on
      if it does not work try 2-3 times?

  3. Hovsep A
    September 13, 2013 at 7:26 am

    have you tried to reset cmos battery or to replace it?
    it can also be hardware problems?

    • Shegzy4 P
      September 13, 2013 at 9:47 am

      Maybe hardware problems but i dont know, even though it is battery problem., i have tried powering it on without battery just by charging, still not power on.

    • Hovsep A
      September 13, 2013 at 8:51 pm

      is there any light when you click on power button, do you hear any noise?

Ads by Google