How do I change permissions for an external hard drive?

Andrew May 9, 2010

I recently got a Mac, and am having a problem using my external hard drive. I only have “permission” to read files on my external hard drive. I am not allowed to write or edit files on the hard drive when using Mac OS. The only solution I have found is to format the drive with the Mac OS.
Is there any easier option to change the drive’s “Sharing & Permissions”?

  1. Hosany Noor
    March 11, 2012 at 9:12 pm

    Hi, i've got a little problem... I was using an external hard-drive on my macbook now am trying to copy my files to my windows 7 laptop but the thing is that the external hard-drive doesn't recognized the hard-drive. I don't see that drive icon in the my computers. Can anyone help me please with this.

    • Tina
      March 12, 2012 at 9:01 pm

      I recommend asking a new question. You are unlikely to receive a solution within this thread, at least not quickly.

    December 30, 2011 at 4:07 pm


  3. Cssrex
    November 24, 2011 at 5:47 pm

    On thing that can express my feelings here : THANKS :)

  4. Slabslab
    November 12, 2011 at 1:34 pm

    there is no little lock on the bottom right after the GET INFO click

  5. The Ultimate Apple Fan!
    November 6, 2011 at 9:16 am

    all you have to do is go to the hard drive, right click and go to "Get info". Then scroll down to the little lock on the bottom right and type in your password. Once your done that then click on the options on any of the users and you are done! Now thanks to me your problem should be solved!

    • fahad
      May 4, 2012 at 9:55 am

      hi ur comment is old but in mac lion ther is no option like that !!! plz help i have a fat32 usb stick in permision it says on read dont hv any lock or anything like that plz help

  6. Guest234234
    October 26, 2011 at 1:55 am

    Tuxera also has a similar app, works like a charm on Lion OS X!

  7. Westwon
    September 26, 2011 at 3:28 pm

    this is the best little program i have came across ... i used it today again on a external hd after running VMWARE ... cause it seems to cater to the pc side of life. :|~

  8. Pooppoo
    August 6, 2011 at 4:03 am

    damn yo i have the same problem does anyone know what type i have to convert my external hard drive into for my macbook pro to write to it. It is is NTSF now. daaaaaaaaaaaaamn i need some genius tech right now

  9. Torrey
    August 1, 2011 at 4:59 pm

    I've asked this question to someone that has switched from a PC to MAC they suggested I copy everything from the external drive to the laptop. Reformat the external drive for MAC and then transfer everything back. The transfer process will probably take longer than the format. Either that or buy another external drive.

    • Tina
      August 1, 2011 at 7:53 pm


      that sounds like a sound solution, although complicated. But since the formatting of the hard drive appears to be the problem, moving the data and re-formatting is the logic consequence.

      The only other way I can think of is finding a hack that will help your Mac to read and write to the file system that the hard drive is currently formatted in.

  10. Dan Coogan
    July 26, 2011 at 7:38 am

    I have the same problem... I want to modify a photoshop jpeg and save the changes, but I get a message that says I am unable to write to the disk... I am the admin.  When I get Info on the external drive, under Sharing & Permissions it says "You can read only" and the names and privileges are grayed out, so is the + - and Action menu.

    • Tina
      July 26, 2011 at 9:57 pm


      I recommend that you ask a new question!

      • Jwhitsch
        August 12, 2011 at 3:07 am

        I have to say your answer "I recommend that you ask a new question!" to be rude and arrogant. 

        I have been dealing with this same problem for years. In my work I produce large amounts of data and I prudently back everything up. Some how 4 of my 11 external HD's are now read only. 

        I have been able to get around this by plugging the problem drives into my Airport's USB port and can write to the drive that way. A slow process but has helped me out in a pinch. The 4 drives effected are 2 TB each and nearly full. To simply copy to another drive and reformat will fix the problem only in the short term since it doesn't address how this happened in the first place. It's like changing your tire every time it has a nail in it but not bothering to sweep up the barrel of nails that some one spilled in your garage. I would rather sweep up the nails and patch the tire.I expect better from apple.

        • Tina
          August 13, 2011 at 5:37 am


          my answer was not intended to sound rude nor arrogant.

          I manage this forum and I'm probably the only one who reads all the comments on this forum. Unfortunately, I don't have all the answers!

          I know from experience that a reply to an old question rarely receives a response because it doesn't receive any fresh exposure. People who have previously replied are notified of the new comment, but they may not be able to help more than they already did. And someone who finds the more recent comment through Google usually does so because they have the same problem.

          Hence, I recommend people to ask a new question, giving them the chance that someone who knows the answer will see it and respond with a solution.

        • Jwhitsch
          August 13, 2011 at 8:09 am


          I'm sorry I misunderstood you. The exclamation point at the end of your post threw me. Having moderated a forum and a chat server in the past I can appreciate the work you do. I was having a BAD day and then the drive I have my current projects had this permissions mess up and I felt sympathy for any one in the same predicament. Again I'm very sorry.I searched for answers and found your site and it seemed to have a good number of people with the same hair pulling problem. Being self employed I'm my own IT dept. so forums such as this are a godsend so I often look to them for answers.

          There is a solution of sorts I posted hope it can help some one.

          Thanks again,


        • Tina
          August 13, 2011 at 9:23 am

          No problem, Jenn. And thank you for sharing your solution!

  11. James Schantz
    July 25, 2011 at 3:22 am

    I was unable to find a solution as far as using this with OSX. However, I also use parallels on my mac with a copy of windows XP sp3. I do not have a problem using any type of external hdd to USB drive through virtualization. Again, this is not a solution for apple's problem but its another option.

  12. Hmessec
    July 10, 2011 at 1:12 am

    Well, I guess I'll join the club too

    I have a MacBook Pro that I purchased almost 1 yr ago, and my formerly trusty iMac.  I have two 1 Tb external drives that I used between my iMac, MacBook Pro and Windows 7 OS PC.  It wasn't right away that I noticed the same problem with read/write permissions, but it showed up quickly.

    I agree Apple needs a utility, or routine that sets up a user ID (+/- a password) to allow the creator of files or partitions on an auxiliary drive to retain permissions.


      December 30, 2011 at 4:05 pm


  13. G E
    June 19, 2011 at 7:27 am

     I recently bought a MAC book pro and am having the same issue as you guys.  This is my first mac experience and wish there was a refund policy for this thing.  It is lacking in so many ways compared to windows.  Oh well thanks for fusion I just start fusion 3 and mange my folders through win 7.  Maybe that will help.

  14. Andrew
    April 27, 2011 at 5:36 pm

    There is a post here on makeuseof that addresses this problem and the solutions; //

  15. ginariggiomusic
    April 27, 2011 at 3:49 pm

    Yeah, I have this problem at work. We create files on a PC and analyze them on a Mac. The external hard drive we use to transfer the files between the two computers will only allow read-only access when the drive is used on the Mac. So, if I need to change anything on the drive, overwrite files, move files around, rename things, etc then I just plug it into the PC to do it. For now, that's how I work around it but it's a pain.

  16. Thatzzzlife
    April 19, 2011 at 7:35 am

    I have the exact same issue! And based on research, so does hundreds of other mac users!
    So why in the world doesn't. APPLE respond and fix this crap!!
    No one has an answer that works. Pathetic!

  17. Anonymous
    May 13, 2010 at 4:58 am

    I don't know whether this will work on your case, but the easiest way to change disk permission in Mac is by opening the disk/folder/file info (right click and choose "Show Info" or select and use Command + I). The lower part of the info window - "Sharing And Permission" will allow you to change the permission just by choosing the kind of permission you want from the drop down menu: Read Only, Write Only, Read & Write, and No Access, for different users.

    • Allen Miole
      January 14, 2011 at 3:53 pm

      there are no options on the bottom part of the info... tried the terminal thing (diskutil...sudo... etc.) but no UUID No. appears so there's no use to continue. Help is still needed please!

  18. Oron Joffe
    May 10, 2010 at 7:11 pm

    Aha! In that case, you need to write-enable NTFS on your Mac, as explained on . Or you could Google:
    how to write enable ntfs on os x
    for additional links.

    Good luck!

    • Thatzzzlife
      April 19, 2011 at 7:37 am

      That still doesn't work

  19. Oron Joffe
    May 9, 2010 at 8:25 pm

    Hi Andrew, there is no general problem with using external drives with Macs, so you need to provide more information. Was the external drive used with a Mac previously, or with a PC? Is the disc formatted in NTFS, FAT32 or another system?

    • Andrew
      May 9, 2010 at 10:37 pm

      Hi, The drive was previously used with windows (which is why the mac OS won't give write permissions). I can still write files to it on windows OS, but can only read files with my mac.
      It is formatted in NTFS.

    • MikiWhat
      August 15, 2011 at 5:22 am

       Dude, I dunno if you still have the problem but I totally figured it out (And for anyone else that finds this). Go applications-Utilities- Disk Utilities and heres the part I couldn't find on the net: Go to Erase tab and click Erase (Obviously back everything up first) Then when you go back into the First Aid options, the Repair Disc option will now be available. This will automatically reformat and fix your problem. Boom.

      • Aibek
        August 15, 2011 at 12:36 pm

        thanks for sharing the solution here.

      • EDboogie83
        September 9, 2011 at 12:35 pm


      • Sean Musicman Madden
        October 4, 2011 at 4:06 pm

        what do you do when its your hard drive your backing up to that turned its self into a 'read only' it used to work and randomly changed and won't let me change the permissions?

      • Guest
        October 18, 2011 at 8:15 pm

        This really helped me! Solved my problem right away! Thanks a lot! 

      • Aswinthram
        December 9, 2011 at 3:51 am

        Thanks.. That helped a lot.!!! it really works

      • Kay Laaaa
        December 13, 2011 at 3:05 am


      • Eira24
        December 30, 2011 at 5:45 am

        Ooooh, thank you, this helped!

      • Mimoi_7
        January 5, 2012 at 9:44 am

        thank you very much, you help me a lot.

      • Atiqah Erlina
        February 5, 2012 at 11:12 pm

        omg it worked!! truly!! TQ SOOO MUCHHH~ XDDD

      • Danwilkie777
        February 12, 2012 at 7:05 pm

        Thanks so much! Worked for me :)

      • Ranjitsingh1310
        February 27, 2012 at 6:38 pm

        thanks a lot !!!

      • Lex Diaz
        March 18, 2012 at 10:21 pm

        I was nervous to try this, mainly because I have a 500GB hard drive and it took several hours to back up all the files, but it worked perfectly.

      • Megz2
        March 20, 2012 at 11:17 am

        When you say back everything up and then use repair disk option does this option then put everything back onto the hard drive? (My computer hard drive does not have enough space to back up everything on my hard drive)

        • aniket
          April 9, 2012 at 7:17 am

          exactly .. my macbook pro have 500gb size bt my data is more dan 650 gb .. n nw m face d same sharing n permission problem .. n nw m stuck here .. 

      • guest
        April 9, 2012 at 7:18 am

        ny other option plzz ..

Ads by Google