Why can’t I use BlueStacks on my Mac?

Anonymous July 26, 2014

I’m having trouble downloading BlueStacks. It says it won’t download on my version of Mac OS X. Please help.

  1. Jan F
    July 27, 2014 at 3:45 am

    As Oron said, please state which OS X version you are running. Click the Apple logo at the top left, then select System Information.

    Going by your post information which says Safari 5 you are either running OS X 10.5 or 10.6.
    BlueStacks requires OS X 10.6. If you are running 10.6 make sure you have all Software Updates installed.

    If you are running 10.5 using an Intel based Mac then you will have to upgrade your OS X to a newer version (i.e. upgrade to 10.6. either by purchasing a CD from Apple or borrowing one from someone you know).

    If you are using a PowerPC based Mac then I'm afraid you will neither be able to upgrade to a newer OS X nor run BlueStacks.

  2. Oron J
    July 26, 2014 at 8:08 pm

    You haven't told us which version of Mac OS X you are using, so it's kind of hard to help you. Have a look at http://support.bluestacks.com/hc/en-us/articles/202028178-Mac-OS-X-Installation-Requirements and perhaps you'll find the answer there.