Why can’t my tablet see my home wifi network?

Colin B January 19, 2014

My router works fine. My laptop, mobile, & tablet connect to wifi. Now my router is hidden from my tablet 99.9 % of the time but works fine on neighbour’s router?  All my wifi connected items work correctly but my tablets can no longer SEE the router.

  1. Colin
    January 24, 2014 at 8:59 am

    Thanks for your help guys. At least Iearnt much more about the Router.
    I am 70 y.o. with Aspergers.
    Anyway I had a call from my ISP tech dept, replying to my e-mails & they changed the router setup to another SSID & NSK? (p/w) & allworks fine.

    • Colin B
      January 29, 2014 at 1:31 pm

      I am back where I started. I switched of; when I switched on again the same problem came back.

  2. Oron J
    January 22, 2014 at 9:35 am

    Thanks. Try to "forget" the network, and also to reboot the router again before trying to reconnect.
    If you still can't connect, log onto your router and check the logs. They should reveal something about what went wrong, and if nothing else, you could pass this info to us and we'll try to figure this out together.

  3. Oron J
    January 20, 2014 at 11:43 am

    Give us a little more info please. Make & model of tablet and router, did the tablet work fine on your home network for a while and then stopped connecting all of a sudden, or did things develop differently? Have you tried to "forget" your home network and connect again? Did you try rebooting your router?

    • Colin B
      January 20, 2014 at 3:50 pm

      Yes, except the "forget". Tablet is original Samsung Galaxy 7" tablet from Verizon. SCH-1800. It worked fine
      until October, connecting ok. Then connecting intermitently, now it doesn't see my router. Works fine on my friends router. My Laptop & phone work on my router ok.

  4. Hovsep A
    January 20, 2014 at 9:26 am

    if you give more details regarding your Tablet then perhaps someone con guide to a solution

    • Colin B
      January 20, 2014 at 3:54 pm

      Samsung Galaxy Tab SCH-1800, Verizon, 7". Router TP-Link TD-W8951ND.

    • Hovsep A
      January 20, 2014 at 7:14 pm

      try to reset the router and also try to soft reset the Samsung Galaxy Tab SCH-1800 (empty the battery and charge again), if there is any update for Samsung Galaxy Tab SCH-1800 try to apply it.

      maybe there are faulty internal DHCP parameters from your last WiFi connection which do not work
      1) select the option to "Forget" the network
      2) Don't rescan for WiFi signals
      3) Manually add a new network, and give it the exact same name as the WiFi network
      4) Enter required security options if there are any, and then connect to that newly added network

Ads by Google