Why can’t I connect to Wi-Fi networks with my Acer Aspire 4743Z laptop.

Cristián T February 16, 2014

My computer’s Wi-Fi is not working, I just installed a fresh copy of Windows 7 and the drivers from the manufacture’s website don’t seem to help, the device shows up as a Network Controller with a Code 28 error, the drivers are installed but the device doesn’t seem to function. I also replaced the wireless card which didn’t seem to help. Help is much appreciated. Thank you.

  1. Cristián T
    February 27, 2014 at 2:26 am

    Just a heads up for everyone reading this thread, I tried getting the Wi-Fi to work in Ubuntu, and it did. It just doesn't work in Windows. What could this possibly mean?

  2. Dalsan M
    February 19, 2014 at 1:35 am

    Which drivers have you tried? I noticed there are drivers for Atheros and for Broadcom, so making sure that you have the right driver for the right hardware would be necessary. Try here: http://us.acer.com/ac/en/US/content/drivers and enter in Aspire 4743Z in the Search by Product Model search box. Select the Windows version, and at the bottom of the driver list should be the wireless LAN drivers. If the Atheros driver does not work, try the Broadcom driver.

    • Cristián T
      February 27, 2014 at 1:25 am

      I tried both
      the device uses a Broadcom

  3. Bob C
    February 18, 2014 at 8:47 am

    If you are certain its the drivers, you should be able to get them. I believe most Acers use the Broadcom card. Have you tried the drivers from this site: http://www.notebook-driver.com/acer/acer-aspire-4743z-notebook-windows-driver-utility/ ? There are drivers for both the Atheros and Broadcom cards (at the bottom of the list). Also User Guides for Acer.

    Another alternative is to right click on your "Computer" icon, click on "Manage" and then click on "Device Manager". FInd your Network device, right click on it and you should see "Update, Uninstall, etc.". You can also click on "Properties" and get a "tabbed window" with a "Drivers" tabb. You can try to Update and if that fails, you could try Uninstall and power restart your notebook and seeif Windows will autmatically reinstall the correct driver - if you haven't tried this step.

    Also, Acer has what tye call "eRecovery Management", which will help restore the system back to the factory defaults and drivers. It also has a "hidden partition" with the Acer and Windows recovery files if worse comes to worse. It should contain the drivers used when the system was first installed (the recovery files).

    If it didn't have the Broadcom card, I would have suggested using your ethernet connection to download Linux Mint with the MATE desktop), burn the ISO to a DVD and boot from the DVD (you can run without installing). If you can connect to the internet "wirelessly", then it would be the drivers. If you have a Broadcom card, then this method probably won't work as that card has been a problem for most Linux distros. This would, at least, help narrow it down to whether its H/W or S/W (drivers). BTW, it also has Gpart (partition manager), which can be used to locate the hidden partition, unhide it and rehide it.

    I assume you can connect via ethernet or are you using another PC? BTW, on the front edge (left section) mof the Notebook, ther should be 4 indicator lights - HDD, Comm. Ind., Power, Battery. On my laptop, the Communication Indicator also acts as a switch (by pressing on it - not so hard that you push into the notebook) - I also have another one like it for Bluetooth. While they are real easy to push, they can accidentally turn off the wireless card but the but you can still see the nearby router hot spots - just can't connect.

    • Cristián T
      February 27, 2014 at 1:24 am

      All of this has been done/known

  4. Bob
    February 17, 2014 at 7:59 am

    Some Acers have a "button switch" in the front. It looks like a light - I had accidentally pressed mine (on my Acer laptop) and "lost my wi-fi". I don't remember how I determined it was the problem (since I didn't RTM) as I thought it was just another light. But pressing it again, restored the wif-fi connection.

    • Cristián T
      February 17, 2014 at 6:47 pm

      The Operating system detects the device, but it doesn't have to proper drivers to run it, the notebook doesn't have an on/off switch

  5. Hovsep A
    February 16, 2014 at 9:14 am

    Code 28 error

    go to BIOS and check settings regarding wifi and enable them

    • Cristián T
      February 16, 2014 at 12:08 pm

      All of these step were done before, didn't resolve the issue. I believe this issue can be resolve with a new driver, but Acer doesn't provide proper drivers, I bet someone here may have the proper drivers / knowledge of how to write drivers

    • Hovsep A
      February 17, 2014 at 9:45 am

      can you try to factory recovery the laptop and see if wifi problems are solved.

      you can also try some driver scanners updaters so that automatically download and install the appropriate driver

    • Cristián T
      February 19, 2014 at 2:05 am

      the laptop was already fac restored, I'll try the driver scanners

    • Cristián T
      February 27, 2014 at 1:21 am

      yeah, they weren't much help. but fortunately I was able to get the exact hardware the laptop uses, so that narrows the search

Ads by Google