Why does my Canon Pixma MP620 All-In-One device not scan?

montse May 24, 2011

My All-In-One Canon MP620 prints and copies, but wont scan. When I press start scanning it displays “preparing …” and after that it asks again to press “start scanning”. I’m using a Mac.

  1. Qiao Chan
    March 9, 2012 at 1:22 pm

    help me..is it no ink no scan? 

    • Gerry_cooley
      March 22, 2012 at 9:27 am

      That worked for me Qiao Chan...Thanks

  2. Tony
    January 11, 2012 at 12:00 am

    If you own a Canon MP620, all in one printer and it will not scan because the ink cartridges are out of ink, this is what to do. Hold the stop button for at least 5 seconds, then the menu appears allowing you to scan. (You must have all the print cartridges in the printer regardless if they are out of ink or not, in order for this to work).

  3. Ck77706
    October 21, 2011 at 2:10 am

    Exact same problem here - and do confess, I do have one empty ink cartridge.  DArn blue is out again.  Doesn't affect my printing at all.  I will get a cartirdge and let you know if it worked.  Hard to belive it's a driver issue, given that it's been working fine for a year now, no problems, then suddenly - won't scan.  Prints, copies fine - just won't scan.  No error message either.  Doesn't*seem* to be a driver issue (it's like it's happeing more at the printer/scanner end - not at the computer interface).  I don't wanna mess with drivers until I rule out the crazy ink possiblity.  We shall see!

  4. Esrdftyghu
    October 18, 2011 at 9:35 pm

    Having the same problem. When ever I go to Scanning App under windows and accessories, I press preview and it works but doesn't save the picture. When it worked it made a noise like it was printing kinda, but I want to post pictures on FB and it won't work. So tempted to call Geek Squad at Best Buy! Did you get it to work?

  5. Gregory
    July 19, 2011 at 10:22 pm

    I have the same exact problem, but with windows.  How do uninstall the drivers?

  6. Tina
    May 29, 2011 at 10:27 pm


    did you try to re-install the drivers and did you check the ink cartridges? Let us know how you were able to solve the problem or in case you need more help. Thank you!

  7. Aldrino
    May 25, 2011 at 4:45 pm

    Probably the ink cartridges are empty. I have a Canon MP198, it won't scan until you replace the empty ink cartridges. 

    • Tina
      May 25, 2011 at 6:30 pm

      Wow, that would be a weird requirement, I would actually call it a bug. Thanks for sharing, Aldrino!

  8. Anonymous
    May 25, 2011 at 1:30 pm

    Uninstal the driver reboot windows and instal a new one from here 

    Got this from
    we can simply prevent windows from loading the filter driver.
    This one is conveniently higher in the list (Should be 4th entry under Class)
    Simply delete the usbfilter.sys upper filter entry.
    Restart the machine. Printing will work again.

Ads by Google