Can you help me jailbreak an iPhone 4 with a broken power button?

a a January 11, 2013
Pinterest Stumbleupon Whatsapp
Ads by Google

Basically, my iPod touch 4 32GB’s top power/lock/sleep button has stopped working.

So I though I would jailbreak it again, I am quite experienced with jailbreaking, and have done it many times before using many different tools but never on a device that can’t physically get into DFU mode. So I thought I’d try this DFU IPSW that you can make in RedSn0w. I made it and successfully booted into DFU mode.

I then tried to jailbreak in RedSn0w, but it failed while uploading the second stage.

So I went to Sn0wbreeze, this made a custom IPSW, I tried shift-restoring to the IPSW it puts on your desktop but it gets to the end and gives me error 1600. I read that iH8Sn0w updated iREB to make it work with error 1600, but maybe not with DFU IPSWs? As I tried using his standalone iREB6 from, and got the same error when attempting to restore in iTunes.

Is it not working because of this DFU IPSW? If so, how can I fix it? Is it possible to get into DFU without using the IPSW?

  1. Phil Botsky
    January 28, 2013 at 10:16 pm

    How can this even happen?

  2. susendeep dutta
    January 12, 2013 at 3:57 pm

    Firstly,use the latest versions of RedSnow and other tools required to perform a jailbreak as mentioned in the link below.
    Your device might be under soft DFU mode which needs to enter into pwned DFU mode for which you can try creating a pre jailbroken firmware which jailbreaking using RedSnow.

    How To Jailbreak And Enter DFU Mode With a Broken Home or Power Button -

    Error 1600 For 5.0.1 – Quick Fix -

    It seems that it's not possible without ISPW files as it's an integral pat of jailbreaking process.