How can I un-write-protect my Sandisk flash drive?

Anonymous January 28, 2014

My Sandisk flash drive says it is write-protected when I to try to save or delete files while there is still enough space to do so. How can I fix this?

  1. Tina S
    February 7, 2014 at 4:28 pm

    If the advice above doesn't help, follow the steps outlined in this article:
    How To Fix Write Protection Errors On a USB Stick

  2. Eswar
    January 30, 2014 at 11:28 am

    Not worked with my Sandisk cruzer 16gb

    • Hovsep A
      January 31, 2014 at 11:21 am

      what did you try? is there any switch key on your USB key?

  3. Sravan
    January 30, 2014 at 4:31 am

    I had the same experience with my SanDisk Cruzer Facet 8GB Pendrive and I tried some online solutions but none of them worked. Then I registered a complaint with SanDisk technical support quoting the problem. They replied that it is not possible to remove the write protection as the disk went into some 'self protection mode' indicating that it was affected by some virus. Then they offered me a 16GB replacement of that same model as they didn't have an 8GB model at that time and I got it replaced within a day.
    -Sravan from Hyderabad, India.

  4. Zach
    January 29, 2014 at 9:16 pm

    The HP USB Format Tool, It can remove secret partitions and other magic, it's amazing.

  5. Howard B
    January 29, 2014 at 8:58 pm

    Is there a tiny slide switch on the drive? If so, slide it to the "off" position.

  6. Hovsep A
    January 28, 2014 at 10:44 am

    1. Start - search bar -> type CMD right click and launch as administrator
    2. type - diskpart and hit enter
    3. type-list disk and hit enter
    4. type-select disk # (# is the number of the USB key)and hit enter
    5. type- attributes disk clear readonly and hit enter
    6.type-exit and hit enter

    • shashidhar
      January 30, 2014 at 3:43 am

      I am using Windows XP.It is showing LIST command is not recognized.

    • Hovsep A
      January 30, 2014 at 3:39 pm

      are you running in administrative mode?

  7. Dalsan M
    January 28, 2014 at 10:33 am

    Try the suggestions here: Funny enough, there is a link within the suggestions that takes you to MUO's article about removing write protections from USB drives, which should help if the commands in the command line do not work.

  8. Oron J
    January 28, 2014 at 9:59 am

    There may be other ways, but the simplest is to back up the data and re-format the drive, then copy the data onto it again.

Ads by Google