How can I root my Droid 2 with SuperOneClick?

Anonymous February 25, 2014
Whatsapp Pinterest

SuperOneClick stops at step 5 when trying to root my Motorola Droid 2. Can anyone help from here?

  1. Ricky G
    February 26, 2014 at 4:48 pm

    Ive tryed it all bra i found this out using Cydia Impactor that durring its thing it ends with invalid apk also i was reading the notes on that root access isn't sufficient on some devices: in order to write to /system, or in order to use setuid root commands, i might need either kernel patches or bootloader changes. and thats the only thing i haven done yet and now thats
    out of my league. back to the drawling board i guess il just have to pay someone to do this :/

  2. Dalsan M
    February 26, 2014 at 1:06 am

    Which version of SuperOneClick are you using? What Android version is on the phone? Is USB Debugging mode on? Did you click on anything on the phone while it was plugged in? (If so, do not touch anything unless directed to). How many times have you tried? (sometimes it takes several tries to get it to take). Have you tried a different sync cable and/or USB connection? Did you disable your security software and firewall? Sometimes AMD processors do not like to play nice with rooting software, or even the Windows version can be an issue, so try updating Windows and drivers or try using another computer. Also, try to reinstall the drivers for your phone onto the computer, get the basic ADB drivers available or try a different version. It is really hard to say what exactly is the issue, but the previously mentioned have been known to cause some form of issue with this type of software. Another issue could be that the update to 2.3.4 caused the exploit methods to not work anymore and another root method must be used instead.

    You can try beh's EzSBF bootable cd method, or the secondary method, both found here: