How can I recover files from my hard drive using a USB to SATA cable?

Anonymous April 11, 2014
Ads by Google

I have a 1TB external hard drive full of old data which I tried retrieving files from by connecting to my new computer (running Windows 7) using a USB to SATA cable.

Once all cables were connected and I plugged in to a USB port, the new PC is not showing the drive at all. When I right clicked on “my computer” and clicked into the Computer Management section, I found my hard drive and assigned a drive letter, however once I completed this step it kept requesting that I format the disk. There is valuable data on this disk so I don’t want to format it, however it seems to be the only option.

Any suggestions on how to retrieve my data?

  1. Peter K
    April 17, 2014 at 12:38 am

    Thanks Tim,

    Yeah I have found that testDisk seems to be reading the data via the "analysis" tool.

    I just hit a stumbling block when it came to re-partitioning as I'm an absolute novice at this. I have a friend who will be assisting me with that!

    In the meantime I'll look at your link too.

    The only data on this hard drive are movie files and music files (10 years of MP3's which I would love to retrieved!)

    Funilly enough, my second WD external hard drive (3TB) just fried also and is encountering the same problems. Coincidence? I hope so, but probably not. I'm guessing both hard drives had a corrupt file on them.

    Thanks all for your advice. I will post the eventual solution soon once I get a pro to assist me with the analysis report.

  2. Tim B
    April 17, 2014 at 12:24 am

    I'd offer up another vote for TestDisk. I've used it in the past to recover folders and drives, but it has the potential to recover whole partitions. You might be waiting a while, but if the data is really that important time shouldn't be an issue.

    Here's an article I wrote about PhotoRec, TestDisk's smaller cousin. It follows the same logic, and might help a little bit: //

    PhotoRec is for only recovering certain filetypes, but TestDisk's usage is very much the same. You can find more info here:

  3. Peter K
    April 13, 2014 at 10:22 pm

    @dragonmouth - the SATA cables work by the way. I tried it on an old discarded hard drive of mine and my computer read it within seconds without a problem.

  4. Peter K
    April 13, 2014 at 10:19 pm

    Thanks @Bruce E, I'll let you know how it goes. I d'loaded it but am starting to get overwhelmed by it all lol. But in answering your qn, it's windows-recognized.

    @dragonmouth - I am using the SATA cables because the regular USB cables don't work (hard drive runs for 5 seconds and then shuts itself down)

  5. dragonmouth
    April 13, 2014 at 12:45 pm

    @Peter K:
    Are you using the same cable to connect the drive to different computers? Try using different cables. I am not saying that is the problem but using different cables will eliminate them as the cause.

  6. Peter K
    April 13, 2014 at 3:52 am

    @Hovsep - yeah it's still doing the same thing on another 2 computers. I downloaded that boot cd but haven't had any luck retrieving (yet). There are so many programs on the disc. Any recommendations?

    @Oron J - when I go into Computer Management it tells me that I have 953mb on this drive, yet when I try to explore the drive it says "you need to format drive x: before you can use it"... so the data recovery won't work, will it? I downloaded one data recovery program but it is unable to navigate through the drive. Is the only option to actually format the drive and then try and recover the data? :/

    • Bruce E
      April 13, 2014 at 4:52 am

      @Peter K - Formatting the drive will make it harder to recover anything from it. You can try to use TestDisk to recover the drive and its data. And just to make sure, this drive is using a Windows-recognized format, right? it isn't a drive formatted with HFS+ for Mac systems?

  7. Hovsep A
    April 11, 2014 at 9:03 am

    try on another pc to see if the problem repeat itself
    Try a live cd like Hirens boot cd
    it has minixp inside maybe you will not get the problem

Ads by Google