How can I make my Samsung Galaxy tablet charge/turn on?

Anonymous March 8, 2014

My Samsung Galaxy Tablet 3 will not turn on no matter what I do. I’ve tried the whole hold down the power button and the volume for about 20 seconds repetitively. I plugged into the computer and tried it. It was on the charger all night long and still it didn’t turn on. I didn’t do anything. All I did was turn it off and didn’t use it for about a month. Please help me.

  1. Sam
    March 31, 2014 at 1:14 am

    The problem is with the reset it you will have to remove the screen with a plastic ply tool that is inserted between the screen and the plastic back cover. The screen is only held on with plastic tabs. Once the back is removed disconnect the battery connector. See beginning of the following video.

  2. Dalsan M
    March 8, 2014 at 10:18 pm

    Try holding the power button for 30 seconds up to one minute if Bruce's suggestion does not work, and then try again. Also, after the tablet had been on the charger for several minutes, try pressing the power button for another 30 seconds to a minute. I would also try to find a 2 amp wall charger and/or a different cable to see if it helps.

    If you do not see any indication of your tablet charging at all, there might be a problem with the chip between the battery and main board that "tells" the tablet the battery state, as in if the battery is plugged in and has a charge. This had been a known issue for Samsung Galaxy S3, Galaxy Note 3, and a few Samsung Tablets. If this is the case, you would have to try and use Samsung's warranty to see if they can fix the device.

  3. Bruce E
    March 8, 2014 at 12:30 pm

    I am assuming you have already read this post. I have seen this on other mobile devices (HP TouchPad, iPod Touch, etc.) and the fix has been the same. Don't bother trying to charge it from a computer. In most cases, the USB port won't provide enough juice to begin charging a fully discharged battery; only use the wall-wart. When you plug it in, do you get the battery charging indicator? If not, unplug it from the wall and wait for a few minutes. Plug it in again. Sometimes the initial surge you get when plugging it in is all that is required to get it charging which is why this normally will not work with USB as any spike you get is much smaller. This worked for both my TouchPad a couple of years ago and my dad's iPod Touch a couple of months ago. It took 3 tries to get the iPod to start charging, just once for the TouchPad.