How can I make my flash drive writable again?

Anonymous May 5, 2014
Ads by Google

I have a new 64 GB Corsair flash drive that stated in the spec’s that it was both Mac and PC compatible, so I used it on my Win 7 Pro 64-bit box for a while then I used it on my iMac to put a movie on. When I put it back in my Windows PC and tried to cut and paste the movie I got a box saying it was read only. I also found out that it had reformatted itself to exFAT or the iMac did it? I have tried everything from the net that I could find to change this, went into Command Prompt and tried to change the attributes and format it but everything keeps coming back Can’t Do – Read Only. Any and all help would be greatly appreciated.
Thank You

  1. Tim B
    May 9, 2014 at 12:40 am

    As the rest of the commenters have pointed out, exFAT is a great option because it is writeable by both operating systems – I wonder, does the drive have a physical switch which "locks" and prevents any data being added or deleted, as per SD cards?

    Worth a check, I've seen some weird things on USB drives in the past. Otherwise reformat with Disk Utility and try again on the Windows PC!

  2. Oron J
    May 5, 2014 at 5:14 pm

    Check the drive again on the Mac. Does it still work normally? If so, the problem is with the PC (see Hovsep's answer). If not, use Apple's Disk Utility to reformat the drive (ExFAT is fine) and try again. If the Mac is unable to reformat the drive, take it back to the shop, stuff happens, and the drive should be under warranty.

  3. Hovsep A
    May 5, 2014 at 3:55 pm

    try to uninstall the driver (do not delete) on Windows, then while the Usb key is plugged reboot

  4. Bruce E
    May 5, 2014 at 3:06 pm

    The part about the exFAT format of the drive is most likely irrelevant. Flash drives < 32 GB are frequently formatted as FAT32 out of the box and drives > 32 GB are generally formatted with exFAT for performance reasons. With either of these formats, the device would be Win & Mac compatible.

    Also, are we to understand that the Windows machine is complaining about the flash drive being read-only when trying to copy FROM the flash drive?